$69 Gemtek Gateway: The Things Indoor Gateway


(Jeff Uk) #167

That’s re-assuring :slight_smile: Guess compliance should be low risk given core design’s previous time in market! :wink:

Credit card at the ready… 4 development test sites already confirmed over weekend :grin:


(Stefan) #168

I had the same problem: Gateway did not appear as connected with fffe’d EUI in the console.

I have sent some test packets and suddenly saw that they were received by my IMST gateway (as expected) and another gateway, which must be really nearby (from RSSI) but has a completely different EUI. I then tried to register this EUI and it was immediately connected. I have now confirmed that this really is my TTN Indoor Gateway (by moving around and sending more test packets).

But the EUI is not related to the Wifi MAC at all:

  • my Wifi MAC starts with 68:c6:3a:…
  • my EUI that appears on Console and now works starts with 58:a0:cb:…

This tells me for my situation: EUI is not derived from the Wifi MAC. The Wifi MAC printed on the device is the same as show on my Unifi Access Points, so that’s consistent.

My suggestion: look at the packets you send and find out if another Gateway receives them nearby. This could be the EUI of your TTN indoor GW.
It seems the Gateways send data to TTN as soon as they have Internet connection, even without being registered within TTN console.


(Matthew Macdonald-Wallace) #169

We’re still testing it, but https://twitter.com/MBConsultingUK/status/1092004015087378432 should give you a rough idea.

We’re hoping to open up those graphs relatively soon so you can play with the data directly as well.


(Ud Lo Ra) #170

Thanks, I expect a different antenna will change the figures.


#171

I do not know that particular board, but usually Semtech put that kind of 0 ohm just to easily identify its frequency, the resistors are not connected. It seems to be the case here.


#172

How you measure the 4 sec ? And SDR ?


(Wjm Brok) #173

This is what I read from the gateway TTN console (the timestamps are listed there). I don’t understand your question about software defined radio.


#174

The best way to know when a packet is really sent is to use an SDR to know when it is going over the air :wink:


(Wjm Brok) #175

You mean, listen with an SDR to what the TIG actually sends?


(Arjan) #176

That’s correct. As stated in the FAQ above, emphasis mine:

image


(Nestor Ayuso) #177

inside pic here.

same desing, just change sx1301 for a sx1308 and saw filters for 868 or 915


#178

yes :slight_smile:


(Jeff Uk) #179

Besides the Sx130x the card you show has seperate SX1276 adding to the internal Sx130x LoRa modems for RX & internal Tx…I assume that is part of the LBT mechanism?! :wink:


(Pirakutu) #180

I also get the same behaviour -> traffic in only 3 channels (the default ones 868.1, .3 & .5)


(Wjm Brok) #181

… that sounds like a good idea, though it will cost me some time to find all the parts and put something together.

Alternatively, I was thinking to take my node elsewhere, have it join via another gateway, take it back home and see if I can send uplink messages to it via the TIG (that one being the only gateway within reach by then).


(Stefan) #182

Thanks! That confused me :wink:


(Meikelg) #183

I’ve tested mine yesterday and it worked with ttn. If you have 2 gateways in parallel this looses every third signal. If you use it alone, every signal will be received. I tested in very nearby installation. May be in longer distance you will loose signals due to the lesser channels. I will test that as well and inform.


(Meikelg) #184

if you are in config mode (pressed setup 10+ sec, light changes) you will see all relevant data:

Gateway EUI: 58-A0-AA-FF-FE-AA-AA-00
WiFi AP MAC: 58:A0:AA:AA:AA:00
WiFi AP Pass: xxxxxxxxx
WiFi STA MAC: AA:00:AA:00:AA:00
Serial Number: TBMH100868000943
MFG date: 2019-01-21 07:38:38
FW Build: 2018-12-06 09:30:37
FW Version: 2.0.0
Core Version: 2.0.0(minihub/debug)

take the Gateway EUI, but small letters without ‘-’. that should work. if not take with leading ‘eui-’.
after connecting to TTN your complete GW-EUI should look like:
eui-58a0aaffeaaaa00


(Arjan) #185

When checking “I’m using the legacy packet forwarder” I cannot prefix any “eui-” and also all letters are uppercased on the fly. So I guess you did not tick that checkbox?

Also, where are you seeing those details? Care to post a screenshot?

Step 3

Huh!?


(Arjan) #186

This scares me a bit: it seems somehow the gateway gets some credentials, even when a gateway is not claimed through TTN Console, which are used to fetch the configuration and all? I wonder what “requires resetting the credentials on the server side” means, and if that needs intervention from the TTN team.