Big ESP32 + SX127x topic part 3


(LoRaTracker) #132

Try it and see.


(Tavisg) #133

I have two Heltec Lora V2 boards and even though I’ve been having some intermittent consistency problems I’m excited today because I got successful 2 way data transmission at 12.4 miles distance. https://photos.app.goo.gl/UBVdm1aq75r3NRxHA


(Sandgroper) #134

Higher value resistors will not improve the current consumption in sleep as these lines are only floating. However, if you have these pull ups connected to the supply rail it means that the current consumption would be higher when the processor is not in sleep state.


(Eric VdB) #135

Have you tried this library: https://github.com/ngraziano/lmicesp32

Greetz,
Eric


(Tavisg) #136

Is anyone else having issues while using the Heltecs board for both rx and tx ? Whenever I use one of these boards to send and receive via LORA they seem to get stuck in RX mode or a TX mode ? A board will receive a “request” packet and then try to transmit a data packet. The packet seems to send but doesn’t actually send. If I reset the entire board then transmitting starts working again. I’ve tried resetting just the LoRa module but that doesn’t seem to help. When I set up the devices so that they only ever send or receive (but not both) then they work just fine with no hiccups. I’m currently using the radiohead library to operate the LoRa radios.


(LoRaTracker) #137

It does sound like an issue with the Radiohead library on ESP32, not sure if its 100% supported. You might find more users of that point to point LoRa library over in the Arduino forums.


(Tavisg) #138

I’m seeing the same problems with Heltec’s own library though so I don’t think it’s RadioHead.


(LoRaTracker) #139

If this is Heltecs LoRa point to point library, then users in this TTN forum may not have a lot of experience with that library or the Radiohead one.

Not heard of similar problems when using the ESP32 for TTN, but maybe I have just not been paying attention.


(Verkehrsrot) #140

Heltec’s “own” library is based on Radiohead lib.
And radiohead lib does not support LoRaWAN, neither checks DIO1 status pin of SX1276.

Use MCCI LMIC and get things up and running in less than 15 minutes.

But beware of other design flaws in the Heltec boards, esp. V1.

The 2,4 GHz RF circuit achieves poor results with paxcounter. Don’t know why.


(Dave Calway) #141

Hi everyone,
i bought the ESP32 Heltec v2 and followed the main guide.
I have found some problems:

//LMIC LoRa module pin configuration

//For ESP32 Heltec v2 use:
const lmic_pinmap lmic_pins = {
  .nss = 18,
  .rxtx = LMIC_UNUSED_PIN,
  .rst = 14,
  .dio = {/*dio0*/ 26, /*dio1*/ 35, /*dio2*/ 34}
};

To use the build in Oled the U8g2 library wants these pins:

U8X8_SSD1306_128X64_NONAME_SW_I2C display(/* clock=*/ 15, /* data=*/ 4, /* reset=*/ 16);

and yes, Software -SW- not Hardware -HW- .

I edited the ttn-abp/otaa example, from lmic library, adding the correct definitions for Oled pins and LoRa module for the ESP32 Heltec v2: https://goo.gl/hKL1mj

Plus if you uncomment #define DEBUG_OLED you can see the the Serial output on the Oled screen.

I hope that help someone!


(Arcos) #142

Pls can you help me, what is this component ?

56236113_797081660653824_7269526340854874112_n


(LoRaTracker) #143

Does not look like a component at all.

Maybe solder pads for attaching a ribbon cable for a display maybe.

Whats the board ?


(Elidee) #144

Looks like the pads for the oled display.IMG_0955IMG_0956


(Verkehrsrot) #145

It’s a printed on board capacitor acting as backup power source :clown_face:


(Arcos) #146

thank you for your answers


#147

It looks more like a touch slider control for adjusting the RF power. :nerd_face: :wink:


(Paul Stewart) #148

I have a TTgo V1 that the microUSB port has come off.

The fine pins are beyond my soldering capabilities, so is there any other way to communicate with the board eg through the RX/TX pins?

Cheers
Paul


(Arinze Izukanne) #149

Yes, it should be possible. According to the schematics, the RX/TX pins are connected to a CP2102 USB-UART bridge controller. If you have USB-UART module like this below you can connect to the ESP32.


(Paul Stewart) #150

Thanks, have since confirmed you can do it

For future reference of others, using RX, TX, GND and 3v3.

When using in Arduino, hit the upload button and wait till it compiles and starts to try and find a serial port, then hold down program, press reset briefly then let go of program.

Then the sketch should start uploading

Cheers
Paul


#151

Yes thanks, that is how a sketch should be ‘manually’ uploaded to the ESP32.
(The same sequence is used for the ESP8266.)

Almost any (breadboard-friendly) ESP32 board already has a USB to Serial adapter integrated on the board so most users never have to press the program and reset buttons sequence (not know about it).
(The integrated onboard USB to Serial adapter uses two transistors in combination with DTR and RTS signals to make uploading go automatically without having to press any buttons.)

Be aware of the 3.3V: When using the separate USB to Serial adapter with your ESP32 board never connect two power sources to the board at the same time. If the board is already powered by a different power source (e.g. a battery or power supply connected to a breadboard) then you should NOT connect the 3.3V power line from the USB to Serial adapter to the board at the same time.
(When normally using the USB connector to both power and program the board this is less/not an issue because power from the USB is normally protected with a diode that prevent reverse currents to the USB port if you have also powered it on the 3.3V pin. But when you power it via the USB to Serial adapter that security measure is not present.)

(Also note that certain CP2102 based boards have a bug where they can output near 5V instead of 3.3V (on the 3.3V line). There also exist CH340 based USB to Serial adapters that you can switch between 5V and 3.3V output but (totally unexpected!) the Rx and Tx signals levels always stay at 5V.
To prevent possibly damage, it is best to measure the output supply voltage(s) and signal level voltages of your (Chinese) USB to Serial adapter before blindly trusting it’s advertised specifications.)