Cannot send data from my Adafruit LoRa Radio Bonnet to my LoRa LG01-P gateway even though it says the gateway is connected on the things network

I have my Adafruit LoRa Radio Bonnet connected to my Raspberry Pi 3 and I am using Raspbian as my computer operating system. I am using the and and code from the adafruit website.

This worked when I was connected to my colleagues indoor LoRa gateway but when I got to my apartment and tried it here, it did not work. My LoRa gateway is connected to thethingsnetwork. I am do not know how to solve this issue. Any suggestions?

You don’t have a LoRaWAN gateway. The LG01 is actually a LoRa node attempting to do a bad job of impersonating, let’s say about 1/24th of what a LoRaWAN gateway does in practice.

Likely the 1/24 or so of what a LoRaWAN Gateway is supposed to do that your LG01 is attempting to impersonate is not the same that your LoRaWAN node is attempting to use.

For this to work at all you’d have to hard code your node to use only the particular frequency and spreading factor the LG01 is set to support, instead of dynamically choosing in the way that a LoRaWAN node is supposed to.

Trying to use a node class device like the LG01 in the gateway role is highly dis-recommended.

1 Like

What would you recommend? Is there another node class device that would work close to 100% of the time?

I cannot see how a node type devcie could act as a proper compliant LoRaWAN Gateway.

1 Like

Not as a gateway, no.

You can alter the firmware of your actual node so that it only uses the air settings supported by your node-pretending-to-be-a-gateway. But then it won’t really be behaving as a proper LoRaWAN node any more, and the presence of your mostly dysfunctional “fakeway” may lead to misoperation of other TTN nodes if a momentary overlap with its settings leads ADR algorithms to mistakenly assume those nodes are close to an actual gateway.