Configuring TTN Australian frequency plan for arduino leonardo


#1

Hello everyone!

I am just getting started with LoraWAN using the bundle kit by meshed.com.au (http://meshed.com.au/product/arduino-with-shield-and-mdot-lorawan-module/) I have been following the tutorial on the the things network website on how to get the device activated(OTAA) after registering it online. I have included the TheThingsNetwork.h file in my arduino sketch, but the example "Send" that comes with the TheThingsNetwork library only supports the EU868 and US915 frequencies.

When I run the above code with the US915, it compiles but doesn't give me any output.

I have had a look at the library C++ Source file and the Header file, they only have functions for the EU898 and US915 frequencies and nothing for AU915.

So is there a library that supports/handles the Australian frequency that has been already written by someone else? or am I missing something that can allow the usage of US915 to work in Australia? How are the others working around this problem?


(Andrew Maggio) #2

Hi @AidanEBS, that library only supports the Microchip LoRaWAN modules (RN2xxx) and there is no Australian firmware available for those modules yet (currently in Beta). US915 modules won't work in Australia either as the firmware is locked to the US LoRaWAN channel plan.

The module supplied as part of the bundle is a Multitech mDot. I haven't seen an Arduino library for an mDot yet, but maybe someone here knows of one - or wants to write one :slight_smile:


#3

Hi @maj,

Thanks for the reply. I found out that for the setup that I have got(Multitech Mdot. Arduino Leonardo and the xbee sheild), I can use the following code

void setup()
{
Serial.begin(115200);
Serial1.begin(115200);
}

void loop()
{
if (Serial.available()) Serial1.write(Serial.read());
if (Serial1.available()) Serial.write(Serial1.read());
}

and send the following AT commands to get started.

at+pn=1
at+njm=1
at+fsb=2
at+ack=0
at+ni=0,your_app_id
at+nk=0,your_app_key
at+join
at+send=HelloWorld

but I am not very sure how I send these commands to the Arduino, I've tried entering them on the serial monitor. but nothing happens. Is there anything That I need to change in the above Arduino sketch? Or is there any other way to send the AT commands to the arduino leonardo?

Thanks.


(Andrew Maggio) #4

That should work fine. Make sure your terminal is set to the correct speed and the shield is set to UART.


#5

I have tried what you have described in your previous comment, but I am still not getting anything.

The correct board and port are chosen, the UART is selected on the shield and the given code is uploaded and the at+pn= 1 command is sent but nothing is received on the console at BAUD rate 115200.

Is there anything else that I am not doing? how close to the gateway should I be to test the lorawan module? or does that matter at all?


#6

Hi again,

I have also tired uploading the code to the arduino using an older version of arduino to make sure this is not a problem with the version of arduino, but it still doesn't work.


(Jervisben) #7

Hi Aidan,

I don't know if this is still an issue you're having, but I was having similar trouble with getting nothing back from the module. The issue ended up being that I didn't have my console configured correctly.

When I used the settings in maj's gif (Both NL & CR, 115200) for those two drop downs in the bottom right corner, I started getting responses from the device

Hope this helps