Connection to TTN host


#1

I built a single channel gateway w/ Dragino LoRa/GPS Gateway & Raspberry Pi 3. I got connection via IP address "40.114.249.243". After some changes on the node side I get no connection again.
I tried the address "router.eu.thethings.network" too but w/o success.
The gateway itself seems to be in operation because I get messages like:
...
stat update: {"stat":{"time":"2016-12-11 08:01:50 GMT","lati":47.18964,"long":8.82922,"alti":405,"rxnb":0,"rxok":0,"rxfw":0,"ackr":0.0,"dwnb":0,"txnb":0,"pfrm":"Single Channel Gateway","mail":"info@ckuehnel.ch","desc":"LoRaWAN Gateway Evaluation"}}
Packet RSSI: -34, RSSI: -98, SNR: 9, Length: 23
rxpk update: {"rxpk":[{"tmst":1731596724,"chan":0,"rfch":0,"freq":868.100000,"stat":1,"modu":"LORA","datr":"SF7BW125","codr":"4/5","lsnr":9,"rssi":-34,"size":23,"data":"QGAXPvuA4AEB2lpdP/3qZs2yPvGpWCI="}]}
stat update: {"stat":{"time":"2016-12-11 08:02:20 GMT","lati":47.18964,"long":8.82922,"alti":405,"rxnb":1,"rxok":1,"rxfw":0,"ackr":0.0,"dwnb":0,"txnb":0,"pfrm":"Single Channel Gateway","mail":"info@ckuehnel.ch","desc":"LoRaWAN Gateway Evaluation"}}
...
What can I do?
Claus


#2

Same problem here :frowning:
https://www.thethingsnetwork.org/forum/t/single-channel-gateway-how-to-check-communication-to-ttn/4386/3

Yesterday, I checked my "Dragino R.Pi Hat single channel Gateway" and I didn't see any messages in the TTN dashboard.
This all used to work fine before, so something must have changed recently ?!?

Does anyone else have communication problems with their "single channel gateway"?
Or even better, can anyone confirm that they have a working "Dragino R.Pi Hat single channel Gateway" ?


#3

Confirmed. My SCG receives packets from my node but doesn't successfully forward to TTN. This is a change in behavior which a friend of mine pegged at starting to around 14:00 PST on December 10 when his packets too stopped being forwarded. Seems there has been a change in the TTN cloud.


#4

Since this morning my LoRa messages are forwarded again. I do not know what happend. Any hints for that from TTH?


#5

Can you confirm the IP you are using that is working? I used two different ones and both don't work as of yet.


Single Channel Gateway, how to check Communication to TTN
#6

I use

#define SERVER1 "40.114.249.243" // router.eu.thethings.network

#7

Thanks CKUEHNEL,
Using that IP in the script got it working again (with R.Pi.+ Dragino GPS hat shield)
update 20/12/12 - use "router.eu.thethings.network"

Edit file main.cpp, type: sudo nano main.cpp and change the server line to point to the correct server as follows:

define SERVER1 "router.eu.thethings.network"

Hopefully this helps others - This is what I now see for ABP nodes (updated)
N.B. the order of the "Keys" are DEVADDR,NWKSKEY,APPSKEY)
* My "RN2483" node using library "TheThingsNetwork.h" works OK (HEX,HEX,HEX using latest version 12/12/16) .
* My "RN2483" node using library "TheThingsUno.h" works OK (MSB,MSB,MSB).
* My "Dragino shield" node using library "lmic.h" works OK (HEX,MSB,MSB)
* My "Dragino single channel gateway (R.Pi)" is now being found OK in https://staging.thethingsnetwork.org/gatewaystatus/ (probably because I managed to get something posted ! )
* When I look at my gateway using https://www.thethingsnetwork.org/api/v0/gateways/XXXXXXXXX I get message saying "error": "Cannot connect to database!"

N.B. This site is very useful for instructions
http://www.mobilefish.com/developer/lorawan/lorawan_quickguide_build_lora_gateway.html
The instructions on how to change are:

  • Open a terminal on your Raspberry Pi.
  • Goto the directory, type: cd lorawan_gateway
  • Goto the sub directory, type: cd single_chan_pkt_fwd
  • Edit file main.cpp, type: sudo nano main.cpp and change the "server1" line to point to the correct server as follows:
    #define SERVER1 "router.eu.thethings.network"
  • Write the changes to file, type: CTRL+O, and then press "enter" to confirm changes
  • Exit the file: CTRL+X
  • Whilst in sub-directory "single_chan_pkt_fwd", compile the code by typing: make to replace the executable file called single_chan_pkt_fwd
  • Execute this changed executable file!

Updated 20/12/12 to use a better IP address (for the production environment)


New gateway - active but not authenticated
(Arjan) #8

For me, router.eu.thethings.network resolves to bridge.eu.thethings.network, being 52.169.76.203 today...

$ dig router.eu.thethings.network
...
router.eu.thethings.network. 3454 IN	CNAME	bridge.eu.thethings.network.
bridge.eu.thethings.network. 3454 IN	A	52.169.76.203

Launching Production Environment
#9

I used the numbers directly.


(Hb9leb) #10

Both IP's:
40.114.249.243 and 52.169.76.203 are working for me in Switzerland.
My configuration looks like:
...

define SERVER1 "40.114.249.243"

define SERVER2 "52.169.76.203"

in main.ccp file of the project:

My configuration is a single channel gateway Raspi + RFM95W.


(Ahmed Elzanaty) #11

I have tried to ping both "40.114.249.243" and "52.169.76.203" for windows 10 running pc, but both of them gave me "request time out". I will be grateful If you can help me. I am trying to connect my "Microchip Gateway Core and Radio" to the TTN, as a first step, I tried to ping them before connecting the Gateway.


(Arjan) #12

You won't get a response to pings:


(Nordthings) #13

My gateway stopped showing up in my TTN console 2 days ago. After trying all the different ip's in this thread including the dns name I finally got it showing activity using "40.114.249.243".


#14

Hi,

When I use the single_chan_pkt_fwd in rPi and Dragino LoRa schield 1.3 I have to send messages for 5 minutes to get 1 message a TTN. I saw that it is possible to get message every 20 second. How? I use this ip:
40.114.249.243

Thanks


(Henda) #15

Good morning , yesterday , i delted my gateway and reconfugired a new one but i still have the same problem , can any one help me please :confused: it's for my final study project and

thanks


(Diego Hinojosa Cordova) #16

Hi, You made sure the poly_pkt_fwd in the gateway well configured? What is your gateway?


(Henda) #17

hi,it worked .. thanks just i changed the IP address to 40.114.249.243, but now i tried and i don't have any result!!!


(Nordthings) #18

continue to have problem getting my dragino 1.4 single channel gateway connected.
I have SERVER1 "40.114.249.243" and SERVER2 "52.169.76.203"
Will now try using dns instead: SERVER1 "router.eu.thethings.network"
to see if I am more lucky with this today..