DRAGINO problems and solutions topic part 1

What your looking for is here, and probably a couple other places in the multiple Dragino or LMIC related posts. Make sure you know what version of the LMIC library you are using before figuring out which set of code you should use.

I am total beginner to LoRaWAN and networks in general, but I was given a task to deploy a LoRa network using the Dragino LoRa Kit. The build I am using is as follows: Gateway is the LG01-P model (915Mhz), and my node is Arduino Uno + Dragino LoRa shield + SR04 sensor.
I have successfully established uplink communication from node to TTN, and I can view all the traffic. Now, my next step is to figure out how to do downlink…

I am simulating downlink messages from the TTN console, and I can see that the payload is scheduled, then delivered. Also, the console output from the Dragino gateway itself shows that the downlink message was indeed received, and forwarded (if I am not mistaken) but I get nothing in my node’s log.
I tried to confirm if the packet forwarding code used supports downlink and I found this in Github - Gateway Packet Forwarding Code - and it seems to support downlink.
Device activation mechanism used is ABP.

These images show what I meant above –

Gateway Console

TTN Device Data

TTN Gateway Traffic

My question is --> How do I successfully relay downlink messages to my node? I am not sure where to look exactly.

Thanks in advance.

Hi everyone,
I’m just trying to get started by setting up an Dragino LG01 Gateway and a RPI3 + Dragino LoRA Hat v1.4 - connected to TTN. But it isn’t working.

So far I have my LG01 gateway set up and appearing as connected in TTN. I have the latest single_pkt_fwd_v004 for the MCU installed and the firmware IoT 4.3.4

My Node is also set up and I’ve been getting successful packet transmissions via TX messages in the console (I think) - inbetween intermittent Radio failure 630 messages.

I am using the examples provided by Dragino using ‘thethingsnetwork-send-v1.cpp’

The problem is that my Gateway is not showing any data in the Sensor>Data and neither is any data forwarding through to reach the TTN.

I have modified and checked all the various dev address/EUI settings so I am confident these settings are all correct.

Here’s what I’m not so sure about:

  1. Where are the settings for spreading factor, transmit spreading factor, coding rate, bandwith and preamble set for the node?
  2. As I’m in Europe I have the transmit and receive frequency both set at 86810000. Where do I set this in the node
  3. Finally, where do I set that it’s operating as a single channel?

Here’s hoping someone can help! There are so many posts it is difficult to know what is current!

Thanks in advance.

try search ?

Thanks. Most helpful.

Your welcome and new here… So I can tell you that you’re not the first one with the same questions/dragino-problems. :wink:

I am also doing almost exactly the same thing, LG01 gateway, rPi 3 and the lora/gps hat. Initially I couldn’t even get the gateway to show up as connected in The Things Network console. I had to SSH to it and manually run lp01_pkt_fwd and then it finally showed connected, but I still don’t see any packets coming through.


so it’s a dragino firmware problem ?

I can’t say for sure, but in my case it seems like something is wrong with the firmware. I see no output in the logs about it trying to start the tool or anything from the packet forwarder at all actually. I have only gotten as far as getting the gateway to show up on the TTN console as “connected”. I’m presently working on assembling / coding a working client device but that has exposed some other problems on my end that I’m working to solve so it will take a while before I am ready to try actually getting lora packets through the gateway.

When setting up my LG01 I did follow the guide on their wiki and was not successful.

Hello, i bought a Dragino lora/gps hat for raspberri, and followthis instruction to set up LoRa single channel gateway, but in ttn status all the time NOT CONNECTED, i tried different servers ip, but still nothing. Tried to send some information from Nedes ir terminal write what getting information. Maybe somebody know where are problem?

are you sure you are using the right instructions for the dragino gps hat ?

The official instructions are here: http://wiki.dragino.com/index.php?title=Connect_to_TTN (look for LORA GPS Hat).
There are a couple of forks from the suggested software that are easier to use (e.g., configuration through a file without recompiling), but the substance is the same.

I did a gateway with Dragino and RPI and Dual_chan_pkt_ fwd.
But I don’t undestander, why the downlink is sented 14s after that received the uplink?. My node never recived downlink because the windows RX1 & RX2 are closed when downlink arrive.

ago 25 17:43:43 raspberrypi dual_chan_pkt_fwd[952]: CE0 Packet RSSI: -34, RSSI: -94, SNR: 9, Length: 14 Message:rxpk update: {“rxpk”:[{“tmst”:2353347751,“freq”:916.8,“chan”:0,“rfch”:0,“stat”:1,“modu”:“LORA”,“datr”:“SF7BW125”,“codr”:“4/5”,“rssi”:-34,“lsnr”:9.0,“size”:14,“data”:“QCMpACaACQABPh0dTm0=”}]}
ago 25 17:43:43 raspberrypi dual_chan_pkt_fwd[952]: Sending message to server:
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: Waiting for incoming server packets…
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: {“txpk”:{“imme”:false,“tmst”:2354347751,“freq”:923.3,“rfch”:0,“powe”:20,“modu”:“LORA”,“datr”:“SF7BW500”,“codr”:“4/5”,“ipol”:true,“size”:14,“ncrc”:true,“data”:“YCMpACaAHwAByOAH4go=”}}Sending frequency from server package: 923.299988
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: data: YCMpACaAHwAByOAH4go=txLoraModem:: powe: 20, freq: 923300000, crc: 0, iiq: 0X64Not 0
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: setFreq CE1 using: 923300000
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: setPow: CE: 1, powe: 15
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: Sending to LoRa node: 96:35:41:0:38:128:31:0:1:200:224:7:226:10:
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: start: -1940820058, end: -1940619545, waited: 200513, delay=0
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: Send TX done.
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: setFreq CE0 using: 916800000
ago 25 17:43:57 raspberrypi dual_chan_pkt_fwd[952]: Sending packet:: tmst=-1940619545, wait= 819117927, strict=0, datr=SF7BW500, freq=916800000->923300000, sf=7->7, modu=LORA, powe=20, codr=4/5, ipol=1, through CE1.

HELP!!! And thanks!!!

I’d say that the problem is in these lines:

It seems it takes far too long to send the data, or starts to “wait” for incoming messages too late? As for why: I don’t know. Maybe it’s related to problems I am seeing at this very moment for a TTN Gateway in the EU region:

11:45 PM LORA: TXPKT failed, too late! tx: 578411324 rx: 595342588
11:47 PM LORA: TXPKT failed, too late! tx: 698416676 rx: 702129451

I’m seeing those every now and then, but it seems it’s never a whopping 13 seconds late.

(The value for "tmst":2354347751 shows that TTN wanted to use RX1, which is 1,000,000 microseconds after the value for "tmst":2353347751 in the uplink.)

How do you manged to flash the MCU? I’m not able to flash any of the available versions from http://www.dragino.com/downloads/index.php?dir=motherboards/lg01/sketch/ via the WebGUI. The flash operation shows no error, so i think the flashing was successful but after the LG01 reboot there is no MCU version shown (like in http://wiki.dragino.com/index.php?title=Connect_to_TTN#Upload_Arduino_Sketch_to_LG01_Linux_System). I’m using the latest firmware (IoT 4.3.4 http://www.dragino.com/downloads/index.php?dir=motherboards/ms14/Firmware/IoT/IoT--build-v4.3.4-20180507-1426/&file=dragino-IoT--v4.3.4-squashfs-sysupgrade.bin) too…

1 Like

DRAGINO support

I have the same as you - I just assumed it was successful. I am using the same versions as you too.

I am using Dragino LoRa Single Channel Gateway LG01. I have registered one gateway earlier on 24.08.2018 and in that data was receiving at Gateway as well as in Application side. But Now I am trying to register one more gateway in my account. It was registered but always showing status as not connected. Even I tried with new login with all same settings which i did for my first gateway but it shows status not connected. May i know what is the problem?


i have been to connect before but when i run the gateway again why i can’t to connect it what happenedM

I’m getting the error ‘Wrong data’ for send_gps_data command with Dragino LG01 gateway. Here is the PuTTY console.

I’m using the up-to-date gpstrack package. The server IP for GPSWOX is (USA) .

Please help me to solve this issue. Thanks.