DRAGINO problems and solutions topic


(Valbuz) #107

hi Mat
thanks for reply.
i use ABP.
i will check this with “frame counter”, but i think that was the problem( hope so :slight_smile: )

valbi


(K5at) #110

I am running a Draguino Shield with an Arduino Uno. I have had this running for several days now, but somehow I’ve changed something. Now when I run it i get the following message on the local terminal.
FAILURE /Users/herbblair/Documents/Arduino/libraries/IBM_LMIC_framework/src/lmic/radio.c:328
Any ideas on what’s going on?


#111

do you have the library still installed ?


(K5at) #112

Yes, I have it installed.


#113

there is a lot of info to find… and we can’t guess what you have changed.
jumpers changed ? … added a new sensor ? added conflicting library’s / timers


(K5at) #114

I think I add a conflicting library, but tried to go back and remove all that I could remember, I even recovered from my backup drive all of the arduino folder prior to having the problem.


#115

after reading THIS you can post your full code here So other users can have a peek too.

and explain what you are trying to achieve.


(K5at) #116

I’ve resolved this issue, but now would like to set a single frequency (as before), but I’ve forgot how to do it.
Thanks,


(Glbaum) #117

What your looking for is here, and probably a couple other places in the multiple Dragino or LMIC related posts. Make sure you know what version of the LMIC library you are using before figuring out which set of code you should use.


(Memeos135) #118

Hello,
I am total beginner to LoRaWAN and networks in general, but I was given a task to deploy a LoRa network using the Dragino LoRa Kit. The build I am using is as follows: Gateway is the LG01-P model (915Mhz), and my node is Arduino Uno + Dragino LoRa shield + SR04 sensor.
I have successfully established uplink communication from node to TTN, and I can view all the traffic. Now, my next step is to figure out how to do downlink…

I am simulating downlink messages from the TTN console, and I can see that the payload is scheduled, then delivered. Also, the console output from the Dragino gateway itself shows that the downlink message was indeed received, and forwarded (if I am not mistaken) but I get nothing in my node’s log.
I tried to confirm if the packet forwarding code used supports downlink and I found this in Github - Gateway Packet Forwarding Code - and it seems to support downlink.
Device activation mechanism used is ABP.

These images show what I meant above –

Gateway Console
35

TTN Device Data
05

TTN Gateway Traffic
09

My question is --> How do I successfully relay downlink messages to my node? I am not sure where to look exactly.

Thanks in advance.


(Johnny English) #121

Hi everyone,
I’m just trying to get started by setting up an Dragino LG01 Gateway and a RPI3 + Dragino LoRA Hat v1.4 - connected to TTN. But it isn’t working.

So far I have my LG01 gateway set up and appearing as connected in TTN. I have the latest single_pkt_fwd_v004 for the MCU installed and the firmware IoT 4.3.4

My Node is also set up and I’ve been getting successful packet transmissions via TX messages in the console (I think) - inbetween intermittent Radio failure 630 messages.

I am using the examples provided by Dragino using ‘thethingsnetwork-send-v1.cpp’

The problem is that my Gateway is not showing any data in the Sensor>Data and neither is any data forwarding through to reach the TTN.

I have modified and checked all the various dev address/EUI settings so I am confident these settings are all correct.

Here’s what I’m not so sure about:

  1. Where are the settings for spreading factor, transmit spreading factor, coding rate, bandwith and preamble set for the node?
  2. As I’m in Europe I have the transmit and receive frequency both set at 86810000. Where do I set this in the node
  3. Finally, where do I set that it’s operating as a single channel?

Here’s hoping someone can help! There are so many posts it is difficult to know what is current!

Thanks in advance.


#122

try search ?


(Johnny English) #123

Thanks. Most helpful.


#124

Your welcome and new here… So I can tell you that you’re not the first one with the same questions/dragino-problems. :wink:


(Ctrowat) #125

I am also doing almost exactly the same thing, LG01 gateway, rPi 3 and the lora/gps hat. Initially I couldn’t even get the gateway to show up as connected in The Things Network console. I had to SSH to it and manually run lp01_pkt_fwd and then it finally showed connected, but I still don’t see any packets coming through.


#126

so it’s a dragino firmware problem ?


(Ctrowat) #127

I can’t say for sure, but in my case it seems like something is wrong with the firmware. I see no output in the logs about it trying to start the tool or anything from the packet forwarder at all actually. I have only gotten as far as getting the gateway to show up on the TTN console as “connected”. I’m presently working on assembling / coding a working client device but that has exposed some other problems on my end that I’m working to solve so it will take a while before I am ready to try actually getting lora packets through the gateway.

When setting up my LG01 I did follow the guide on their wiki and was not successful.


(Meshla) #128

Hello, i bought a Dragino lora/gps hat for raspberri, and followthis instruction to set up LoRa single channel gateway, but in ttn status all the time NOT CONNECTED, i tried different servers ip, but still nothing. Tried to send some information from Nedes ir terminal write what getting information. Maybe somebody know where are problem?


#129

are you sure you are using the right instructions for the dragino gps hat ?


(Ud Lo Ra) #130

The official instructions are here: http://wiki.dragino.com/index.php?title=Connect_to_TTN (look for LORA GPS Hat).
There are a couple of forks from the suggested software that are easier to use (e.g., configuration through a file without recompiling), but the substance is the same.