ELSYS LoRa® ERS / ERS-lite

I can’t see traffic on my gateway. I’m assuming that the devices are not connecting.
I’m using a TTN gateway configured with AU band 915Mhz. I have other devices working but with this one I really don’t know how to troubleshoot it.
I triple check DEVEUI/APPKEY/APPEUI are the correct ones.
Just confirming that is not a ERS-Lite is a ELT-Lite (should be the same procedure/configuration).

Hello all, has anyone successed the connection to TTN via gateway configured for AS923? I have tried Multitech Conduit and Dragino LG01 as packet forwarder, but failed.

I believe SplPer is in seconds, as it’s also configurable in seconds via the app, and the configuration value stored in the NFC tag is also in seconds.

Not sure about SendPer yet. On the ERS with CO2 sensor that I just checked (a rev E with firmware 2.2.4), the SendPer and several other *Per multipliers are all set to 1. I assume they just /are/ multipliers.

1 Like

To turn Confirmed Messages off remotely - 3E030A00FE - to Port 6

SplPer (example 1800 seconds) - 3E061400000708FE - to Port 6

They have a nice generator on their site.

Always apply the reboot… I learnt a hard lesson there.haha


When I follow your guide with my Elsys sensor it does not respond.
It keeps sending at the old interval.

Any idea why this happens?

Did you see the sensor reboot afterwards? How far away from the gateway is it?

No reboot.

There are 3 gateways in reach, with RSSI -118,-87,-60.
The time on air is only 62ms.

I send ‘3E061400000708FE’ to port 6, scheduling: replace, Confirmed not selected.

To confirm these are the ERS-lites? How strange.

I’ll send the command to one of ours now, and show you the traffic.

I am working with ELT-2’s.
The downlink payload format is the same for all models.


This is what happens with ours. As you can see the device reboots and re-joins afterwards.

Hmmm, interesting - looks like my ERS sensors (ERSgrid / ERSeye) also don’t accept config changes over LoRaWAN.

I tried to reconfigure the SplPer and SendPer with a downlink message to port 6 (including a reboot command, payload created with Elsys downlink generator) but no reboot seen and sensor stays at the old sample & transmit periods.

Last test was against a sensor running firmware 2.2.7. I also tried a confirmed downlink; after that one, the sensor was lost completely, so I’ll have to go out and try to fix it on-site.

When I manually send a downlink message to my Elsys ELT2 through TTN it almost never works.
However, when I send a downlink message through AWS IoT Core MQTT client with the options:

  "port": 6,
  "confirmed": false,
  "payload_raw": "AQIDBA=="

‘confirmed’ = false it always works.
It seems like TTN will always send downlink messages as confirmed even when you have not selected the option.


Never run into any of these problems - configured many an Elsys and Zane products over the air with no issues.

Are your gateways 100% transmitting the packet?

Hi, I am using a Raspberry Pi with IMST iC880A and trying to connect Elsysy ERS into the network. I am using the semtech gateway and packet forwarder.
ABP mode is working as expected but in OTA mode its failing to complete the join processs.
In gateway logs I am getting the uplink message(join request) from the End node and also the downlink message(join complete) from network server, But Again I am getting the join request from End node.
Is any logs I will get in Elsys ERS to check whether its getting the downlink messages or not??? And how to check that logs??? is there any another way to debug on node side???

Strange. We are using a MatchX Gateway, and also at home I have a Tektelic. Never ran into any issues at all with the Elsys. OTAA works perfectly. All I can think is something is off in your global_config.

… Come to think of it - how far is the node from the gateway? Sometimes if they are too close you can run into issues.

What behaviour did you experience when the node was too close to the gateway?

It would receive a packet on multiple channels simultaneously… And OTAA seemed to take a few transmissions to settle. This was about 5m distance.

I am having a similar problem, downlink message are not doing anything. Whats strange is if I hard reboot the node then the message seems to get processed when the node comes up. Its very annoying so wondering if anyone ever figured out whats happening. I have other nodes where the Downlinks work just fine.

Solved the downlink issue by always issuing a reboot in the commande.

But so sad to report that I am having a terrible support experience with these guys. I bought a sensor direct from them which is supposed to work with a Maxbotix MB7360 and I have tried for days to make it work, but it does not. This should have been straight forward, they provide a wiring diagram and NFC based setup tool.

Their support replies like once every 3 days so I have been waiting like a week now for some answers and still nothing. Sent a reminder email 2 days ago and no answer :frowning:

1 Like

In their configuration app there are two different MaxBotix sensors you can select when configuring the external input. Did you try both options?
If both options don’t work you can connect the MaxBotix sensor as analog input en read the data that way.