Gateway already registered

Hi Team,

greeting and Good day,

I recently deleted my RAK Wireless (RAK-7249) LoRaWAN Gateway from the legacy console.
I am creating the same gateway on v3, however while registering the gateway, i encountered the error message as listed below.

I believed related data needs to be purged from the legacy system. can someone please advise how to complete the Gateway registration process on v3.

A gateway with EUI AC1F09FFFE014970 is already registered as ac1f09fffe014970

{
“code”: 6,
“message”: “error:pkg/identityserver:gateway_eui_taken (a gateway with EUI AC1F09FFFE014970 is already registered as ac1f09fffe014970)”,
“details”: [
{
@type”: “type.googleapis.com/ttn.lorawan.v3.ErrorDetails”,
“namespace”: “pkg/identityserver”,
“name”: “gateway_eui_taken”,
“message_format”: "a gateway with EUI {gateway_eui} is already registered as {gateway_id}",
“attributes”: {
“gateway_eui”: “AC1F09FFFE014970”,
“gateway_id”: “ac1f09fffe014970”
},
“correlation_id”: “2f596b5efe3e4f20af1c3b4bca503ab7”,
“code”: 6
}
],
“request_details”: {
“url”: “/users/avishek/gateways”,
“method”: “post”,
“request_id”: “4508a99e-0218-4825-a5a7-f663cf7c544e”,
“stack_component”: “is”
}
}

Many thanks,
Best Regards,

Dear @Avishek – do you use the same Gateway_ID in v3 as used before in v2 ? Yes – you did … And that will not work as spoken many times about here … so there is no Error at all, as deleted Gateway_IDs will not be purged out of the system. Can you register a new Gateway in v3 but with different ID ? I guess this will work well …

It looks like @rez20004 already registered a gateway with that EUI.

@rez20004 please double check that you really own a gateway with EUI AC1F09FFFE014970 and if you registered it by mistake, please delete it so that @Avishek can register theirs.

Hello Jensileinchen,

Thanks for your swift response, Yes I am using the same gateway_ID on V3.

So basically, the Gateway_ID is supposed to be globally unique being MAC address which is embedded in the Gateway itself if not mistaken, adding FFFE between the 3rd and 4th position of the MAC address to make it EUI.

We are not supposed to change the Gateway_ID on the Gateway itself or even the console “Correct me if I am wrong”. otherwise if we can by mistake register someone else Gateway_id…

Many thanks,

Hi Hyle,

trust you are doing good and thanks for your swift response.

Infact, this is a RAK7249 Gateway having EUI AC1F09FFFE014970 and the owner is me and you can clearly see from the logs, but i have a question, how come this Gateway-ID is under Rez20004 account?.

“request_details”: {
“url”: “/users/avishek/gateways”,
“method”: “post”,
“request_id”: “4508a99e-0218-4825-a5a7-f663cf7c544e”,
“stack_component”: “is”
}

@rez20004 grateful if you could please release/deprovision EUI from your side.

Many thanks again for your help.
Best Regards,

As I understand it the EUI is considered immutable (often derived from MAC add as you say - ok some GW’s allow a reprogramming of EUI as well but thats a complication here) and the EUI identifies GW to LNS for registration and data exchange, but Gateway-ID is a ‘label’ and can be anything you like or that is convenient (as long as using right character limits) but should not be too obvious as others in same cluster may use same name - ‘mygateway’ likley to be picked by others - hence you get error saying GW ID already in use. e.g. I could go for ‘jeffs-brilliant-ttn-gw’, but another Jeff might choose same (ok unlikely) before me but then I could use ‘jeffs-brilliant-ttn-gw2’ and be ok (assuming another Jeff has’t… you get my drift) in many cases I’ve seen people adopt the eui for ID also (as in this case) but given that is just a convenient label it could be finger trouble and a mis-type of id from similar model leads to situation like this with same GW ID under different account… just thinking… or there could be situations of prior ownership/registration, mischievous claiming (seen recently in Greece?) etc.

1 Like

Hi Jeff and all,

Greetings and Good day, trust you all are doing good.

Yes, I followed the provided steps as stated above, its all working fine now…
Thanks a lot for your help and guidance.

image

Best Regards,

No. The system cannot delete the ID. I have experienced the same issue.

ID is not EUI. So which one are you referring to? This topic is about someone (accidentally?) using the EUI of someone else’s gateway.

I’m also having the same problem has anyone managed to solve the problem?

Submit failed
Gateway with EUI B827EBFFFF6F704E already exists and is not authorized for claiming

arrow_drop_upHide details

{
“code”: 9,
“message”: “error:pkg/deviceclaimingserver:gateway_not_authorized (gateway with EUI B827EBFFFF6F704E already exists and is not authorized for claiming)”,
“details”: [
{
@type”: “type.googleapis.com/ttn.lorawan.v3.ErrorDetails”,
“namespace”: “pkg/deviceclaimingserver”,
“name”: “gateway_not_authorized”,
“message_format”: “gateway with EUI {gateway_eui} already exists and is not authorized for claiming”,
“attributes”: {
“gateway_eui”: “B827EBFFFF6F704E”
},
“correlation_id”: “e6656341890c4d6aaccab2401db3cb78”,
“code”: 9
}
]
}

You’ll see the every post on this forum is in English - native, 2nd language or via Google Translate. This will be fine, we understand, but further posts should be in English please.

Formatted post as per guidelines

By consensus the Forum is English Language please - even if dual language posted or e.g. Google Translate used for conversion if not proficient enough…

This looks like a RPi based GW - and should be registered vs claimed…

First I apologize because I’m using google translator to make this communication.
I’m having problems recovering my gateway, I’m a student so I made a gateway with raspberry, but I left it idle for a while and now when I tried to register it again, I couldn’t because it says I already have a gateway with this EUI (B8:27 :EB:FF:FF:6F:70:4E), so far so good because that’s what I’ve done in the past, but now I can’t recover it or erase it so I can use it again

If left idle vs being deleted then yes it will still be there… on V2 as indicated by

{"id":"eui-b827ebffff6f704e","frequency_plan":"US_902_928","public_rights":["gateway:location","gateway:owner","gateway:status"],"frequency_plan_url":"https://account.thethingsnetwork.org/api/v2/frequency-plans/US_902_928","location_public":true,"status_public":true,"owner_public":true,"attributes":{"antenna_model":"DIY antena","model":"Dragino Lora Sheield v1.1","brand":"Single-channel DIY gateway","description":"Respberry LoraWAN","placement":"indoor"},"router":{"id":"ttn-router-brazil"},"fallback_routers":[],"antenna_location":{"altitude":900,"latitude":-3.99966267,"longitude":-40.86497771},"location":{"lng":-40.86497771,"lat":-3.99966267,"longitude":-40.86497771,"latitude":-3.99966267},"altitude":900,"owner":{"id":"6064c6544c09ca00317c47f9","username":"Mateus_Cordeiro"}}

But most important within this old V2 account info is the block of text:-

model":“Dragino Lora Sheield v1.1”,“brand”:"Single-channel DIY gateway

Sorry but this is a single channel packet forwarder and NOT a LoRaWAN GW (as required for use on TTN) and is not supported on TTN or the community forum, as these are disruptive to other users it’s perhaps just as well that it dies with the V2 to V3 transition. Please disconnect it and get yourself a true LoRaWAN GW - they are not expensive these days so use of a SCPF or DCPF is no longer justified (hasnt been for many years now).

Unfortunately I can not find the Button to create a new topic, so I have to hijack a thread…
(edit: now I reached level 1 and the button is there, how frustrating)

I have an account where I misspelled the email-address. So the account was blocked due to missing mail verification, taking the Gateway-EUI with it. Support isn’t helping. Does anybody know who to contact? There is one letter to change… Or to temporarily unlock so I can transfer ownership of the Gateway…

We don’t have account access on the forum so perhaps use #support thread on TTN Slack