Gateway not connected


#1

Hi,
My gateway (Lorank8) is working for months and from one moment (last night) it shows as "not connected". I rebooted it, removed it from TTN console and added it again, nothing helps. As far as I understand it is working fine....

Any idea's?

log:
Jul 16 23:19:53 lorank8 kernel: [ 783.346688] export_store: status -16
Jul 16 23:19:53 lorank8 lorank8v1[2929]: Starting the Poly packet forwarder.
Jul 16 23:19:53 lorank8 lorank8v1[2929]: *** Poly Packet Forwarder for Lora Gateway ***
Jul 16 23:19:53 lorank8 lorank8v1[2929]: Version: 3.0.0
Jul 16 23:19:53 lorank8 lorank8v1[2929]: *** Lora concentrator HAL library version info ***
Jul 16 23:19:53 lorank8 lorank8v1[2929]: Version: 4.0.0; Options: native;
Jul 16 23:19:53 lorank8 lorank8v1[2929]: ***
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: Little endian host
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: found global configuration file global_conf.json, parsing it
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: global_conf.json does contain a JSON object named SX1301_conf, parsing SX1301 parameters
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: lorawan_public 1, clksrc 1
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: antenna_gain 0 dBi
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: Configuring TX LUT with 16 indexes
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: radio 0 enabled (type SX1257), center frequency 867500000, RSSI offset -166.000000, tx enabled 1
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: radio 1 enabled (type SX1257), center frequency 868500000, RSSI offset -166.000000, tx enabled 0
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: Lora multi-SF channel 0> radio 1, IF -400000 Hz, 125 kHz bw, SF 7 to 12
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: Lora multi-SF channel 1> radio 1, IF -200000 Hz, 125 kHz bw, SF 7 to 12
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: Lora multi-SF channel 2> radio 1, IF 0 Hz, 125 kHz bw, SF 7 to 12
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: Lora multi-SF channel 3> radio 0, IF -400000 Hz, 125 kHz bw, SF 7 to 12
Jul 16 23:19:53 lorank8 lorank8v1[2929]: INFO: Lora multi-SF channel 4> radio 0, IF -200000 Hz, 125 kHz bw, SF 7 to 12
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Lora multi-SF channel 5> radio 0, IF 0 Hz, 125 kHz bw, SF 7 to 12
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Lora multi-SF channel 6> radio 0, IF 200000 Hz, 125 kHz bw, SF 7 to 12
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Lora multi-SF channel 7> radio 0, IF 400000 Hz, 125 kHz bw, SF 7 to 12
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Lora std channel> radio 1, IF -200000 Hz, 250000 Hz bw, SF 7
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: FSK channel> radio 1, IF 300000 Hz, 125000 Hz bw, 50000 bps datarate
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: global_conf.json does contain a JSON object named gateway_conf, parsing gateway parameters
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: gateway MAC address is configured to 0000000000000000
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Found 1 servers in array.
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Server 0 configured to "router.eu.thethings.network", with port up "1700" and port down "1700"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Found 5 system calls in array.
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: System command 0: "df -m"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: System command 1: "free -h"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: System command 2: "uptime"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: System command 3: "who -a"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: System command 4: "uname -a"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: monitor hostname or IP address is configured to "127.0.0.1"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: monitor port is configured to "2008"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: ghost hostname or IP address is configured to "127.0.0.1"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: ghost port is configured to "1918"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: format is configured to "semtech"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: filename for statistical performance is configured to "stats.txt"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Damping for statistical info is configured to 50%
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: downstream keep-alive interval is configured to 10 seconds
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: statistics display interval is configured to 30 seconds
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: upstream PUSH_DATA time-out is configured to 100 ms
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: packets received with a valid CRC will be forwarded
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: packets received with a CRC error will NOT be forwarded
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: packets received with no CRC will NOT be forwarded
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: GPS serial port path is configured to "/dev/ttyAMA0"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: SSH path is configured to "/usr/bin/ssh"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: SSH port is configured to 22
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: HTTP port is configured to 80
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: NGROK path is configured to "/usr/bin/ngrok"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Reference latitude is configured to 0.000000 deg
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Reference longitude is configured to 0.000000 deg
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Reference altitude is configured to 0 meters
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: GPS is enabled
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Using fake GPS coordinates instead of real.
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Upstream data is enabled
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Downstream data is enabled
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Ghoststream data is disabled
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Radiostream data is enabled
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Statusstream data is enabled
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Beacon is disabled
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Monitor is disabled
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Packet logger is disabled
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Platform configured to "Lorank"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Contact email configured to ""
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Description configured to ""
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: found local configuration file local_conf.json, parsing it
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: redefined parameters will overwrite global parameters
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: local_conf.json does not contain a JSON object named SX1301_conf
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: local_conf.json does contain a JSON object named gateway_conf, parsing gateway parameters
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: gateway MAC address is configured to 54544E4B26424E31
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: format is configured to "semtech"
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: packets received with a valid CRC will be forwarded
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: packets received with a CRC error will NOT be forwarded
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: packets received with no CRC will NOT be forwarded
Jul 16 23:19:54 lorank8 lorank8v1[2929]: INFO: Reference latitude is configured to 52.170234 deg

Jul 16 23:24:57 lorank8 lorank8v1[2929]: # PUSH_DATA datagrams sent: 1 (251 bytes)
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # PUSH_DATA acknowledged: 100.00%
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### [DOWNSTREAM] ###
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # PULL_DATA sent: 3 (100.00% acknowledged)
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # PULL_RESP(onse) datagrams received: 0 (0 bytes)
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # RF packets sent to concentrator: 0 (0 bytes)
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # TX errors: 0
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### BEACON IS DISABLED!
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### [JIT] ###
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # INFO: JIT queue contains 0 packets.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # INFO: JIT queue contains 0 beacons.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### [GPS] ###
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # No time keeping possible due to fake gps.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # Manual GPS coordinates: latitude 52.17023, longitude 4.63579, altitude 0 m
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### [PERFORMANCE] ###
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # Upstream radio packet quality: 50.00%.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # Upstream datagram acknowledgment quality for server "router.eu.thethings.network" is 100.00%.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # Downstream heart beat acknowledgment quality for server "router.eu.thethings.network" is 100.00%.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # Downstream datagram content quality for server "router.eu.thethings.network" is 0.00%.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # Downstream radio transmission quality for server "router.eu.thethings.network" is 100.00%.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # Semtech status report send.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ##### END #####
Jul 16 23:24:57 lorank8 lorank8v1[2929]: INFO: [up] PUSH_ACK for server router.eu.thethings.network received in 29 ms
Jul 16 23:24:57 lorank8 lorank8v1[2929]: INFO: [down] for server router.eu.thethings.network PULL_ACK received in 32 ms
Jul 16 23:24:57 lorank8 lorank8v1[2929]: INFO: [down] for server router.eu.thethings.network PULL_ACK received in 28 ms
Jul 16 23:24:57 lorank8 lorank8v1[2929]: INFO: [down] for server router.eu.thethings.network PULL_ACK received in 28 ms
Jul 16 23:24:57 lorank8 lorank8v1[2929]: INFO: Disabling GPS mode for concentrator's counter...
Jul 16 23:24:57 lorank8 lorank8v1[2929]: INFO: host/sx1301 time offset=(1500247194s:433413µs) - drift=3997µs
Jul 16 23:24:57 lorank8 lorank8v1[2929]: INFO: Enabling GPS mode for concentrator's counter.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ##### 2017-07-16 23:24:56 GMT #####
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### [UPSTREAM] ###
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # RF packets received by concentrator: 0
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # CRC_OK: 0.00%, CRC_FAIL: 0.00%, NO_CRC: 0.00%
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # RF packets forwarded: 0 (0 bytes)
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # PUSH_DATA datagrams sent: 1 (251 bytes)
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # PUSH_DATA acknowledged: 100.00%
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### [DOWNSTREAM] ###
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # PULL_DATA sent: 3 (100.00% acknowledged)
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # PULL_RESP(onse) datagrams received: 0 (0 bytes)
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # RF packets sent to concentrator: 0 (0 bytes)
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # TX errors: 0
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### BEACON IS DISABLED!
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### [JIT] ###
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # INFO: JIT queue contains 0 packets.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # INFO: JIT queue contains 0 beacons.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### [GPS] ###
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # No time keeping possible due to fake gps.
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # Manual GPS coordinates: latitude 52.17023, longitude 4.63579, altitude 0 m
Jul 16 23:24:57 lorank8 lorank8v1[2929]: ### [PERFORMANCE] ###
Jul 16 23:24:57 lorank8 lorank8v1[2929]: # Upstream radio packet quality: 50.00%.

(Alexbn71) #2

The Gateway status is still unreliable. My gateway disappeard three days ago even if my end device still sending data, that are visible in the TTN dashboard.

Alex


(Stefanth) #3

Hi,

i have the same problem. My SCG isn't connected in the console.

But on this link I see that is connected: http://noc.thethingsnetwork.org:8085/api/v2/gateways/eui-b827ebffff0d60f6

Stefan


(Stefanth) #4

Update: now it's working for me...

Thanks for resolving


(Alexbn71) #5

...my Gateway has resurrected as well.

Alex


#6

  1. Sometimes the console doesn't show things correctly.

2.
Do you have
"stat_format": "semtech"
and
"fake_gps": true
and
"gps":true
in the local_conf.json?
That helped me to show up in the console:
https://www.thethingsnetwork.org/forum/t/gateway-not-activated-in-console-and-not-on-the-map/4673/6