Heltec LoRa 32 - Trying to register on TTNv3

Getting failed registrations. I could not find a APPEUI in v3 so I used the JOINEUI - is that my problem? I was able to get a license key so I think that is OK.

You need to be more exact, provide more information, shall check the forum for information already available (and questions already answered) and read (some of) The Things Stack V3 documentation. :slightly_smiling_face:

What exactly is “Heltec ESP32v2”? See ESP32 topic for boards and exact naming.
What do you mean with “Getting failed registrations.”?
What do you mean with “I was able to get a license key so I think that is OK”?
Don’t make others have to guess and ask what you mean.

1 Like

I changed the name on the post to the name on the box - Heltec LoRa 32.

I had read a lot, but did read the TTN device registration document and followed it. At one point it said to enter all zeros if your device did not have a DEVEUI or a APPEUI - I tried this and it said somebody already registered with that DEVEUI. I modified each of those by changing one byte and it accepted my device. When I try to register OTAA it fails - I have seen some MIC mismatch in the logs, but could not figure that out.

Here’s the error message for the all zero’s issue:

  "code": 6,
  "message": "error:pkg/identityserver:end_device_euis_taken (an end device with JoinEUI `0000000000000000` and DevEUI `0000000000000000` is already registered as `060010923952` in application `kcityv3f06`)",
  "details": [
      "@type": "type.googleapis.com/ttn.lorawan.v3.ErrorDetails",
      "namespace": "pkg/identityserver",
      "name": "end_device_euis_taken",
      "message_format": "an end device with JoinEUI `{join_eui}` and DevEUI `{dev_eui}` is already registered as `{device_id}` in application `{application_id}`",
      "attributes": {
        "application_id": "kcityv3f06",
        "dev_eui": "0000000000000000",
        "device_id": "060010923952",
        "join_eui": "0000000000000000"
      "correlation_id": "1f2578e6307b457dad2335c0f132a681",
      "code": 6
  "request_details": {
    "url": "/applications/loradbwtest/devices",
    "method": "post",
    "request_id": "d59ab913-184a-4649-b991-7b9946528607",
    "stack_component": "is"

I am completely new to LoRa and my programming skills are not current.


The devil is in the detail I’m afraid - it says if you don’t have an AppEUI the use all zeros, it doesn’t say that for the DevEUI at all.

It is not certain yet if LMIC can cope with all zeros - some have tried, been told to change it and then it’s worked, but I haven’t tried it yet to be 100% but all the evidence fits.

As you are building a Maker style device you need to get a DevEUI from somewhere, the somewhere being found via the forum or for speed, this chap’s web page is pretty good: Random EUI or Key generator - there is a link in the footer back to the forum that will explain what is going on.

If you are new to LoRaWAN and your programming skills aren’t current, I’d definitely find some materials to read - like the documentation - and go slow so you can absorb the materials.

I would strongly recommend this chap’s framework: GitHub - lnlp/LMIC-node: LMIC-node | One example to rule them all. LMIC-node is an example LoRaWAN application for a node that can be used with The Things Network. It demonstrates how to send uplink messages, how to receive downlink messages, how to implement a downlink command and it provides useful status information. With LMIC-node it is easy to get a working node quickly up and running. LMIC-node supports many popular (LoRa) development boards out of the box. It uses the Arduino framework, the LMIC LoRaWAN library and PlatformIO. as it directly supports the Heltec LoRa 32 but you will need to know which version you have - the bits where you put your code are clearly laid out.

Thank you - thank you - generating a DEVEUI did the trick and the join worked.

The example code I am using came direct from Heltec support so I didn’t have to write my own - I’m usually pretty good at modifying existing code. For others here is the link to the Heltec code: https://github.com/HelTecAutomation/ESP32_LoRaWAN.git

1 Like

The problem with that software is that it is proprietary and hardly anyone on the forum uses it because closed source and runs on Heltec ESP32 devices only and each device needs its own license code that (somehow) needs to be configured in the application code.


They based it on the open source LoRaMac-node library which is good, but their specific closed port to Heltec ESP32 only devices makes it by default not interesting for the open source community and cannot be re-used with any other ESP32 devices.
They took from the open source community (and Semtech) but then don’t give back to the community and don’t share which is poor practice.
(They don’t share because essential parts of the source code are obfuscated which makes it unreadable and unusable for other devices.)


After many frustrating moments with this device I finally got everything working that I needed to send data to TTN through my gateway. I ordered another like it but plan to return it and switch to an Arduino and HOPERF module for my node work.

It took me a week to make it worked. So, I wrote an example here. https://bit.ly/2WxvwMZ