LoRaWAN Academy - AWS stack error

(Hs) #6

Thank you for repairing this so fast. It is now OK.

(Tdsm) #9

Hi guys, tried to create a new AWS integration but there seems to be an error in the cloudformation template.

AWS::ElasticBeanstalk::ConfigurationTemplate	TTNConfigurationTemplate	
No Solution Stack named '64bit Amazon Linux 2018.03 v2.9.4 running Go 1.11.4' found. 

Related to this closed topic:

Found this on the Amazon docs: 2.10.0 seems to be the current version.
I guess the templated needs to be updated for every new version.

(Gcl8a) #10

I’m having the same issue. @johan refers to a solution, but I don’t see what I’m supposed to do – does he have to update it again? If there is a solution that I can implement, can someone please help? Feel free to explain in painful detail – I’m fairly new to AWS.



@gcl8a what exactly is your error? Because 64bit Amazon Linux 2018.03 v2.10.0 running Go 1.11.5 is the latest and that’s what we have in the CloudFormation template deployed at the moment.

(Gcl8a) #12

Thanks for the quick reply, @johan.

The specific error is: “No Solution Stack named ‘64bit Amazon Linux 2018.03 v2.10.0 running Go 1.11.5’ found. (Service: AWSElasticBeanstalk; Status Code: 400; Error Code: InvalidParameterValue; Request ID: …”

It does show CREATE_COMPLETE for AWS::ElasticBeanstalk::Application. But then the configuration fails.

In case it matters, I’m using us-east (DC).


@gcl8a removing solution stack support very often is one thing, but not actually having one available is really weird. My source is https://docs.aws.amazon.com/elasticbeanstalk/latest/platforms/platforms-supported.html#platforms-supported.go

Am I overlooking anything?

I wish AWS was a bit developer friendlier…

(Gcl8a) #14

First off, I’m super new to all of this, so when you ask me, “Am I overlooking anything?” I can only say, “I have no idea. You tell me.” :wink:

But the version you linked to certainly seems correct, so my question is: Is there something I need to do on AWS to set up a beanstalk? From the video, it appears that all of that is supposed to be taken care of for me, but I’m not sure. I’ve followed the quick start to the letter and I keep getting this error.

At this point, I have to assume there’s something wrong with my AWS setup. I’ll see if one of my students can figure anything out. If there is any other information that might be helpful, let me know.


Can you try another region?

(Gcl8a) #16

I tried US-west (Oregon) and got the same result.

Last night, I was able to use EB to start an application based on Go, completely independently of TTN.

Is anyone else having this issue? Or can anyone who’s following along confirm that they can make a new stack?

(Datth22) #17

Hi Johan,
Is this issue resolved yet? I still have error message. Any work around for this?
Thank you

(Gcl8a) #18

@datth22 Does this mean you had the same problem? I don’t know if that’s good (it’s not just me!) or bad (there is something deeper going on that’s going to take some time to fix), but @johan let me know what I can do to help test things.

I’ve also opened a forum post on AWS: https://forums.aws.amazon.com/message.jspa?messageID=892174 to see if anyone there has any ideas.

(Datth22) #19

Hi SJKear,

What was the fix for this issue as I still have this error? Can you share what solution name/ platform you are running atm so I can adjust the template accordingly?

Thank you.


I dived in this and this is an error in the AWS documentation.

Where the documentation says:

64bit Amazon Linux 2018.03 v2.10.0 running Go 1.11.5

This should be:

64bit Amazon Linux 2018.03 v2.10.1 running Go 1.11.5

This has been fixed in our CloudFormation template – a build is running and will be deployed automatically.

(Sj Kear) #21

Hi @datth22. With my anomaly the ‘Go solution stack’ version number in TTN’s ‘cloudformation.template’ needed updating - which @johan kindly did.

Looking @johan latest post, it again looks like a version numbering issue and the TTN’s ‘cloudformation.template’ template has been updated so hopefully this should resolve your anomaly. It’s bizarre AWS has implemented it in this way…

(Gcl8a) #22

I can confirm it works for me. Danke!

(Tad Slawecki) #23

A related (?) AWS stack error … starting from the [AWS Quick Start instructions]((https://www.thethingsnetwork.org/docs/applications/aws/quick-start.html), I get an error when trying to create a new stack by clicking on (e.g.) US us-west-2. The error is

Template validation error: Template format error: YAML not well-formed. (line 308, column 13)

The same error occurs for the other regions.


(Tad Slawecki) #24

FWIW, looking at the template file, maybe it’s just an extra tab?

The last two lines (308 and 309) might be wrongly indented:

   - Namespace: "aws:elasticbeanstalk:application:environment"
      OptionName: "TTN_SHADOW_DELTA_FPORT"
        Ref: ThingShadowDeltaFPort
    - Namespace: "aws:elasticbeanstalk:application:environment"
      OptionName: "AWS_THING_TYPE"
        Ref: ThingTypeName
    - Namespace: "aws:elasticbeanstalk:application:environment"
      OptionName: "AWS_CLOUDWATCH"
          Ref: CloudWatch


Thanks for reporting. I fixed this just now

New build is running, please wait ~10 minutes on CD

(Guillermo Pallarolas) #26

Hello Johan,

I have had a similar problem as the others, and could reach to CREATE_COMPLETE without many issues by replacing the SolutionStackName item with the newest supported by AWS, i.e. SolutionStackName: “64bit Amazon Linux 2018.03 v2.11.0 running Go 1.12.1”.
The main issue now, is that I cannot see any sync Things from TTN. Message says at the aws console: " You don’t have any things yet. A thing is the representation of a device in the cloud."
I already tried to re-create the stack with a shorter ThingSyncInterval (1m, etc.), tried several other choices, and even wait for about 1/2 day. It does not seem to work.
What else could a try?

(Sylvain Prost) #27

Hello @guillermo_pallarolas

Can you follow those instruction, https://www.thethingsnetwork.org/docs/applications/aws/troubleshooting.html and post any error you can find ?
This is likely to be an access problem either on the TTN or AWS bound. Check your Application settings for the integration and that the integration is allowed to IoT Core via the policy.

One thing you can do to test it out is to see if there is any traffic incoming in IoT Core. If that is the case, then check, the App Access key. It should have the “devices” right for the sync to work.