LoRaWAN Academy - AWS stack error

Hello @guillermo_pallarolas

Can you follow those instruction, https://www.thethingsnetwork.org/docs/applications/aws/troubleshooting.html and post any error you can find ?
This is likely to be an access problem either on the TTN or AWS bound. Check your Application settings for the integration and that the integration is allowed to IoT Core via the policy.

One thing you can do to test it out is to see if there is any traffic incoming in IoT Core. If that is the case, then check, the App Access key. It should have the “devices” right for the sync to work.

Cheers

Hi Sylvain, thanks for your quick reply!
Yesterday I deleted the whole thing, and tomorrow will start again. I will post then the error messages according to your link. Just for the record, the only thing that was not working is the synchronization and things shadow. We could pretty much pass messages from TTN to AWS and later to DynamoDB. This is Ok for now, but we will most probably create a custom app and use the TTN SDK to access devices config from it. I find the whole AWS config, debugging and troubleshooting very complicated.
Thanks for your support!
Guillermo

Then something is wrong with the AppKey or the AWS Policy.

Thank you for your feedback, I feel the same way for the debugging but its AWS being AWS. We will definitely try to improve that with the V3 integration.

Cheers

Hi Sylvain again,
after deleting our application in TTN console, creating a new one at TTN, and creating a new stack… again we reached to the point that the devices config are not being synchronized (passing the messages to dynamo db is working pretty well though). I followed the instructions within the link you sent earlier, and from the logs the only thing that caught our attention are the following lines (the rest seems to be fine):
From /var/log/app-1.log

WARN Failed to set device remotely DevID=nodouno error=InvalidRequestException: Can not create new thing with depreated thing type:lorawan
status code: 400, request id: 96266b94-5a4e-11e9-bfa9-555efab6ca35
WARN Failed to set device remotely DevID=nododos error=InvalidRequestException: Can not create new thing with depreated thing type:lorawan
status code: 400, request id: 97ebc2b2-5a4e-11e9-af32-0358dee54a39
WARN Failed to set device remotely DevID=nodouno error=InvalidRequestException: Can not create new thing with depreated thing type:lorawan
status code: 400, request id: 97f25210-5a4e-11e9-b7f1-0bab508b41a9
WARN Failed to set device remotely DevID=nododos error=InvalidRequestException: Can not create new thing with depreated thing type:lorawan
status code: 400, request id: 99b55f82-5a4e-11e9-b8a3-a92e605c5d30
WARN Failed to set device remotely DevID=nodouno error=InvalidRequestException:

Looks you the ThingType has been deprecated on your account. This might be due to the integration failing during clean up correctly or a manual action.

Go to Manage > Types > lorawan > Action (right - top) > Undeprecate.

Hope it helps.

Best

Dear Johan,

I might be wrong but I’m failing to execute the AWS IoT integration as I’m experiencing a similar problem to others; the version of Go referenced in the CloudFormation template is possibly not current on AWS and it fails with the following message:

“No Solution Stack named ‘64bit Amazon Linux 2018.03 v2.11.0 running Go 1.12.1’ found. (Service: AWSElasticBeanstalk; Status Code: 400; Error Code: InvalidParameterValue; Request ID: d7”

AWS indicate “64bit Amazon Linux 2018.03 v2.11.1 running Go 1.12.4” as current.

Am I correct is understanding this to be a cause of problems?

with my thanks,

Dominic.

Yes, same old problem. I updated the solution stack again, please wait for CD to pass; ~10 minutes.

will this be to the latest version of:

64bit Amazon Linux 2018.03 v2.11.1 running Go 1.12.4

Also been struggling today.

Yes it is

Hi johan, The same old problem, as per last cases mentioned.

"No Solution Stack named ‘64bit Amazon Linux 2018.03 v2.11.1 running Go 1.12.4’ found. (Service: AWSElasticBeanstalk; Status Code: 400; Error Code: InvalidParameterValue; Request ID: acf8ba73-2d8f-4682-be08-b905e48bee17) "

Would you please have a look.

Cheers

The update is on its way, expect ~10 minutes

1 Like

Marvelous work Johan, Thank you.

Hi I’m new to TTN and I am getting the same error for my AWS Stack:

No Solution Stack named ‘64bit Amazon Linux 2018.03 v2.10.0 running Go 1.11.5’ found. (Service: AWSElasticBeanstalk; Status Code: 400; Error Code: InvalidParameterValue; Request ID: 88d378e3-b07f-424c-8c13-dc82357d8a15)

Would be very appreciated if someone can aid with this!

I’m getting the same error. So it seems AWS guys are changing the versions of Amazon Linux too often! We need to wait for the johan to help.

I wondered if it would help to choose a different Instance Type, instead of default t2.micro? so this tried t2.small but the error was same.

1 Like

Tried today and worked. All seems to be fine now.

The issue is fixed and working now. Hopefully a permanent fixed can be find.

Hello Johan,

I am currently using Klarrio/ttn-aws-workshop in order to create a stack for AWS to complete the integration side of my IoT project. I am currently using an AWS account created by my professor for research purposes but am having the same difficulty as other users above when attempting to create my stack with the template created (ttn-cloudformation-template) in Klarrio’s repository.

ERROR: No Solution Stack named ‘64bit Amazon Linux 2018.03 v2.11.1 running Go 1.12.4’ found. (Service: AWSElasticBeanstalk; Status Code: 400; Error Code: InvalidParameterValue; Request ID: caabaff1-32a6-4da1-9a66-2e843cd9f8a5)

After reading multiple forums, I have tried changing the SolutionStackName to the following:

  • 64bit Amazon Linux 2017.09 v2.7.5 running Go 1.9

  • 64bit Amazon Linux 2018.03 v2.10.0 running Go 1.11.5

  • 64bit Amazon Linux 2018.03 v2.11.1 running Go 1.12.4

but have had the same issue leading to ROLLBACK_COMPLETE on the stack.

I have continued to change a few things around when creating new stacks like changing TheThingType from lorawan to ttnLoraWan as stated within Klarrio’s repository but no success. Should I try changing the region, SolutionStackName, InstanceType, and/or another parameter in order to confirm the issue by trial and error or am I missing something else??

Your help is much appreciated!

Also, my ttn application handler is set to ttn-handler-us-west if that helps at all.

Thank you!

Hi i have the same problem

“No Solution Stack named ‘64bit Amazon Linux 2018.03 v2.12.1 running Go 1.12.7’ found. (Service: AWSElasticBeanstalk; Status Code: 400; Error Code: InvalidParameterValue; Request ID: …”

any help?

Hi we also have the same problem.
“No Solution Stack named ‘64bit Amazon Linux 2018.03 v2.12.1 running Go 1.12.7’ found. (Service: AWSElasticBeanstalk; Status Code: 400; Error Code: InvalidParameterValue; Request ID: …”

I hope we can get some help. Thank you in advance.