Move a thing vfrom one account to another

I registered a device (SODAQ tracker) on a wrong account and got data. Afterwards I deleted the device and registered it again on the correct account, but now, no data appears. EUIs and keys are correct, that was simply copy and paste. What can I do ? I already deleted again and re-registered.

Power cycle the node

That did not work, although I tried several times. I also changed DevEUI, Appkey and AppEUI, but it didn’t help either.

I tried to re-register it on the previous account, but I couldn’t. It told me, that it is already present, although I deleted it. So the problem may be an incorrect deletion at TTS ??

This is rather ambiguous so it’s going to be hard to help as there are several know situations that could be relevant here - the EXACT error message would help.

Submit failed
an end device with JoinEUI 0102030405060XXXX and DevEUI 0004A30B00EF8XXX is already registered as eui-0004a30b00ef8XXX in application sodaqtracker

“code”: 6,
“message”: “error:pkg/identityserver:end_device_euis_taken (an end device with JoinEUI 0102030405060XXX and DevEUI 0004A30B00EFXXXX is already registered as eui-0004a30b00efXXXX in application sodaqtracker)”,
“details”: [
@type”: “”,
“namespace”: “pkg/identityserver”,
“name”: “end_device_euis_taken”,
“message_format”: "an end device with JoinEUI {join_eui} and DevEUI {dev_eui} is already registered as {device_id} in application {application_id}",
“attributes”: {
“application_id”: “sodaqtracker”,
“dev_eui”: “0004A30B00EF8XXX”,
“device_id”: “eui-0004a30b00efXXXX”,
“join_eui”: “0102030405060XXX”
“correlation_id”: “3714ed6d739146d49ccc3bcb86b4XXXX”,
“code”: 6
That is the exact error message, with some xxx in the keys.

This is what serial logging tells me,but still nothing on TTS, even after firmware update:


sys reset
[expectString] (“RN”) .–> “RN2483 1.0.4 Oct 12 2017 14:59:25” found a match!

The device type is RN2483

mac join abp
[expectString] (“ok”) .–> “ok” found a match!

[expectString] (“accepted”) .–> “accepted” found a match!


sys sleep 259200000
** Boot-up completed successfully!
Starting getGpsFixAndTransmit()…
Setting RTC from 9466848XX to 16372759XX
Timestamp, BatteryVoltage, BoardTemperature, Lat, Long, Altitude, Speed, Course, SatelliteCount, TimeToFix
1637276002, 75, 33, 511236117, 71895190, 224, 6, 97, 5, 21


mac tx uncnf 1 62D996614B2115D8781E96084904E00006006XXXX
[expectString] (“ok”) .–> “ok” found a match!

Waiting for server response…
Received mac_tx_ok

mac save
[expectString] (“ok”) …–> “ok” found a match!

Data transmitted successfully.

sys sleep 259200000