MQTT V3 Publish Unsuccessful

I am having difficulty with MQTT Publish on TTN V3.

I have successfully managed to subscribe to the uplink and can read data etc.

Using topic: “v3/light-relay@ttn/devices/eui-70b3d58ff102165a/up”

However, when I try to publish a command, this is not seen in the Live data on TTN.

I am publishing the command:

{"downlinks”: [{"f_port”: 2,"frm_payload”: “BAABAAAAAAAAAA==”,"priority”: “NORMAL”}]}

To Topic:


(I have tried with @TTN and without @TTN. This made no difference.)

My MQTT Broker does not return any error, and the application confirms connection when I connect.

I have tried on port 1883, and 8883 TLS enabled and disabled.

MQTTFX broker log message:
2021-10-23 09:25:26,996 INFO — PublishController : publish
2021-10-23 09:25:26,997 INFO — MqttFXClientModel : attempt to add PublishTopic
2021-10-23 09:25:26,997 INFO — MqttFXClient : sucessfully published message {"downlinks”: [{"f_port”: 2,"frm_payload”: “BAABAAAAAAAAAA==”,"priority”: “NORMAL”}]} to topic v3/light-relay@ttn/devices/eui-70b3d58ff102165a/down/push (QoS 0, Retained: false, ContentTpe: text/plain)

However, when I send the same message to port 2 from the console, the message is received.

Any ideas on why this is happening.

Your JSON is invalid - you have got fancy quotes rather than boring straight ones.

1 Like

Wow, thanks for that,
something so simple that I was overlooking.
Cheers for the speed of your response too!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.