New gateway from Laird: Sentrius RG1XX

(Danny Boyle) #153

Where did you get your IP68 Enclosure?

(Myttndel) #154

were you able to get this working ?

(Jbkiwi) #155

Enclosure is a StationBox made by RF Elelments

(Jbkiwi) #156

Yep, got four out in the field and three more Raspberry Pi MTac based gateways as well.

(Everhamme) #157

Can you tell me about how many solar panels you used in this setup?

(Jeff Uk) #158

How many/size you will need will depend on placement - how much of a clear horizon you have, if there are buildings or trees obscuring /shadowing for part of day etc. - whether you have fixed or tracking install of the panels, and where you are in the world (solar elevation angle). The summer experiment kicked off with just one and a single battery per photo. It wasn’t expected that would be enough to get through winter :slight_smile: or even through Autumn days if weather poor. Have been experimenting with since and have also been evaluating 24hr pwr consumption of the target GW’s.

If it helps a crude measurement of the consumption for a Laird bd running off nominal 5V USB supply suggests ~8400mAh - assume reading was 10-20% ‘light’ and looks like 10,000mAh a good target 24Hr pwr spec to work with…

So you need one or more panels capable of powering GW whilst also charging the standby back-up battery and ensuring adequate reserves under local adverse conditions - leaf fall and snow cover etc. (unless you are in a desert of-course :wink: ), during whatever local sunshine hrs you get. During good summer weather I found I was getting useful (>75%MPP) for around 6-8 hrs/day so could size for ~1/3rd-1/4 of time being run with recovery whilst 2/3rd-3/4 draining battery. This time of year I’m finding its barely 1-2 hrs/day so have had to look at 50% increase in battery capacity and doubling up on the panels (Parallel install to ensure adequate charging current for battery whilst also running the GW). Even then I’m not convinced system will survive the worst a British winter and dark/rainy/snowy days can throw at it! Will be adjusting config as time goes on and will see what happens by time we get back to next spring :slight_smile:

(Rserag) #159


I have just updated firmware of my RG186, after reboot all lights are blinking. What is the problem? How can I fix it?

And here is log of Laird from UART

RG1xx29387F login: killall: input-event-daemon: no process killed
Stopping semtech packet forwarder
Stopping bluetooth
Shutting down nbnsd services: sh: you need to specify whom to kill
Stopping ntpd: cat: can’t open ‘/var/run/’: No such file or directory
sh: you need to specify whom to kill
Stopping USB host-mode
Stopping network interfaces… wlan0 eth0 lo
Stopping logging services: syslogd klogd
Saving random seed… done

The system is going down NOW!

Sent SIGKILL to all processes

Requesting system reboot
[ 14.510000] reboot: Restarting system

AT91Bootstrap 3.7.1-laird08 (Thu Dec 8 23:52:27 EST 2016)

NAND: ONFI flash detected
NAND: Manufacturer ID: 0x2c Chip ID: 0x31
NAND: Initialize PMECC params, cap: 0x8, sector: 0x200
NAND: Image: Copy 0x80000 bytes from 0x20000 to 0x23f00000
PMECC: sector bits = 0x1, bit 1 means corrupted sector, Now correcting…
Correct error bit in OOB @[#Byte 0x2,Bit# 0x2] 0xee -> 0xea
NAND: Done to load image

U-Boot 2014.07-laird04 (Dec 08 2016 - 23:52:30), Build: jenkins-wb50n-laird_fips-

Crystal frequency: 12 MHz
CPU clock : 528 MHz
Master clock : 132 MHz
DRAM: 64 MiB
NAND: 128 MiB
In: serial
Out: serial
Err: serial
Net: macb0, usb_ether
Hit any key to stop autoboot: 0

NAND read: device 0 offset 0x5e0000, size 0x500000
5242880 bytes read: OK

Booting kernel from Legacy Image at 22000000 …

Image Name: Linux-4.4.39-laird07.02
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2627611 Bytes = 2.5 MiB
Load Address: 22000000
Entry Point: 22000000
Verifying Checksum … OK
Loading Kernel Image … OK

Starting kernel …

Uncompressing Linux… done, booting the kernel.
[ 0.000000] Booting Linux on physical CPU 0x0

[ 0.000000] Linux version 4.4.39-laird07.02 (jenkins@usdc01bd02) (gcc version 4.8.3 (crosstool-NG 1.20.0) ) #1 PREEMPT Wed May 23 11:39:36 EDT 2018

[ 0.000000] CPU: ARMv7 Processor [410fc051] revision 1 (ARMv7), cr=10c53c7d

[ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache

[ 0.000000] Machine model: Laird Workgroup Bridge 50N - Project Gatwick

[ 0.000000] bootconsole [earlycon0] enabled

[ 0.460000] atmel_sha f8034000.sha: initialization failed.

Initializing random number generator… done
Starting logging services: syslogd klogd
Looking for resetsh: write error: Device or resource busy
/etc/init.d/S05factoryreset: line 60: can’t create /sys/class/gpio/pioE31/direction: nonexistent directory
cat: can’t open ‘/sys/class/gpio/pioE31/value’: No such file or directory
sh: ==: argument expected
cat: can’t open ‘/sys/class/gpio/pioE31/value’: No such file or directory
sh: ==: argument expected
cat: can’t open ‘/sys/class/gpio/pioE31/value’: No such file or directory
sh: ==: argument expected
Reverting forwarders
Remove custom configs
Unpack default configs
Waiting for release
cat: can’t open ‘/sys/class/gpio/pioE31/value’: No such file or directory
sh: ==: argument expected

Summit Data Communications

(Jeff Uk) #160

@BWhitten Hi Ben can you shed light on this/recommend action or does @rserag need to go back through Laird support channels?

(Lachlan Etherton) #161

I must give credit where credit is due. The RG191 is a great gateway. For Aussies, they are one of easiest, most affordable and refined gateways on the market that work out the box for AU915. There is nothing at the same price point which works with such ease. They may have to have a firmware update done on them if they are older stock, but it beats mucking around with Raspberry Pis and he setup if all you want is a working gateway without the need for complete control and flexibility.

The best thing about this gateway is the fact that it works just like a modem router. It is not hard to setup, nor it is a new experience, it just does the job.

There is an issue with it however and it is the fact that when you access the web portal, it has a message saying “Connection with gateway may have been lost” which is annoying, but otherwise harmless. In addition, it is supplied with a US power supply, so those down under need to get a converter (female US to male AU) for about $10 to get it working.

Those interested can get them from Element14. Make sure it is the 915MHz version, otherwise it’ll be an expensive paper weight.


Thats had a partial upgrade, kernel and rootfs have gotten out of sync. This may have been due to an upgrade over unstable wifi or network outage.
It is unfortunatly an RMA job, later versions of the firmware dont suffer from this.

(Rserag) #163

Thank you @BWhitten for support. @Jeff-UK thank you too!

(Varun) #164

i have sentrius RG168 gateway EU region if i use in India . Is it illegal ?
What is different b/w RG168 & RG168 m2 ?

(Jeff Uk) #165

Hi Lachlan, agree with you that the Laird RG1xx one of the easiest to set up and run - I can usually get an unboxed assembled unit up and running on E’net connection & registered on TTN in under 4 mins…a Wifi unit might take me 5! :slight_smile: Until last few months it has been one of my favourites and have deployed many for myself and for clients either directly or by recommendation, not least as also a relatively low cost unit, even if its closed/proprietary and not a flexible/open platform in the way say a RPi or embedded PC/Linux based unit can be. As I’m not much of softie or code hacker latter point doesn’t bother me too much and I don’t have to worry about loading images or mitigating potential (u)SD card reliability issues :wink: Support from the Laird team has been good and responsive also and have shared what I hope is useful tech/feature insight that is in part reflected in the GW/Sensor product family.

Interesting to see you have issues with supplied main adapter…that is also a big problem here in the UK - so a heads up for UK users to a deployment problem I have experienced - where EU rules allow suppliers to ship in mains adapters where the pins are not specifically designed for UK traditional 3 Pin socket use.:frowning:

This is typically as supplied:

Which forces the use of one of these to adapt to UK 3 Pin outlet:

Before deploying to the field I usually soak test configured units for at least a few days - and often 1wk to as much as 1month before pushing out the door.

In the office/lab several may be on test at a time:

Late in the summer I had a problem with a deployment in N.East UK where install kept dropping off line…long story short TL::DR…problem turned out to be plug was vertical mount as usual for mains sockets vs office lab testing horizontal:

It turns out that the sideward/vertical load of weight of plug/adapter combined with differences in contact metal shape and area of the various ‘shaver style’ adapters meant that, esp if combined with slightly bent/deformed main adapter pins as seen in photo, a small amount of ‘creep’ was enough to break mains connection causing unit to go off line…a re-seating and holding with tape solved initial problem but it cost 2 day trip to other end of country with attendant costs and opportunity impact + damage to client confidence to get resolved! :frowning: Now have to be very careful what type of adapter used for installs…with another ‘suspect site’ due for a visit shortly!

I flagged this a while ago with Laird tech and prod management teams to give them chance to root problem and source alternate supply for future sales - I have highlighted the slip on style adapters such as used by Lorix, Multitech and others, which allows for various territory support inc EU, UK, US & AU with one unit :slight_smile: I know they are close to finding a sourcing fix hence posting this caution now, after holding back for several weeks as hopefully they will be offering improvement to market shortly :slight_smile: :ok_hand::tada:

In the meantime the last 10 or so gateways I have deployed myself & 40-50+ done by/for clients have been other vendors solutions inc reverting again to some RPi derived platforms…

Hopefully Laird will become a ‘favourite’ once more early in the new year…:thinking:

(Lachlan Etherton) #166

Thank you for the extensive reply mate. Great to hear someone else using these gateways.

Just a couple of things. Do you know what the SD card slot is used for? I can’t seem to find any documentation on it other than a mention of where it is located in the user guide and no forum seems to describe its use.


In addition, other than the power adapter problem, why have you stopped using the gateway and what have you switched to instead? Do these newly chosen gateways provide greater functionality/ features as well? I know that’s quite a few questions, but I am going to be deploying a few gateways and really want to provide the best value for money solution for my clients and seeings as you’ve done quite a few, I might as well ask you.

Keep in touch.

(Jeff Uk) #167

From discussions I have had the SD card slot is not (yet) an end user service item. may get used for future features/capabilities or in connection with cellular upgrades, hence you wont find many references to it other than its location. I’m hopeful it may get s/w update to allow local storage option or for easing s/w updates etc. but don’t hold breath…

For me it all came down to the PSU! I also use these units re-housed in external boxes as proto earlier in the thread, and where PoE or Solar supply used, hence where Laird supply not used/isn’t issue. That one bad example cost £hundreds in direct travel & subsistence costs, plus 2 days eng time plus ‘opportunity cost’ of not doing other things…total £thousands! :frowning: Which totally offset the price benefit seen c/w alternate units, hence decision to (sadly) stop using for basic deployments until Laird supply with pucka UK PSU’s. That said I have clients aware of the issue who are still planning to deploy the Lairds in Q1 where I will be providing training/consulting support - as noted ‘they just work’ :wink:

As called out in other Forum threads there are techniques that can be applied to wear leveling and wear-out mitigation for the uSD cards used on RPi based platforms and others so once they are adopted and applied to standard image builds the on cost isnt huge and card upgrades scheduled in as part of planned s/w updates & maintenance routines (annual/bi-annual) mean risk mitigated in large part. That combined with some newer units and boards that have come to market since the summer has made such units viable and cost effective again. I and clients using a range of alternate gateways that are off the shelf - I’m still experimenting to determine which one I prefer and would like to use going forward. Several vendors have sent me sample units for eval & feedback as part of my consulting activities so wont ‘declare’ yet, though the Multitech & Kerlink production units seem to get good press/feedback, as do the iMST Lite Gateway & RAK Pilots for engineering/test deployments and I really like the look of the pending new Reece Innovation LGW01 for outdoor use, though it was still awaiting approvals when I saw it in October and the guys are late shipping me test/evaluation units for my trials. I have more project time allocated in Jan & Feb for evaluating other suppliers GW’s if/when they decide to ship me units… :slight_smile:

Will post on forum once I finish evals…

(Everhamme) #168

What size is the barrel power connector?

(Jeff Uk) #169

I believe it is a 5.5mm OD (just measured!) 2.1mm ID (for pin), I found from trial and error that was most reliable/snuggest fit with a range I had in stock from configurable PSU’s that this was best fit. 4.75-6mm OD worked for me as did 2.1 & 2.5mm pin - 1.7 was too narrow. YMMV as some barrels as just hollow center and some have flexible blades inside to ensure tolerance & good contact to pin…

(Bryansmith) #170

I questioned the Laird folks about this in regards to software updates out in the field with out internet connectivity, which is a realistic scenario. I didn’t get a favorable answer but I can tell you for a fact that this was supported at one point and if you hack around a bit you can get it to work again.

It’s definitely available from the command line and with a bit of work potentially from the web gui. If you have root access to the device you can upgrade from where ever you’d like. I’ll address this later.

The SD card slot is in use and has been ever since they’ve released this unit. It gets mounted at /media/usb0.

I’ve been planning on releasing a video on how to get root on this device quite easily by using the sdcard. My RG1XX is thoroughly hacked for GPS, VPN, remote logging, ssh, lora-gateway-bridge and various other things. This unit isn’t closed or proprietary really.

(Jeff Uk) #171

Yes please! :slight_smile: …A TTN Lab Story?

(Lachlan Etherton) #172

Second this! Would be great to hear how this is possible!