Problem with Nodes, Gateway Traffic received but not shown in application data


(Mawuottor) #1

Hi iam new developing with LoRaWan and right now i have to gateways.
The first one is built using a RPi 3 and a Dragino RFM95 Hat , the second one is a multitech conduit.
I have already activate both gateways in the platform but i have the same problem receiving the data.
like you see in the nest picture i receive the payload and can visualize it in the gateway traffic.


but then when i go to my application data , there is no data in this part and the platform tells me that my device had never connect, but is the same device that the gateway show that the information was received, i have this problem using an RN2093 Microchip Mote and algo with and arduino with a RFM95 Dragino Hat.

is there something missing? or anything i need to do to vinculate this devices with the aplication?
Im using ABP activation mode and using network session key and app session key for the connection.
Sorry for the long post, but hope someone can help me with this.
Im in México , so im using 915Mhz frequency.
Regards.
Miguel W.


#2

did you use the right byte order for app and session key ? depending on the used sketch either msb or lsb need to be used for RFM95 Dragino Hat.


(Robputt796) #3

Hi,

I am also seeing this symptom for the last 3 days, however previously the node was receiving application data fine. I didn't see this thread until I already made my own :frowning: - https://www.thethingsnetwork.org/forum/t/the-things-network-super-unreliable-the-last-few-days/7441

Best Regards,

Rob


(Mawuottor) #4

Hi Salfare, i check my code and i was using LSB with the dragino example code from their github (Link) ,but like you said, this was the problem, i change the network session key and app session key to MSB and know i see the information in the Application Data section.
Regards.


(Mawuottor) #5

Hi robputt796, i had just try the solution that salfare recomends and my problem was solved, i dont know if there is another problem with your application data section, if you solve it please share it with us.
Regards.
M.


(Robputt796) #6

Hi @mawuottor,

I can confirm I am already using MSB however the problem still persists.

Best Regards,

Rob


(Srbotero) #7

Hi,

I'm having the same problem and I tried almost everything, I don't know what else to do. I'm following this tutorial to the node dragino . I changed the app and session key byte order but it didn't work and I also reset frame counter and it didn't work. What can I do?

Thank you!


(psyec) #9

I Am also facing the same problem,can you tell me what is MSB and LSB


#10

Check this wikipedia article.


(psyec) #11

We have gone through wikipedia article and changed the APPSKEY,DEVADDR and NWSKEY to MSB ,but the problem still persists.


#12

What code are you using?


(psyec) #13


This is the code we are using.


#17

#18