RN2483 Adaptive Data Rate


(Franck Cordu) #1

Hi there,

I’m trying to make the ADR work on my RN2483 Module but somehow my SF isn’t changing (and I’m pretty sure it should). There is my configuration :

  • I’m using it in ABP mode, with 8 channels defined like this :
  • data rate from 0 to 6
  • one of these frequency is defined for each channel : 868100000, 868300000, 868500000, 867100000 , 867300000, 867500000, 867700000, 867900000
  • with a duty cycle of 1/8, that is to say a value of 799 for each channels
  • Apparently the SF used by default on the module is SF12.

I’m sending 15 bytes every 2 minutes. Once the send is done, the module is shutdown and will be turned on 2 minutes later.

There is only one gateway in my area (homemade, based on the ic880A concentrator on a raspberry pi) and it is right next to the sensor so I would expect a diminution of the SF.

On TTN I can see that the downlinks are sometimes sent (on the application console and on the gateway console) but nothing change on the module response that remains in SF12.

What is strange is that I get a downlink almost after every message received by TTN and sometimes it stopped…

Any idea of what I’m doing wrong there ?

Thank’s for your help :grin:


(Jeff Uk) #2

First thing is move node and GW a few metres apart - pref >5m, 10+ if poss as if right next to each other (<0.3-~2m) you will be operating in the near field vs far field and system may detect across mutiple channels and with internal cross-talk confusing RF front end/Baseband processing & modem and hence the ADR options…on TTN IIR the system will then monitor around 20 messages to then determine the right ADR settings to send to the node…

Good Luck!


(Franck Cordu) #3

thank’s for your help ! :grin:

I moved the sensor to 10 meters but I’m now pretty sure the gateway is stuck. I can see that the downlink are “sent” on the application console but not on the gateway console. Is it possible that my gateway limitate itself its own downlinks messages ?

I will try to let it run in this configuration to see if there is any evolution in terms of downlinks. I will come back with more informations soon.

Thank you again !


(Franck Cordu) #4

So It’s still not working :thinking: … I decoded the physical payload available on the gateway console and the Fctrl.adr is set to true.

I have a question, is the ADR still working if the RN2483 is shutdown ? I suposed yes until now but maybe it’s not the case ?

Any help or piece of advice will be appreciated :grin: