RN2483 problem temperature



i'm using the rn2483 for cumminicate to the gateway. I have a switch power supply with 3.3V and a battery.
When the temperatura go down the 10°C the module stop to work when i try to set the OTAA join.

18:03:49.525> LORA get ver: RN2483 1.0.1 Dec 15 2015 09:38:09
18:03:49.525> LORA HWEUI: 0004A30B001XXXX
18:03:49.587> LORAWAN set freq 868 Mhz: ok
18:03:49.587> LORAWAN resume: ok
18:03:49.587> LORAWAN DEVEUI 0004A30B001XXXX: ok
18:03:49.587> LORAWAN setAPPEUI XXXXXXX...: ok
18:03:49.650> LORAWAN set appkey XXXXXX....: ok
18:03:49.650> LORAWAN set ar on: ok
18:03:49.650> LORAWAN set pwridx 1: ok
18:03:49.650> LORAWAN set dr 1: ok
18:03:49.650> LORAWAN set adr off: ok
18:03:49.650> LORAWAN set retx 10: ok
18:04:53.585> LORAWAN join otaa: ok
18:04:53.585> denied
18:05:57.523> LORAWAN join otaa: ok
18:05:57.523> denied
18:07:01.399> LORAWAN join otaa: ok
18:07:01.399> denied

where the module return danied. When the temperature return up the 10°C the module return to work.
I have ask here http://www.microchip.com/forums/m951726.aspx#951878 but without response.

My cpu and all the other electronics work fine. I have try to coated the pcb with an epoxy resin but without solve the problem. The power supply and the battery are stable at low temperature
Someone else have the same problem with this module?


Getting Badgerboard to work with TTN
  • I see now that your battery voltage at that temp = stable (because LipO's only below zero can give problems)


Yes the battery voltage is stable. For test if could be a battery problem i had change the battery with another that had an ambient temperature (25°C) but the problem persist. I have also try powering the device with usb and the problem is the same.

Someone else use this device outdoor and with low temperature?


so, the device worked inside, at room temp, and as soon as you take it outside (below zero) it doesn't work ?
that's strange ..


Yes, correct. Same problem with 2 nodes, all two covered with silicon for protect from humidity


Just some "thinking outside the box": as you are going outside to a different location to have a lower temperature: this isn't related to coverage (IE a lower location)? Did you inspect RSSI values. Although I wouldn't expect coverage issues when the gateway is in/on your building and you stay near it, it might be something to have a look at.



if i put the sensor in the fridge it work for some minute. When it reach low temperature instead stop to work. So: same position, only the temperature change


could be an error in your 'temp' code and has maybe nothing todo with the RN2483

try it outside your freezer (ice water) with the processor connected, so you can read the sensor output, what happens below zero, getting a negative reading ? is the data processed or 'hangs'


I have found the temperature has to go down to -20 for the batteries to be affected. Just moving the sensor from indoors to outdoors is not enough to drop the voltage that much.

Probably more like a coding or range issue.



I have try to pick the sensor from the freezer and put on my table. Connecting the debugger i can see the commands visible in the first post. The cpu work fine, in fact i can set the parameters and execute the command join. At this point the response is always denied.

Someone else have a node with rn2483 to test at low temperature?



what temp sensor do you use ? - and can you emulate the freezing temp on your desk (ice cube or something) with the debugger connected.

what mcu do you use ?

** if you close the freezer door, you created a faraday cage, maybe that's a reason why it doesn't work IN the freezer


That problem could be solved using a external antenna. Or use a piece of RG-174 coax that will have enough RF leaking throw it that a 50 Ohm resistor at the end of it as antenna would do the trick and connect to a 12m away gateway.

Putting the gateway in the freezer might be a bad idea. :blush:


i use a freescale arm. I have a cable that come out from the freezer and i read the printf command with a ft232. No the freezer isn't the problem. I put the device in the freezer and it work for 20min before stop, the time to reach 0°C .

The sensor is the tc1047


That problem could be solved using a external antenna. Or use a piece of RG-174 coax that will have enough RF leaking throw it that a 50 Ohm resistor at the end of it as antenna would do the trick and connect to a 12m away gateway.

Putting the gateway in the freezer might be a bad idea.

ok i will try to use another antenna. Yet i always use external antenna


Hello to all.

Same problem here. Two devices working without issues in positive temperature range. When i put them in freezer, they work for a short while, and suddenly transmitting of frames will stop.

Unit RN2483, FW 1.0.1 .

Does the topic starter have any answers to this issue already ?

Thanks for reply,



what is the power source... lipo ?


Hello, yes it's a lipo. Third unit also has problems with temperature. All RN2483 are from the same batch 1613 QHM. To be sure it's not the lipo i will try other power source. However topic starter did also change the power source, with no result.


Hello i have do some other test and yes it is the lipo. I don't understand why because i have a stable 3.3V at low temperature but using a NIMH now work.


Ok. I will do some more tests with different batteries also. If this is true, lots of early adopters will get problems this winter, cause most are using lipos.


Unit tested with Lithium-ion non rechargeable battery.
Still working after 30min @ -15 C.

I'm researching the issue now, probably the ESR from the lipo (chargeable), has something to do with it.

Keep you all posted.