RN2483 problem temperature


Counting down now @ -19 C, unit still working. Battery @ 3.64v
Will test for several hours now.


Battery still stable and unit now @ -24C . This looks promising .


I tested for about 4 hours now with the Saft LS 14500, and it still works. No issues whatsoever. A very stable battery status and temperatures downto -25C
I 'll now test with the last battery combo, this will be the GP NiMH 3 x 1.35v .

Test will be made with the same device @ same circumstances.


And reception has stopped @ exactly 16.94 C. Tomorrow i will do some more tests with different unit, same batteries. For now i call it a day, saft has the only working solution up till now. But i wonder why the other batteries are so close to each-other with respect to temperature (both stopped @ almost exactly -17 C), however these are completely different types with different voltage. (4.5v & 4.09v)

As soon as the unit comes into positive territory, it automatically starts sending again. (don't have to do hard reset )


I have problem with 4 Nodes of 10 if temperature goes down. It is about 0°C.
Every commands works fine. But "radio_tx xxxxx" doesn't response at all. Then you need reset the module and everything is fine until "radio_tx" command.
For me it looks like issue on RN2483. I have installed that 10 Nodes in May, but these days someones stop workning.


Could the power supply be insufficient at that temperature for those nodes? TX requires a more power compared to the other operating modes.


I don't think so. Just for sure I used batteries for GSM which has no problem with 1.5A .


Hello "jhulka"
Are you using Lipo's in this project, cause the standard ones are not rated for temps < 0 deg C.


Battery isn't the problem. I am using er34615m, but I tried at balcony with laboratory source. The same battery works fine with different module.
I have a suspicion that the problem is first serie of RN2483 which strats with 15xxxxx. I let you know as soon as I test all of them.


Could it be that there are two problems regarding temperature?

  1. Low capacity of the battery. -> unexpected hardware behaviour.
  2. Sign bit of a negative temp-value. -> unexpected software behaviour.


Again when the module stop working. Every command work fine except "radio tx ". It is even possible to receive data via radio. I know the TX is worst for comsuption, but I check that with external power supply.

Some modules works fine with negative temperature. And there no issue with negative values.

(Led) #52

Hi jhulka,

I have same problem with RN2483. Somewhere starting at -11°C and down 'radio tx xxxx' command is not sending data out, at least receiver get nothing. I tested 4 modules and all have same issue. Firmware version is 1.0.1. When I bring it back to warm environment then it started to work again. I tested it also such a way that first I cooled it down to -20°C, then powered on and started to send data. Receiver which was in warm environment got nothing. When I brought TX back to warm and all the time it sent data but in this case receiver never get data. After reset the TX receiver started to get data normally. So far I didn't find any workaround to get TX working correctly.

Also I made test that I put both TX and RX to -20°C. Receiver stopped to receive data too at low temperatures. Then I used another TX at +25° for data transmission. RX in -20° didn't receive any data.

Sounds serious hardware issue. Time to add ticket to Microchip. Or any suggestions?

(Led) #53

I got answer from Microchip that they are working on firmware fix for that issue


I'm also have the tx problem when below -5°C.
When the temperature rises above -2°C it starts again.

Info : for testing I have power my node over a external power supply to remove battery out of the test equation. Same result.


I got answer from my distributor that Microchip working on that. Let's hope it will be soon.

Thank you for yours replies. I wasn't sure if that is hardware issue.


Did u get any update from Microchip? Do you mind sharing your case number? I would like to reference your case in my ticket. I observe similar issues with both rn2903 and rn2483 modules, and this is no battery related at all. Btw. You should be able to see similar behaviour with their mote....


Same applies to North American version, both modules are failing in low temp....

(Led) #58

Sad to hear that US version have same issue - I need both versions.

So far no solution from Microchip. They just said that issue has been identified in some modules and they are working on it.

My case number: 00125837

I informed also distributor who is selling their modules in hope that they could solve this issue quickly. Now is winter and systems with Microchip module are failing and causing disasters...

(Phang Moh) #59

In my personal opinion, I'm suspecting this is due to the crystal tolerance drifting when used at these low temperature (would probably drift too at higher temperature). With setting at SF=12 and BW=125kHz, these are at the border of working operation for crystal with 10 ppm provided the temperature is not too far away from room temperature. This is just a hunch. But if this is correct, there's no quick fix for this. Using a TCXO crystal would be a better solution but it will be more expensive and it continues to run even though during sleep mode (so it consumes some current in mA range unless the PIC MCU inside the module uses a pin to shut it off but wake up time will be affected).


What do you think about different setting of SF or even switch frequency to 433Mhz?