RN2483 + Raspberry Pi


#1

Hey all!

At the moment I'm trying to get the RN2483 working on my Raspberry Pi model 3 v2. The previous owner of the chip used an Arduino to power and control the chip. So here's what I've got:

1x Xbee Socket
1x RN2483
1x Raspberry Pi model 3 v2.

The RN2483 chip is socketed into the Xbee socket. Can I simply connect the 5V, GND, Tx and Rx to my Pi GPIO headers? I've already tested my Tx and Rx pins with a simple java loopback program and the UART seems to work. If I now connect the RN2483 to the UART pins and the ground and power, it should all start to work right?

Thanks in advance!


#2

Best to use 3v3, but the short answer is "yes, it just works".

For a simple/clean solution, you might just buy this board. Attach the headers and you're done.

https://www.wirelessthings.net/slice-of-pi-add-on-for-raspberry-pi


#3

Thanks for the response! I've connected everything and ran my program. Unfortunately I'm getting no response at all from the RN2483.

I've programmed my Pi in Java using the Pi4J library. When I connect the Pi's Tx and Rx, I get a nice echo/loopback so the UART seems to work...

Do you have any suggestions to debug the problem of getting no response from the RN2483?

Edit: My UART set up is: 57600 bps, 8N1, no flow control. I'm sending "sys factoryRESET", but get no response after sending the command.


#4

Well, that's annoying.

Here's what I would do if I were in your shoes:

Option 1: use a cable such as this one to put the Lorabee on a breadboard, and connect it to your PC/Mac and verify that it is working.
https://www.adafruit.com/products/954?gclid=Cj0KEQjw0MW9BRDxtYTn2_S699MBEiQAw33y43yyRv6d5LXJwfki9Raz_gg4COTu8H0OxfkPkBYvnFQaAn1G8P8HAQ

Option 2: Solder the SJ1 on the back side of the Lorabee, which then delivers the hardware reset functionality of the RN2483 to Pin 17 on the XBee socket. Once you have done this, if you start up your test program and tap pin 17 with a ground jumper, you should see the RN2483 startup banner being delivered to RX on the pi.


(Rene) #5

Did you connect your RPi's TX line to the RX line of the RN2483 and vice versa? The commands to the RN2483 should be to its RX line, while the response from the RN2483 is on its TX line.


#6

Ye I've connected the 5V, Tx,Rx and GND to the corresponding pins on the Xbee socket.(I've double checked that it's 'cross-cabled'!) I might as well try to connect my GPIO headers directly to the RN2483, without using the Xbee socket. I'll then use 3.3V since that's the voltage which the RN2483 uses to operate on, right?


#7

Have you terminated with CR+LF after sending the command?
The RN2483 parser won't react unless it sees CR+LF!


#8

Yes I've terminated every command with CR+LF. I'm using the Pi4J java library in order to use the GPIO headers on my Pi. This library has a method 'writeln' which sends ASCII characters over UART and terminating the line with CR+LF. I've also tried to use their 'write' method and using \r\n as a suffix of my command String.


(Jose Marcelino) #9

The Pi 3 UART has been one big messy clusterf* because of how they connect the Bluetooth side, documented in this thread https://www.raspberrypi.org/forums/viewtopic.php?f=107&t=138223

The only way I got mine talking to anything was to disable Bluetooth and remap /dev/ttyAMA0 back to the serial pins. I followed the instructions in that thread, basically add the line:

dtoverlay=pi3-miniuart-bt

to /boot/config.txt and reboot your Pi. Then use /dev/ttyAMA0 to talk to your device.


#10

Thanks @jmarcelino, I'll look into that! One thing I don't understand though is: I'm already using /dev/ttyAMA0 to talk to the GPIO serial pins. I even connected the Rx and the Tx of the GPIO pins and stated that it echoes, meaing the UART should work, right?

EDIT: When I change /boot/config.txt and add dtoverlay=pi3-miniuart-bt, my pins dont echo anymore, so it looks like this isn't gonna fix it...


(Jose Marcelino) #11

I fear something may have changed again in the crazy world of Pi 3 UART and my info has been outdated by the latest firmware.

So remove the dtoverlay line I suggested and try this one instead

enable_uart=1


#12

Thanks for the quick responses @jmarcelino! I've tested and confirmed that my UART is working. I connected my Pi via an FTDI cable to my windows PC and monitored the COM port with SerialMonitor. I can see the sys factoryRESET string coming in and starting on new lines. I think I'm doing something wrong with connecting the RN2483 to my Pi...


(Mailsc123) #13

Since you mentioned you got the response for factory RESET, means you are using ttyS0. Right ?
Also, this is more than 6 months now, did you finally solve the matter ? Please let us know. :slight_smile:


#16

#18