Single Channel Packet Forwarder part 2 [Deprecated]

@mw12554 Maarten can you comment on this (above):

With all respect for the work done, but committing code that breaks is bad practice.

Both single channel gateway implementations below give errors during compilation in Arduino IDE v1.8.4.
(And even more issues in PlatformIO but latter probably due to my limited PlatformIO experience.) and

I used a custom pin configuration because I wanted to add an SSD1306 OLED (I2C) display for showing status messages. That did not yet workout however because I ran out of of available pins/ports.

Hallard’s board connects RFM95W’s DIO0, DIO1 and DIO2 all to a single ESP8266 GPIO port (with diodes, using a separate diode per DIOx port). I don’t have Hallard’s board but I may give that a try myself. I read somewhere (can’t remember) that this is not an ideal situation however.

Andres Spiess has a version of the software that already includes support for SSD1306 display, but is based on the much older things4u v1.0 version:

Hardware used:

(I did solder the RFM95W module onto the adapter board manually.)

I succeeded to get both version 3 and 4 of things4u ESP single channel gateway working with PlatformIO.
Including the ‘Hallard’ pinout. Connecting DIO0 and DIO1 via diodes to a single GPIO port, which left D1 and D2 free for the display.

while trying to build a SC gateway for development purposes only, I encountered an issue when connecting an ESP8266 to an RFM95W with the following software:
I followed the readme and chose a “COMRESULT” pcb layout.

My connections are the following:

RFM95W ------> ESP8266
DIO 0/1/2 from RFM to D1/D2/D3 esp
G from RFM to G esp
SCKfrom RFM to D5 esp
miso from RFM to D6 esp
mosi from RFM to D7 esp
NSS from RFM to D8 esp
3.3V from 3.3V

The problem is that it can receive any packet (and forward to TTN), but is unable to send anything back (so OTAA will fail).
Can anybody spot my flaw? Maybe the RFM95W is different to other LoRa-modules available?


In order to have the gateway send downlink messages on the pre-set spreading factor and on the default frequency, you have to set the _STRICT_1Ch parameter to 1. Note that when it is not set to 1, the gateway will respond to downlink requests with the frequency and spreading factor set by the backend server. And at the moment TTN responds to downlink messages for SF9-SF12 in the RX2 timeslot and with frequency 869.525MHz and on SF12 (according to the LoRa standard when sending in the RX2 timeslot).

1 Like

…but for LMiC, disabling uplink frequencies might not affect the downlink frequencies, in which case you need to ensure the frequencies as commanded by TTN are used by the node, just as usual in LoRaWAN.

I can follow your thoughts but unfortunately it doesn’t make a difference with my gateway. Still searching for the problem


8 posts were merged into an existing topic: Node not showing up in Applications

I have been experimenting with TTN last year with RPi based single channel gateway and RFM95 and RN2483 based nodes. The RPi and MCU’s were later re-used for other projects. Not long after the TTN environment was updated/changed.
I decided to wait until the TTN gateways that were planned for my neighbourhood become available before picking up again. However, availability of the ‘The Things Network Gateway’ devices (and their roll-out) has been seriously delayed and there still is no TTN coverage in my area. I decided to setup a single channel gateway again instead and continue from there.

I currently have a running Things4U ESP single channel gateway v5 (hardware: ESP-12E, RFM95W and SSD1306 OLED display). I am yet unable to test it due to a lack of nodes. Next step is setting up some nodes that will work with this gateweway.

I have the following questions, hope you can help:

  • Where can I find the most actual ‘standard reference’ code for a TTN node (RFM95/SX1276 based) for AVR (e.g. Pro Mini) and ESP8266?

  • How to properly configure the nodes / adapt the code so the nodes will work successfully with the Things4U single channel gateway?
    Both ABP and OTAA. I’m looking for some clear step-by-step instructions and/or code examples.

  • I have previously used Thomas Telkamp’s single channel packet forwarder for Raspberry Pi software but that is no longer maintained (“this repository is deprecated, and the code is not up-to-date to use on The Things Network”).
    What is the best alternative/most up to date software for a Raspberry Pi + RFM95W/SX1276 based single channel gateway?

Hi all,

I am playing since some weeks with BME280 and an arduino pro mini with the code from lex (LoRaWAN_TTN_Env_Node). Everything was fine. Since some days (tried also the cayenneLP integration) I didnt receive traffic neither in the traffic tab of my two getways within the ttn console nor in the data tab of my device. Gateways were an Dragino Raspi hat with the single_channel_paket_forwarder and the Dragino LG01-P. Both gateways are connected to the ttn.

I also changed the to the “relax frame counter” and I can also see the data packets sended by the raspi gateway in the raspi terminal. I get also the EV_TXCOMPLETE in the console. I use ABP btw.

Any ideas what’s wrong ?
Thanks for your help !

I have a single channel gateway ( running.
Have no nodes running at the moment but the gateway picks up a few messages per day.
In TTN Console / Gateway / Gateway Overview I can see that the messages are received by the backend but no traffic is showing up in Gateway Traffic.
The gateway is only running since a few days. I have not seen any traffic showing up in ‘Gateway Traffic’ yet.
This appears similar to your issue.

Hey Guys,
I have a problem with my Single Channel Gateway and a sensor node.
My gateway is a Raspi + Dragino-LoRa-GPS-Shield. The sensor node is an ArduinoUNO with a Dragino-LoRa-Hat.

The code i use for the node is this:

The right keys from the console are in MSB inserted.
I can receive frames from the node in the gateway traffic window but in the application data and device data there are no frames at all and the device status is “never seen”.
The device is activated over ABP.
I tried to reset Frame Counter Checks without success. Deactivate Frame Counter Checks doesn´t help too.

I hope you can help me. There are a few threads with the same or nearly the same problem but the answers dont help in my case.


Not an answer to your question but I’m curious which single channel gateway software you are running on the RPi. Do you have a link?

This one:

Have you noticed the following?:

Please note this repository is deprecated, and the code is not up-to-date to use on The Things Network.
This repository will not be further maintained. Please find another repository if you want to deploy a single channel gateway.

Did you make any changes to make it ‘up-to-date’ (I’m not sure what parts need an update, if any)?

I found this guide:

It is based on this repository and when you follow the instructions, there will be some changes in the code…
the changes depend on your location of course…

I don’t see any code changes there, only configuration.
I’m not sure if any changes are needed but “depricated” and “not up-to-date” suggested to me that the code may have to be adapted to changes done on the TTN network.
I’m looking for an up-to-date version of a single channel gateway for RPi myself. No response on my question yet though (Single Channel Gateway part 2).

Hi all,
I’ve been trying to run a single channel gateway with downlink capability but I could not get it work. I`m trying the C++ version with now successful. I could make it work only on Lua version.
Does anyone could run the version in C++ with downlink?

Additionally I could not run the new 5.0 version. it causes ESP to restart in loop.
Does anyone have the same error? And could solve it?


1 Like

Could your problem be related to incorrect wiring/configuration?

I have Things4U esp-1ch-gway v5.0 running on ESP8266 (ESP-12F) and get feedback on serial monitor and OLED display, no restarts here.
But it does not see my nodes yet. I tried with both _STRICT_1CH enabled and disabled on the gateway and tried nodes with both ABP and OTAA but the gateway does not pick up any traffic from my nodes.

I’m going to recheck my wiring.