[solved] Raspi3+Ic88a gateway not connected on TTN


(Vcs Iot) #1

------------------------------------------------------ post editted


(Vcs Iot) #3

Hi,
I have a Pi3 connected with IC88a board using SPI (with jumper cable).
I know that spi could give some problem with jumper cable but since my log says “concentrator started” I think the spi is working. Even if I send packet with util_tx_test I get the LED on IC88a.
I used the example in this link in order to create the gateway:

https://github.com/ttn-zh/ic880a-gateway/wiki

I have registered my gateway on TTNbut I see that my Gateway is “not connected” on TTN console
this is my log file:

[TTN Gateway]: Use Gateway EUI B827EBFFFE6FC2F6 based on eth0
*** Poly Packet Forwarder for Lora Gateway ***
Version: 2.1.0
*** Lora concentrator HAL library version info ***
Version: 3.1.0; Options: native;
***
INFO: Little endian host
INFO: found global configuration file global_conf.json, parsing it
INFO: global_conf.json does contain a JSON object named SX1301_conf, parsing SX1301 parameters
INFO: lorawan_public 1, clksrc 1
INFO: Configuring TX LUT with 16 indexes
INFO: radio 0 enabled (type SX1257), center frequency 867500000, RSSI offset -166.000000, tx enabled 1
INFO: radio 1 enabled (type SX1257), center frequency 868500000, RSSI offset -166.000000, tx enabled 0
INFO: Lora multi-SF channel 0> radio 1, IF -400000 Hz, 125 kHz bw, SF 7 to 12
INFO: Lora multi-SF channel 1> radio 1, IF -200000 Hz, 125 kHz bw, SF 7 to 12
INFO: Lora multi-SF channel 2> radio 1, IF 0 Hz, 125 kHz bw, SF 7 to 12
INFO: Lora multi-SF channel 3> radio 0, IF -400000 Hz, 125 kHz bw, SF 7 to 12
INFO: Lora multi-SF channel 4> radio 0, IF -200000 Hz, 125 kHz bw, SF 7 to 12
INFO: Lora multi-SF channel 5> radio 0, IF 0 Hz, 125 kHz bw, SF 7 to 12
INFO: Lora multi-SF channel 6> radio 0, IF 200000 Hz, 125 kHz bw, SF 7 to 12
INFO: Lora multi-SF channel 7> radio 0, IF 400000 Hz, 125 kHz bw, SF 7 to 12
INFO: Lora std channel> radio 1, IF -200000 Hz, 250000 Hz bw, SF 7
INFO: FSK channel> radio 1, IF 300000 Hz, 125000 Hz bw, 50000 bps datarate
INFO: global_conf.json does contain a JSON object named gateway_conf, parsing gateway parameters
INFO: gateway MAC address is configured to AA555A0000000608
INFO: Found 2 servers in array.
INFO: Server 0 configured to “router.eu.thethings.network”, with port up “1680” and port down “1681”
INFO: Server 1 configured to “iot.semtech.com”, with port up “1680” and port down “1680”
INFO: Found 5 system calls in array.
INFO: System command 0: “df -m”
INFO: System command 1: “free -h”
INFO: System command 2: “uptime”
INFO: System command 3: “who -a”
INFO: System command 4: “uname -a”
INFO: monitor hostname or IP address is configured to “127.0.0.1”
INFO: monitor port is configured to “2008”
INFO: ghost hostname or IP address is configured to “127.0.0.1”
INFO: ghost port is configured to “1918”
INFO: downstream keep-alive interval is configured to 10 seconds
INFO: statistics display interval is configured to 30 seconds
INFO: upstream PUSH_DATA time-out is configured to 100 ms
INFO: packets received with a valid CRC will be forwarded
INFO: packets received with a CRC error will NOT be forwarded
INFO: packets received with no CRC will NOT be forwarded
INFO: GPS serial port path is configured to “/dev/ttyAMA0”
INFO: SSH path is configured to “/usr/bin/ssh”
INFO: SSH port is configured to 22
INFO: HTTP port is configured to 80
INFO: NGROK path is configured to “/usr/bin/ngrok”
INFO: Reference latitude is configured to 10.000000 deg
INFO: Reference longitude is configured to 20.000000 deg
INFO: Reference altitude is configured to -1 meters
INFO: GPS is enabled
INFO: Using fake GPS coordinates instead of real.
INFO: antenna_gain 0 dBi
INFO: Upstream data is enabled
INFO: Downstream data is enabled
INFO: Ghoststream data is disabled
INFO: Radiostream data is enabled
INFO: Statusstream data is enabled
INFO: Beacon is disabled
INFO: Monitor is disabled
INFO: Platform configured to “IMST + Rpi”
INFO: Contact email configured to “operator@gateway.tst”
INFO: Description configured to “Update me”
INFO: found local configuration file local_conf.json, parsing it
INFO: redefined parameters will overwrite global parameters
INFO: local_conf.json does not contain a JSON object named SX1301_conf
INFO: local_conf.json does contain a JSON object named gateway_conf, parsing gateway parameters
INFO: gateway MAC address is configured to AA555A0000000608
INFO: packets received with a valid CRC will be forwarded
INFO: packets received with a CRC error will NOT be forwarded
INFO: packets received with no CRC will NOT be forwarded
INFO: GPS is enabled
INFO: antenna_gain 0 dBi
INFO: Upstream data is enabled
INFO: Downstream data is enabled
INFO: Ghoststream data is disabled
INFO: Radiostream data is enabled
INFO: Statusstream data is enabled
INFO: Beacon is disabled
INFO: Monitor is disabled
INFO: Successfully contacted server router.eu.thethings.network
INFO: Successfully contacted server iot.semtech.com
INFO: [main] Starting the concentrator
INFO: [main] concentrator started, radio packets can now be received.
INFO: [up] Thread activated for all servers.
INFO: [down] Thread activated for all server iot.semtech.com
INFO: [down] Thread activated for all server router.eu.thethings.network

##### 2018-05-30 16:29:39 GMT #####
### [UPSTREAM] ###
# RF packets received by concentrator: 1
# CRC_OK: 100.00%, CRC_FAIL: 0.00%, NO_CRC: 0.00%
# RF packets forwarded: 1 (16 bytes)
# PUSH_DATA datagrams sent: 4 (910 bytes)
# PUSH_DATA acknowledged: 0.00%
### [DOWNSTREAM] ###
# PULL_DATA sent: 6 (0.00% acknowledged)
# PULL_RESP(onse) datagrams received: 0 (0 bytes)
# RF packets sent to concentrator: 0 (0 bytes)
# TX errors: 0
### [GPS] ###
# Invalid gps time reference (age: 1527697779 sec)
# Manual GPS coordinates: latitude 10.00000, longitude 20.00000, altitude -1 m
##### END #####

my local config file is:

{
“gateway_conf”: {
“gateway_ID”: “AA555A0000000608” /* you must pick a unique 64b number f$
}
}

My global_ config is

“gateway_conf”: {
_ /* change with default server address/ports, or overwrite in local_conf$_
_ “gateway_ID”: “AA555A0000000608”,_
_ /* Devices */_
_ “gps”: true,_
_ “beacon”: false,_
_ “monitor”: false,_
_ “upstream”: true,_
_ “downstream”: true,_
_ “ghoststream”: false,_
_ “radiostream”: true,_
_ “statusstream”: true,_
_	_

_ “server_address”: “router.eu.thethings.network”,_
_ “serv_port_up”: 1680,_
_ “serv_port_down”: 1681,_
_ /* node servers for poly packet server (max 4) /_
_ “servers”:_
_ [ { “server_address”: “router.eu.thethings.network”,_
_ “serv_port_up”: 1680,_
_ “serv_port_down”: 1681,_
_ “serv_enabled”: true },_
_ { “server_address”: “iot.semtech.com”,_
_ “serv_port_up”: 1680,_
_ “serv_port_down”: 1680,_
_ “serv_enabled”: true } ],_
_ / adjust the following parameters for your network /_
_ “keepalive_interval”: 10,_
_ “stat_interval”: 30,_
_ “push_timeout_ms”: 100,_
_ / forward only valid packets */_
_ “forward_crc_valid”: true,_

_	“forward_crc_error”: false,_
_ “forward_crc_disabled”: false,_
_ /* GPS configuration /_
_ “gps_tty_path”: “/dev/ttyAMA0”,_
_ “fake_gps”: true,_
_ “ref_latitude”: 10,_
_ “ref_longitude”: 20,_
_ “ref_altitude”: -1,_
_ / Ghost configuration /_
_ “ghost_address”: “127.0.0.1”,_
_ “ghost_port”: 1918,_
_ / Monitor configuration /_
_ “monitor_address”: “127.0.0.1”,_
_ “monitor_port”: 2008,_
_ “ssh_path”: “/usr/bin/ssh”,_
_ “ssh_port”: 22,_
_ “http_port”: 80,_
_ “ngrok_path”: “/usr/bin/ngrok”,_
_ “system_calls”: [“df -m”,“free -h”,“uptime”,“who -a”,“uname -a”],_
_ / Platform definition, put a asterix here for the system value, max 24$_
_ “platform”: "",_
_ / Email of gateway operator, max 40 chars*/_
_ “contact_email”: “operator@gateway.tst”,_
_ /* Public description of this device, max 64 chars */_
_ “description”: “Update me”_

_ }_

From what i see i have port 1680 and 1681 configured.

How can I get my server connected on TTN ?
At the moment I have no end-node up and running . Is this a problem ? Do I need it in order to solve the gateway connection problem on TTN?

Hope you can help.

Thanks


(Jac Kersing) #4

Download the TTN global config for your region from Github
Also enter a unique ID based on the Mac of your Ethernet interface in the local config.


(Nick Ttn02) #5

Thanks kersing.
All now It’s working . Thanks for your support. Great :slight_smile:


#6