T-Beam TTNMapper Changing SF

Could anyone else with a t-beam V1.0 take a look at https://github.com/kizniche/ttgo-tbeam-ttn-tracker/issues/10

I’m running that code using OTAA with ADR turned off. I’m seeing messages suggesting the link is dead on the screen and the spreading factor keeps increasing at random intervals. I’ve tried turning off link checking but see no difference

Any ideas?

Have you checked the packets with the online decoder to see if adr is off?

Seems I’ve fixed it by turning off link checking elsewhere in the code to ensure it happens after joining the network.

It looks like link checking and ADR are handled differently in LMIC and link checking is now on by default. The link check looks for any downlinks and if it doesn’t see one within 64 uplinks then it will increase the SF. If ADR is turned off then it forces the device up to the highest SF levels with no means for TTN to decrease this. With fixed transmission intervals it becomes very easy to jam a gateway and break the fair use.

Perhaps one for the MCCI team to adjust in the LMIC library