Temperature reading of The Things Node not changing


(Lombi) #1

I connected my new The Things Node with my gateway and uploaded the “Basic” Sketch from the The Things Node examples. Everything works fine. However, somehow the temperature does not change. It always remains “29.06”. No matter where I put it, it always stays there. Does anyone know where the problem could be?


#3

I have exactly the same problem ( although temperature is always 29.19 rather than 29.06 ) using this sketch

I’ve tried changing the sensitivity of the temperature sensor using configTemperature but temperature remains 29.19.


(Lombi) #4

I am using the same sketch as jj1. Could it be a hardware problem?


(Fabian) #5

I have the same issue, although the returned value in my case is always “22.19”.


(Sangrei) #6

maybe its RF and gateway had bad communication.


(Laurens Slats) #7

We found out a small bug in the Node library. @johan just pushed an update, it might take a few days before Arduino updates the library. If you don’t want to wait you can already download it here:


(Guy Dillen) #8

I tried with the new version of the library but have still the same problem: always the same temperature.
In the Arduino IDE (v1.8.5 on macOS): removed/deleted the old v2.0.0 library (~/Arduino/Documents/libraries/) downloaded/installed the new zip-file library 2.0.1. Also, when checking the installed version it keeps saying v2.0.0.

Anyone, any idea what I’m missing here?

Thanks.


(Arjan) #9

Where are you checking that?

If in code, then maybe make a change in your code to force the compiler to use the new library?

If in the IDE: did you restart it?


(Guy Dillen) #10

Where are you checking that?

If in the IDE: did you restart it?

Yes, and re-compiled/uploaded the code.


(Arjan) #11

Seems @johan might have forgotten to increase the version number?

Also, maybe only the examples changed, not the actual library? So, did you try one of the new examples?


(Guy Dillen) #12

Indeed, I used the ‘old’ version of the example basic sketch. I thought only the inners of the library has changed and not the example sketches. Above that I was confused since the library version didn’t match.

Anyway, many thanks @arjanvanb now the temperature is entering correctly.
Thanks.


#13

Yep, I will push this again, thanks for reporting.