Ttgo T-beam


(Rodri16) #69

On the Tbeam GPS is powered directly from 3.3V so it is not possible to switch it off with a GPIO (without cutting the trace)
I go into deep sleep mode on ESP32 but GPS never gets the position because it is rebooting every time
Also trying to reduce consumption in the gps moduel sending Special characters (0xB5, 0x62, 0x02, 0x41, 0x08, 0x00, 0x00, 0x00, 0x00, 0x00, 0x02, 0x00, 0x00, 0x00, 0x4D, 0x) but also without sucess
Take a look to these links
Arduino Forum and characters to send
Neo6 power management
Keep trying, let you know


(Rhinoteknl) #70

i am unable to upload TTN-Mapper coding into TTGO Tbeam , Arduino compiler results this error;

Using library SPI at version 1.0 in folder: C:\Users\dvfd\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.0\libraries\SPI
exit status 1
Error compiling for board Heltec_WIFI_LoRa_32.

Please some body help


(menno faber) #71

Hello rodri16,

I tried the TTGO beam and I did have the same problem as you guys. I was not able to put the GPS in sleep mode and the current was about 50 mA. I then desoldered the GPS module and the current went to 2.2 mA, ever so this is much better, for a low battery application this is still pretty high.

I also tried the TTGO LoRA V2.0 the current in sleep mode is 0.16 mA for this chip. (I did also remove a LED that didn’t turn off, I don’t know if this LED is connected to a GPIO).

Serial.println("go in to sleep");
esp_sleep_enable_timer_wakeup(TIME_TO_SLEEP * uS_TO_S_FACTOR);
esp_deep_sleep_start();

(Rodri16) #73

Cool Jazzip0 , well done!
Did you try sending periodically data to TTN with GPS position and going into sleep mode to see how long does GPS take to have a fix position?


(Rhinoteknl) #75

Hi,
I copied the same code to my TTGO-Tbeam device and there is no compiler error , uploaded smoothly with my device addr and config.

but the device shows no connectivity on TTN console side.

Please help.


#78

@ jazzip0 - if you read this… excuses but I noticed that the system was thinking you’re a spammer.

and I can’t ‘undo’ this


#80

Would it be an idea to use wifi to get location when the gps data is not valid? That way you could keep following your pet indoors.
The downsides here are that the unit is more sized toward a car or an ebike and that it seems to be rather power hungry on battery. Any progress on that? I’ve seen a sketch that delays sending when the position did not change, that should already make a difference.


https://ictoblog.nl/2018/11/25/ttn-mapper-versie-2-ttgo-t-beam-eerste-resultaten


(Deux Vis) #81

@paulb : I’m not working on that project at the moment, but I definitely will integrate any improvements other people are publishing at some point.

If you want it faster, a great way to help is to submit a pull request on github.


(Rem73) #83

Hello,
After many investigations i have the solution to improve the poor level of transmit power on Lora TTGO version 1 at 868 Mhz ( I suppose it is version 1.) The lora TTGo like this :

There are 2 issues :
Software :LMIC library is not clear on this side : Check radio.c file, and go to SX1276 power definition ( about line 476 ) : add this at the end of configuration file: writeReg(RegPaConfig,0b01111111) : It suppose you have a hardware witout Paboost connected.

Hardware:Is low cost, interresting but poor RF design. I remove all the parts at he RF filter. I apply the Semtech ref design to changes 8 capacitors and inductors, and use Pa output without Paboost option
https://www.semtech.com/uploads/documents/SX1276MB1MAS_e315v01a_prod_folder.zip

Measurement are performed with radio laboratory equipement in conducted condition : about ±0,1 dBm absolute accuracy. That’s my job.

Before : 2dBm : about 1,6 mW ( with LMIC modification describe above)
After : 14dBm : 25mW. ( with LMIC same modification describe above)

Conclusion : some issue around lora TTGO could be the result of wrong parts…Simply apply Semtech refdesign could solve the issue, without hard optimisation, without network analyser and PCB effect compensation.

I don’t check the receiver parts. May be some errors on design again…

You cannot have this kind of issues with RFM95 module.


#84

buying a new one is probably cheaper… time is money :wink:


(Verkehrsrot) #85

but sure that the newer versions does not have these or other flaws in RF design?


(DarkMan) #86

nice. tnx.


(Rem73) #87

“buying a new one is probably cheaper…” : No!! You don"t undestand.
I’m pratically sure that the mistake is not on MY board but on ALL TTGO V1 at 868Mhz:
There is a mystake in the layout: use of PAboost with wrong parts. Or it is only a BOM mistake
Understanding PA SX1276 is not obvious: many frequencies and BOM changes, many power configuration, 2 différents layout available, use or not EMI filter…not so easy as connecting an Oled Display.

Any way , if you are not able to do the measurement with specific hardware, you can not see the difference. 10dB Could be over-pass by good or bad cable and antenna. You will see it only for test at the limit range, with same antenna…


#88

ok, therefore you can’t say that changing a few components will help if there is a fundamental design error.


(Rem73) #89

To be clear : If you change theses components ( not easy ) and modify LMIC lib, you can improve de transmitted power, to be close to the semtech specification and RFM95


(Ud Lo Ra) #90

There is a video by Andreas Spiess about the ESP32 issues due to bad RF design . However, I agree that is likely better to buy an ESP32 alone + RFM95w instead.


#91

tnx… Andreas was spotted at The Conference yesterday ! :sunglasses:


(Ori) #92

I wonder what is this UFL connector for, does anyone know?UFL


(Eric VdB) #93

Wifi ?


#94

It is meant for connecting an external Wifi/BT antenna but that would require moving (de/re-soldering) a 0 ohm resistor (on the left of the U.FL connector) from one location to another to switch the RF connection.