Ttgo T-beam


(CovraWorkS) #61

Sorry forma that! You are fully right, you can activate loraWAN by code😁


(Nograin) #62

so i finally tried to get this thing running, hoping it would be easy with @DeuxVis TTNMapper port… well it likely is easy, but still being a noob i guess i’m missing some basic points.

it seems t-beam and software are running fine, i get reasonable output in the serial console and i can see traffic coming in on my TTN-gateway.

but - and this is something i can’t get my head wrapped round: the devaddr i see in the TTN-console is different from the one i set in config.h … is this normal with ABP activation? but since there’s a device with a different devaddr waiting for data in the TTN-app - i suspect this can’t work that way…
any idea what i’m doing wrong?

thanks,
markus.


(Nograin) #63

well, after creating a new device in the TTN app and using it’s devaddr i got an error compliling - so i realized it wasn’t the right format. after some digging found out i’d have to prefix the 0x

now i do get packets (22 bytes) with the correct devaddr in the gateway console - but not in the app itself, the device in there still shows a status of “never seen” … :frowning:


(Jezd) #64

check your device keys have not changed (NWKSKEY/APPSKEY) and copied to config.h, double check and then recompile - this is often the issue if the gateway is getting the packets but not the app


(Jezd) #65

Finally got my tto t-beam working, had to tidy up code and had issues around the board type, in the end my platformio.ini looked like the following:-

[env:ttgobeam]
platform = espressif32
board = ttgo-lora32-v1
framework = arduino
upload_speed = 921600
monitor_speed = 115200
lib_deps =
https://github.com/matthijskooijman/arduino-lmic
https://github.com/mikalhart/TinyGPSPlus
build_flags =
-mfix-esp32-psram-cache-issue

No extra wiring needed, builtin LED was on pin 14 mind, not 21


(Hasiflo) #66

Hi,
has anybody got the GPS-module (I use the m8n version) into sleep-mode?

I think the power of the gps-module can’t be switched off with a gpio, right?

Best regards


(Rhinoteknl) #67

i have got TTGO T-beam (868) installed in my laptop with win7, but arduinio compiler doen’t work properly it says error at the end of compiling

expected ‘,’ or ‘;’ before ‘TinyGPSPlus’

TinyGPSPlus gps ;


(Rhinoteknl) #68

I am having same problem with my TTGO -Tbeam , could you please share your coding to very with mine


(Rodri16) #69

On the Tbeam GPS is powered directly from 3.3V so it is not possible to switch it off with a GPIO (without cutting the trace)
I go into deep sleep mode on ESP32 but GPS never gets the position because it is rebooting every time
Also trying to reduce consumption in the gps moduel sending Special characters (0xB5, 0x62, 0x02, 0x41, 0x08, 0x00, 0x00, 0x00, 0x00, 0x00, 0x02, 0x00, 0x00, 0x00, 0x4D, 0x) but also without sucess
Take a look to these links
Arduino Forum and characters to send
Neo6 power management
Keep trying, let you know


(Rhinoteknl) #70

i am unable to upload TTN-Mapper coding into TTGO Tbeam , Arduino compiler results this error;

Using library SPI at version 1.0 in folder: C:\Users\dvfd\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.0\libraries\SPI
exit status 1
Error compiling for board Heltec_WIFI_LoRa_32.

Please some body help


(menno faber) #71

Hello rodri16,

I tried the TTGO beam and I did have the same problem as you guys. I was not able to put the GPS in sleep mode and the current was about 50 mA. I then desoldered the GPS module and the current went to 2.2 mA, ever so this is much better, for a low battery application this is still pretty high.

I also tried the TTGO LoRA V2.0 the current in sleep mode is 0.16 mA for this chip. (I did also remove a LED that didn’t turn off, I don’t know if this LED is connected to a GPIO).

Serial.println("go in to sleep");
esp_sleep_enable_timer_wakeup(TIME_TO_SLEEP * uS_TO_S_FACTOR);
esp_deep_sleep_start();