TTIG Problems, - no location data, wrong date/time, wrong channel and stability issues


Thanks for the fix, my TTIG showed up on just now (although it is still marked offline despite being online, but alt least it’s visible at all).
Edit; switched to online just now, so ttnmapper seems fine now.


My problem with “Joining” solved: i needed to set ATS220=3 on my Adeunis Tester.
(extend RX Windows Timing for Testhouse certification).

Now everything works fine with the TTIG (also can not see regulary reboots etc)


1 Like

I’d also like to know this.

This is why we’ve chosen to ‘wait’ and/or use something a bit more ‘robust’ like Laird Sentrius for indoor commercial applications…
There, I couldn’t read :smiley:

We asked them (TTI) why Ethernet was NOT an option for this little very nicely priced IG, we haven’t got an answer. Relying solely on WiFi as backhaul especially on the 2.4GHz very crowded RF space and all that WiFi’s unpredictability entails, IOHO, is not very wise, and it starting to show. I think the reasoning here, much like Semtech is doing with their new ‘kit’, is to follow the ‘in a Box’ biz model. We don’t think, again IOHO, that’s a very wise move. Add that to the ‘bugs’ everyone’s referring here, and well you get this long thread. Our Laird Sentrius are definitely more expensive, 2-3 times the price, but they work (ironically) right out of the ‘box’ the 1st time and no problems thereafter…

1 Like

Apart from TTIG bashing, what is your point?

The TTIG does not support wired ethernet because it is based on a cheap chipset that does WiFi. The hardware was designed some time ago for a different product and with new software re-released as TTIG at a very competitive price point. Redesign and re-certification (CE/FCC etc) would increase the price and add little (imho).


I find that insulting - who’s bashing anyone here? It is a valid, professional point that, bashing or not, is still pressing and very much relevant. As such, if it’s already giving so much headache, how can that be considered ‘competitive’? Sounds more like ‘rushed’ or ‘cheap’, which is very un-TTI-esque. We are very appreciative of TTN/TTI, extremely supportive and collaborative, so if you or anyone consider the sound based criticism as ‘bashing’ then maybe that’s something you need to work with - not us. :red_circle:


Ok, I should not have called it ‘bashing’, my appologies.

I think you could make your point differently. Posting a huge screenshot of a tweet where you could just as easily have posted a link to twitter and provided some context in the message does set the tone. Stating you prefer wired connections, which as we all know TTIG does not support and compare it with a product which is 2-3 times the price (and had issues with the first firmware release as well (frequent packet forwarder failures)) is not particulary helpfull for people with issues with TTIG. The Sentrius gateways have been availble for over two years so if anyone considered it an option they would have bought one and not waited for the hard to obtain TTIG. (And with the newer firmware I would certainly recommend the Sentrius gateways!)

With regards to the stability of TTIG, may-be it does need some time to mature? Brand new packet forwarder, not supported by the back-end (yet) and as a result needing a protocol bridge that does not scale well is not an advertisement for a mature product. Let’s face it, releasing a gateway that is not finished is very TTI-esque. Ask many backers of the original TTN gateway or read the messages on the forum regarding the problems people are (still) having.

TTI does a decent job providing the community back-end, however I’ve talked to several commercial customers that shy away from TTN lately because of the stability issues and outages. A year ago the back-end was a lot more stable. Once people start looking for alternatives the community looses gateways and coverage.


FW 2.0.0, build 2018-12-06. So I suppose the same. However, for some reason it runs. I do not know if different batches of gateways are assigned to different servers in the backend…

FW 2.0.0, build 2018-12-06.
Nothing changed until today …
short Power outage or short wifi outage terminates lora communication
as described in this thread by Kalle, me and others

will there be a fix in the near future ?

TTN shows continuous growing.

Is The Things Industries Indoor Gateway (TTIG) is a stable device? How many here have 3+ devices so that you can report back if they work stable or have issues. I have seen issues listed in this post but can’t figure out are these issues generic ones or just few devices have some problems.

If you wouldn’t recommend TTIG which gateway would you recommend for TTN?

Is The Things Industries Indoor Gateway (TTIG) is a stable device?

There have been ample reports here which seem to indicate that the combination of the gateway software and the protocol translation servers it connects to is unreliable at present. And being closed source, there’s essentially nothing you can do to improve the situation.

which gateway would you recommend for TTN?

Something where you can rebuild the system software from source, and (if it’s going where it’s at all hard to get at) where the base computer is not a Raspberry Pi and does not depend on an SD card (though if it’s going to be where you can pop in a new card if it eats itself, a pi can be an easy path to initial success). Most of the more “commercial” platforms like Multitech, TTOG, etc have their own chosen compact flash-based Linux. Overseas vendors seem to be doing good things with the Atheros and Mediatek OpenWRT router platforms - for example I have a RAK 2758 box running a built from source stack and several prototypes of a fully custom design using the same Mediatek SoC and concentrator card integrated in a way that hopefully better fits specific needs of where they will be installed, also have several of what are essentially pi gateways using an emmc-based OrangePi instead which now have nearly a year of shakedown on them to understand the rare issues. If you want to use post-UDP connectivity protocols some work combining packet forwarders supporting those with sources vendors have modified to work around SoC SPI oddities may be needed, but it all ultimately traces back to the same origins in Semtech’s version so that should be quite doable as a merge. Getting a bit far from the topic of this thread however…

1 Like

I’m still wondering if it’s possible to get the TTIG timesynced via NTP.
It is sending a time in metadata meanwhile, but does not sync via NTP.
Any ideas how to solve this?

      "gtw_id": "eui-58a0cbfffeXXXXXX",
      "timestamp": 158969515,
      "time": "1970-01-01T00:00:01.575482652Z",
      "channel": 0,
      "rssi": -84,
      "snr": 11.25

We probably will have to wait until availability of TTN V3 before this gets solved.

TTIG uses an implementation of the new Basic Station LoRa packet forwarder.
If I remember and understand correctly:

  • Basic Station will require a V3 backend.
  • Time is synchronized via the LNS protocol (not NTP) by the LoRaWAN Network Server.
  • For TTIG currently an intermediary system is used to make it work with TTN V2
    (which likely does not support all V3 features).

This may explain why TTIG’s (reported) time is currently incorrect.

How is firmware update done with TTIG? Does this happen automatically, triggered by TTN?

In Basic Station firmware updates are handled by the Configuration and Update Server via the CUPS protocol. How exactly this will be managed and how updates will be initiated I don’t know.

My personal guess is that we may have to wait for availability of TTN V3 before TTIG firmware can be remotely updated (but I may be wrong).

For more information see Basic Station Docs

1 Like

A post was split to a new topic: Does TTN Mapper show gateways when it only received “experimental” data?

What is the status regarding the time element in the received gateway data?
Is it considered as bug which will get fixed - if yes till when?

BTW: Is there something like a roadmap what will happen software wise in the TTIG?

      "gtw_id": "eui-XXX",
      "timestamp": 3076547067,
      "time": "1970-01-01T00:00:01.576063743Z",
      "channel": 0,
      "rssi": -36,
      "snr": 10.25