TTIG : The Things Indoor Gateway

This scares me a bit: it seems somehow the gateway gets some credentials, even when a gateway is not claimed through TTN Console, which are used to fetch the configuration and all? I wonder what “requires resetting the credentials on the server side” means, and if that needs intervention from the TTN team.

I understand, that you need to change your data in TTN console after a reset.

What data? (I’d not press that button until I understand…)

Are you looking at the TIG’s gateway Traffic page in TTN Console, or at the gateway(s) metadata you see when clicking an uplink in the application/device’s Data page?

(I wonder if maybe the TIG is just a bit slower, and de-duplication hides the uplinks it has received from the non-standard channels? Weird though…)

I just repeated setup to look. press the setup button not the reset button. connect to the new AP ‘MiniHub…’. on the bottom of the page 192.168.4.1 you will find the datas of your GW. scroll down the page.

after that you need to connect to your own network by clicking your wifi on the list. put in the credentials and save. after a reboot and some time the gw will be connected to your own router. then you can start in the TTN console as described in recent mails before.

I hope, you can figure all out.

1 Like

I looked at the GW traffic page.

I wonder if given the new Basic Station software there is no need to configure a router/frequency plan in TTN Console, for a TIG to become fully operational? But maybe that needs V3, rather than V2 with some bridge?

Some statistics seem to show only few have registered their TIG so far. Too bad not everyone is using the same description :slight_smile:

   1 "Gemtek / TTN Node TTN 2019"
   1 "Gemtek Femto"
   1 "Gemtek GIOT InDoor FemtoCell "
   1 "Gemtek IOT Femto Gateway"
   3 "Gemtek Indoor Gateway"
   1 "Gemtek IoT Femto Gateway"
   1 "Gemtek Mini"
   1 "Gemtek MiniHub MH100"
   1 "Gemtek Minihub"
   3 "Gemtek TBMH100"
   1 "Gemtek TIG"
   1 "Gemtek TTN GW Mini"
   1 "Gemtek TTN Indoor gateway"
   1 "Gemtek TTN Indoor"
   1 "Gemtek TTN limited mini GW"
   1 "Gemtek Tabs Mini Hub "
   1 "Gemtek Tabs Mini Hub"
   1 "Gemtek Tabs indoor gateway"
   1 "Gemtek Technology Co. Ltd. MXF-MHB100 Tabs Mini Hub"
  10 "Gemtek The Things Indoor Gateway"
   1 "Gemtek The Things Network Indoor Gateway Conference Edition"
   8 "Gemtek WLRGFM-100"
   1 "Gemtek WLRGFM-100(EU)"
   1 "Gemtek indoor gateway"
   1 "Gemtek pico"
  15 "Gemtek"
  ...
   1 "The Things Industries Indoor"
   1 "The Things Network Minihub"
   1 "The Things Network ttnctl"
   1 "The Things Products Indoor Gatway; 2019 The Things Conference Limited Edition"
   1 "The Things Products TBMH100 (Gemtek Tabs / Mini Hub)"
   2 "The Things Products TBMH100"
   1 "The Things Products The Things Gateway (tabs)"
   1 "The Things Products The Things Gateway Mini"
  ...
   5 "The Things Products The Things Indoor Gateway"
   1 "The Things Products The Things Mini-indoor Gateway"

I don’t know if http://noc.thethingsnetwork.org:8085/api/v2/gateways also shows TIGs that have been set up for some WiFi (and then are forwarding packets to TTN just fine), but have not been registered in TTN Console.

It works for me.
Just put the gateway onto power, push the button and connect to wifi.
You can put in 8 different wifi accesspoints as defaults.
Then register at TTN and a few minutes later i see traffic.

Nice that it is portable, so i can take it with me for demos.gateway-tabs2

Given problems reported in earlier post, can you extend on that? Like: does OTAA work? (Or more generic: do downlinks work?) Do you see it use more than 3 channels? Do you see all expected frame counter values, without gaps?

Hello Everyone,

We here at TTI are slowly recovering from our post conference fatigue. Thanks a lot for keeping this thread going and we’re very grateful for this amazing community.

Firstly, the channel config was a yaml reading mismatch between the way the CUPS server sends it the gateways use it. This has been fixed as of 5 minutes ago and the UL/DL should be on par with other gateways on TTNv2. The packet loss should be resolved now.

Secondly, we are working on official docs for configuring and connecting the TTIGs to the network (although you’ve figured out all of it… :smile: ). This will be useful for future users to quickly set things up. The docs will be available in a few hours.

Thanks for your support and let’s build this thing together,
Krishna on behalf of the TTI team

20 Likes

@Krishna Thanks for the information. Will there also be information/investigation if it’s possible to change a 915 device to 868?

We are currently facing one administrative compliancy hurdle which should be resolved asap. We will keep you posted. And make sure the message is first posted here before we spread it further.

2 Likes

Don’t think that from a compliancy perspective we can state anything official about that.

Unfortunately no. That’s a hardware change that cannot be made.

Hello @Oliv, @KrishnaIyerEaswaran2, the gateway works like a charm now. Earlier reported issues with the node not getting the join accept seem to be solved now. Thanks!

4 Likes

The TIG is working now perfectly… Thnx…

2 Likes

then try to reset the gateway by holding the reset button for about 5 secs until the LED blinks rapidly GREEN<->RED for a couple of times.

from meikelg (could not reply with my normal account): after resetting I added my WLAN again, but no access. even worse: instructions tell me I need new credentials on server side. since I have still the same EUI, i cannot delete my gw in TTN, because I got this message from TTN: ‘You will not be able to restore the gateway or re-use its ID.’ Now I am doomed?

I have a US915 gateway. It was quite fast with the OTAA join accept initially. I rebooted it about 20 minutes ago and now it doesn’t see any packets what so ever.

Perhaps the CUPS fix broke something on the frequency plan for the US gateways?

I don’t see any traffic on my TIG no matter what. Even if it’s a node that’s already received an OTAA Join Accept. It’s gone deaf somehow :face_with_raised_eyebrow:

What browser are you using? I have that problem with Firefox, Chrome works fine.

1 Like

@KrishnaIyerEaswaran2

After rebooting several times I now get packets but it’s dropping packets like crazy. I’ve received only 3 packets in over 20 minutes

They are now at weird frequencies and they are actually outside of subband and don’t follow the appropriate 200 hz step interval ie, 902.725, 902.325, 903.075.

I’m sending every 5 seconds btw

Screenshot%20from%202019-02-04%2017-13-08

It’s actually always seemed to have used weird frequencies when I unplugged all of my other gateways and used it solely. When I have it running along side my other gateways it doesn’t see any packets.