TTIG : The Things Indoor Gateway

(arrowcircle) #631

Maybe a stupid question, but how can I buy it? I can’t find any links.

(Jeff Uk) #632

Not sure where in the world you are but sales are through RS Components/Allied.

Here is UK link

Single units:

Back in stock 17th June?

(Tomcroft) #633

Just received “The Things Industries” gateway. I’m in Australia. I selected the AU frequency band. 915. I received a gateway with a U.S.A. power pin adaptor unit. If anyone from The Things Industries is reading, please be more industrious in your catering for the correct power adaptor unit distribution for the regions. The nifty little well designed adaptor you supplied now has to be butchered, so your clever multi-region design philosophy has been wasted on me. Just a bit frustrated to see the clever design wasted for want of an appropriate reginal power type distribution strategy. BUT, design is 1st class :slight_smile:


Did you bought your gateway unit from 'The Things Industries ?

(Ud Lo Ra) #635

At least you have received one adaptor :slight_smile:

(LoRaMac) #636

Hi there,

tried to preorder one at RS Germany but they only sell to companies - the RS store for non-commercial customers did not sell/list this device yet.

Then tried to buy one at RS UK but they only sell in the UK! :-o

(Malbec) #637

I have both a TTIG and a RAK2245.

For test, I send a message every minute with a Steval-STRK01 Lora sensor.
With a message every minute, the RAK2245 got all messages, but the TTIG got only one message over two.

I have now repeated the experiment with a message every two minutes.
Now both TTIG and RAK2245 get all messages.

The sensor is in the house, but far away from the gateways

RAK2245 :
“rssi”: -67,
“snr”: 10,

“rssi”: -69,
“snr”: 10.75,

but variations occur. the rssi of both gateways are comparable.

(Ud Lo Ra) #638

Not so much, but I am also sure some packet is lost. Which SF do you use? However, as I had the impression that the gateway was not listening for some time after receiving a packet, I did a test as suggested by @LoRaTracker, with a node set for sending every 7 seconds (but ended sending every 12, LMIC takes some time for completing). This at SF7. Almost all packets were received. I would replicate at SF12, but I have to set two nodes for sending one some second after the other.

(Mariacarlinahernandez) #639

Hello Community! :raising_hand_woman:

I had registered two TTIG in an account, they were connected and receiving data without any inconvenience. Last week I transferred the ownership of one of the gateways to a personal account successfully. Then, 5 days after, both gateways changed their status to “not connected” just in TTN.

The log times for their disconnection were:

  • 5/9/2019 03:12:58
  • 5/9/2019 03:13:42 (Gateway transferred)

I rechecked the WiFi connection for each of the gateways, and they are connected, but regrettably, after 5 days I can’t still see them connected in TTN.

The behavior presented can be related to the transfer of the gateway? or maybe, any update for the TTIG that I’m missing?

If someone had the same behavior once, I would appreciate any assistance on this to start testing my project. :grin:

Maria C.

TTIG "not connected"
(Al Bennett) #640

Hey, we’ve just opened pre-orders for TTIG at Connected Things Store. We have our first units arriving mid-June, so we’re taking orders now and will ship out ASAP.

We can take orders from companies or individuals and ship anywhere in Europe (and wider), so hopefully that will help with some of the supply issues!

You can pre-order here:

Give me a shout if you have any problems ordering from the link above and I’ll see if I can help out!


(Dave Wal) #641

Tom, where’d you get it?

(Tomcroft) #642

Allied Electronics & Automation.
DHL shipment 6185827244
I was on TTN wait list.
Got e-mail to say “Available now”
Clicked on all the links… whatever…
Obviously a U.S. version.
It’s fine by me.
I only give information in case someone’s interested in process improvement.

(Jim Hollister) #643

I installed a new Indoor Gateway in my house a couple of days ago. The installation went smoothly and TTN says the gateway is connected and receiving and transmitting messages. The documentation says this about the green LED:

GREEN - blinking 1 sec - [GW Mode] WiFi STA not connected
GREEN - blinking 1/4 sec - [GW Mode] WiFi STA connected,establishing connection to LNS, configuring radio
GREEN - solid - [GW Mode] WiFi STA connected, GW connected to LNS, radio listening

Since I installed it, my gateway has been alternating between Green-solid and Green-blinking-1/4-sec. It’s solid for about 55 seconds and then blinking for 10-20 seconds. The WiFi at the installation location is strong and I’ve also tried two other locations with good WiFi. My Internet connection seems stable.

Is this behavior normal? I wouldn’t be too concerned except that I have a device that doesn’t seem to be receiving messages. According to TTN it is succesfully activating but the device doesn’t seem to think so. I also see pulses on the DI1 pin which the LMIC doc tells me is called RxTimeout and the device is acting as if its activations requests are timing out.

(Dutchpeter) #644

Hi All,

We have The Things Indoor Gateway:
MFG date2019-01-21 22:33:33
FW Build2018-12-06 09:30:37
FW Version2.0.0
Core Version2.0.0(minihub/debug)

But we’re facing a problem that the led is not always green. Sometimes it blinks for 30-60 seconds, then it’s green again.

Is anyone of you facing the same problem. We tested it on multiple wifi access points, all have the same behavior.

Regards, Peter


I have the same at the moment, however when its flashing its receiving data.
There are some instabillity problems with the server side handling of TTIG according to HTDVisser.


(Wrldtvlr) #646

For what it’s worth, I have a new unit that exhibits the same behavior. Goes into flashing green every so often and then back to solid green.

(Jim Hollister) #647

For those people having this problem: does it affect devices ability to communicate through the gateway?

(Wrldtvlr) #648

I don’t have enough edge nodes to tell. The interval seems to be quite random. I only see if I’m looking at it, but there are times when it seems to be 20 or 30 minutes apart, and times when it is just a minute or so.

(Jim Hollister) #649

Thanks for letting me know. It sounds like your edge nodes must be working most of the time, at least, or you would have noticed. I haven’t been able to get my first edge node to work at all and I was wondering if that was related to the green LED behavior. I must have a different problem with my edge node.

(Wrldtvlr) #650

It would be nice if the beta gateway traffic tab was working in TTN Console. I just see a blank screen even though things seem to be passing through the gateway.

I had a few challenges getting my Dragino dev kit up and running. The single channel gateway works, but because the edge nodes try multiple channels, it took a long time to verify they were set up properly. TTN Indoor Gateway works much better.