TTIG : The Things Indoor Gateway


(Arjan) #105

…stating:

ISM or ISM & BT or GPS Stamp Metal Embedded SMT Antenna
868 MHz, 915 MHz, 1.575 GHz, 2.4 GHz

So, it’s actually used/usable for both EU868 and US915?

(@dmth’s pictures with the part number 1002427 are for a EU868 model.)


(Kater) #106

I needed several attempts also, but now it is working.

Be sure to use the right MAC – not the WiFi STA MAC you can read on the label, but the WiFi AP MAC that is shown on the web interface page bottom. For me it reads “58:A0:xx:xx:xx:xx” in the second line, the first line being “Gateway EUI 58-A0-xx-FF-FE-xx-xx-xx”.
So I typed “58a0xxfffexxxxxx” (lowercase, no hyphens!) into the “Gateway ID” field. It then says “It looks like you are trying to register a gateway by EUI. This probably means you are using the legacy packet forwarder.”, so I checked the “legacy packet forwarder” checkbox.
Registration was no problem then.


(Cnoork) #107

I have almost the same, connected to the TTN but no traffic. Green led is most of the time on and so now and then blinking green. All looks fine only no trafic. My nodes are running and see the trafic from different other gw’s. What do I wrong? I see only many join requests when I reset my node on the Tabs, if I switch the Tabs off it needs only one join request. Who knows where I should look?


(Arjan) #108

Just a wild guess: if OTAA Join does not work when the TIG is active, but works great when switching off the TIG, then apparently TTN has selected that TIG for the Join Accept. And somehow that Join Accept is not received by the node:

  • Maybe the selected router in TTN Console’s settings is not correct, adding too much latency for the downlink to arrive at the gateway in time?

  • Maybe the selected frequency plan is wrong (making TTN make wrong choices as for the Join Accept’s downlink settings)?

The above, plus “All looks fine only no trafic” makes me think you actually did not register the gateway correctly, so any configuration you made in TTN Console does not apply to the actual device: check and double-check the EUI?

Do you see any Join Accept in TTN Console, on the device’s Data page? If yes, is the TIG listed in the meta data of the gateways that received that Join Request? (Click on an item in the Data page for more details.)


(Kater) #109

Any experiences already with the gateway’s performance?

Having the TIG here and a DIY RasPi + IMST iC880A with a small stub antenna, all in the same room with two Heltec ESP32 LoRa nodes running different software (one is PAXcounter that constantly sends packets every 60 seconds after one join, the other is a sensor that wakens up, joins, then sends a packet and goes to sleep again).
Both nodes are received by both gateways. Looking at the Console’s gateway traffic, the TIG has about half as many entries as the RasPi does.
The TIG’s LED stays green mostly, but sometimes it flashes.


(Afremont) #110

Unless I’m mistaken, again, the notch filters are done in an FPGA making them roughly a matter of software (SDR).


(Oes249) #111

Are the channel plans for the RasPI and the TIG the same? I.e. is it always the same channel
where the TIG does not pick up the packet?


(Arjan) #112

Are you only referring to traffic of those nodes? Or does the Raspberry Pi also receive packets from other nodes? (Like more distant nodes with a weaker signal.) And are the nodes at least a few meters away from both gateways?

Beware that gateways are half-duplex, so if the TIG is sending the Join Accept for this node, then it cannot receive uplinks from the other node. But I guess that cannot account for missing many uplinks.


(Bahnhofsoma) #113

Many thanks. It is connected.


(Jose Marcelino) #114

I’d be surprised that’s the case - there are two reference designs available. The cheap way is to use a physical filter, eg Johanson 0868LP15A020E or a TDK B3717 SAW Filter for 868Mhz designs

If no one does one sooner I intend to do a proper teardown - including the removing the RF cans - soon when I’m reunited with my tools. Will let you know :slight_smile:


(Arjan) #115

A, CUPS was new to me (when not related to printing): apparently that’s “Configuration and Update Server”.


(Octoate) #116

I have the same problem. Currently I am testing with a temperature sensor that sends its packets every 15 minutes on SF7 changing its channel for every packet. The second device is a RAK Wireless Wistrio using their default firmware, that sends a status packet every minute on SF12 changing the channel on every packet. The TIG does not receive a single packet from the Wistrio (but my RasPi with IMST iC880A and 2 other gateways of our community does).
However, sometime the TIG receives a packet from my temperature sensor. The behaviour is the same like yours: mostly green, sometimes green blinking.


(Mascarpone) #117

Same here. I have the TIG up and running and it’s shown as connected in the console. I have serveral nodes running but there is no traffic on the TIG.When is start up a new node, I see join requests on the TIG but still no traffic. When I switch it off, the nodes have no problem joining TTN using a different gateway with a single request. Any ideas?

Update: I have 4 Nodes running here right now (ElSys ERS, PNI Placepod, Adafruit GPS Tracker and simple LoRa32u4). Only the packets sent by the LoRa32u4 are being forwarded by the TIG. All others are ignored. So the chosen router or the frequency plan shouldn’t be the problem. Also, all nodes are several meters away from the TIG.


(Verkehrsrot) #118

Same here, roughly every second packet is missed by the TIG, but seen on my MatchX GW.
Both gateways are in ~20m distance.


#119

I have similar behaviour. I see it ‘connected’ in the TTN console, and every now and then the ‘last seen’ counter jumps back to zero, but I don’t see any traffic, not even join requests.

I thought maybe it had something to do with the port forwarding in my firewall, because I already have a gateway in my network. So because I have the luxury of a fully redundant Internet connection, I set up my existing gateway on wifi network A, using internet access A, and the TIG on wifi network B using internet access B, and set port forwarding accordingly, but it makes no difference…


(Wjm Brok) #120

I have the same issue here. On the TTN gateway traffic tab I see join requests coming in from my node and 4 seconds later a response (join accept) leaving the gateway. This is never picked up by the node. There is no other traffic observed by the gateway (for all I know, there might not be any, as I am in a somewhat quiet place, with no other gateway coverage). The distance from node to gateway is approx. 10m.


(Verkehrsrot) #121

I took my TIG offline. If i run it in parallel to my MatchX gateway, this causes serious join problems.
MatchX only: Join in 2-3 seconds.
MatchX & TIG in parallel: Joins take sometimes minutes!


(Lachlan Etherton) #122

Thanks for the great discussion guys!

Very interesting. Seeings that the antenna supports 915 MHz and there would have been some antendees from Australia and the US, would anyone be able to make the mod and test it for the frequency plan?

Also, when the board is released online, could someone post a link? Can’t wait to get it in my hands to do some of this testing as well.


(Ud Lo Ra) #123

For those comparing to another gw: what about RSSI/SNR? Thanks.


#124

can you try changing the TIG position from horizontal to vertical (probably need some sticky tape :wink:)