TTN GATEWAY central 2

Based on the recent posts on this thread I took a look at the noc for my TTN GW - bought in December commissioned/installed Jan/Feb - delayed as I saw people had serious problems with none working GW’s. As mine installed and worked fine OoTB i decided to leave well alone and had disabled auto updates.

When I look on noc however it shows:-

“The Things Gateway v1 - BL r1-7167873a (2017-06-02T13:48:18Z) - Firmware **v1.0.5-fa89b993 (2018-07-17**T08:11:52Z)”

Implying its been updated to v1.05 despite GW set up as


So either auto update opt out ignored or noc telling porkies! :thinking:

GW has run fine since install despite a couple of power cuts to office and GW being relocated around UK a couple of times for pop-up tests…fortunately haven’t had problems seen by others - so far…and hadn’t seen any reboots that would imply it was updating…strange…


Just checked things-gateway.local/info to see what GW status says and it shows

So clearly the autoupdate opt out has been ignored! :frowning:

Interesting. Similar situation here. Auto update turned off since no apparent problems, but now I see:
Firmware: v1.0.5-fa89b993 (2018-07-17T08:11:52Z)

Hi all,

We have a TTN Gateway and we want to configure it with a local network, however in order for the gateway to connect to the gateway we need to allow it through its MAC address.

How can we get the MAC address for the gateway?


You can look it up in your DHCP server.

Are these issues with the firmware the reason the gateways are backordered until March '19?

the 915 mhz version… chip production related I think…

these chips are VERY populair at the moment :wink:

They should be back in stock either end of September or end of October.

Finally working !!! update from SD card never worked, but a colleague helped me with a Microchip programmer and now the gateway is stable and working !


Tried to get the gateway working once more, after some time of inactivity. Today, I managed to update the firmware to v1.0.5. There was a short moment when the gateway seemed to be fully connected. But, it is again back to the sequence of the fourth led flashing, then rebooting. Activation of the gateway appears to be complete.
Screenshot%20from%202018-09-22%2016-44-36 Screenshot%20from%202018-09-22%2016-35-32 Screenshot%20from%202018-09-22%2016-33-37

It could be that the local network is the cause of all trouble. It is a Fritzbox on Xs4all ADSL. But, the gateway has unrestricted access to the internet.

To check an alternative, I also configured the gateway to connect to the internet via my iPhone’s hotspot. But, it all does not make a difference.

I am running out of options for things I can do myself. Not willing to buy additional controllers or toolkits to get low level access to the gateway: no more funds to this device because it has not worked a second yet.

Anybody has suggestions on how to get the gateway connected and working?

Version 1.0.5 is a great improvement, fortunately. Any progress to report on the remaining issues?

And I am wondering: since the Lora issue was addressed, what about the bootloader which was supposed to address the same issue - should I revert to the original version, or keep version 2 installed?

Did you validate that using, e.g., the serial monitor?

True, my gateway rarely needs manual intervention, but it has rebooted itself 522 times just due to the following failing assert, since installing 1.0.5 on July 17th (which is 70 days ago):

LORA: Kick LoRa module with ACK after not acked it for 60s
*** assert ../src/app_lora.c:842:w == size:LORA Uart write should be blocking

(Not every occurrence of the “LORA: Kick LoRa module with ACK after not acked it for 60s” message yields a failing assert. See also GitHub #52.)

No, I did not - I followed the TTN claim for this release. I probably should have written ‘supposedly addressed’.

Hello guys!
I have a TTN gateway connected by cable to a 3G router with a weak signal (with lot of surrounding noise). I don’t have any physical access to the gateway but someone to power / unpower it.
The gateway somehow looses the connection to the router. Before rebooting the gateway, the 2nd LED is blinking fast with the first one ON. This means that the internet connection failed. We suspect that this comes from the poor 3G signal strength.
After rebooting, all LEDs are ON and the data transfer too. Then, it stops after a few hours.
I don’t know the flashed firmware version. Is there a mean to get it remotely?

Do you know how to solve this connection problem?

  • yes that’s possible

  • you could check the firmwareversion

where xxxxx is you gw eui


Thank you for your help !

Here is what I get for the platform field :
“The Things Gateway v1 - BL r1-7167873a (2017-06-02T13:48:18Z) - Firmware v1.0.5-fa89b993 (2018-07-17T08:11:52Z)”

Ok, so let’s assume that the problem comes from my 3G connection that is not stable.
Is there a way to solve this issue ? A new firmware version ? a beta version ?

Note that before rebooting the gateway, the 2nd LED is blinking fast whereas internet is up and running on the 3G router.


It seems that the problem comes from the TTN gateway. Could this be related to this problem?

In the same building, I use a dragino gateway and I had the same type of problem. I managed to solve it by doing a periodic restart of the LORA packet forwarder.

Any help would be welcome. This situation is really disastrous for me.

can’t you check the workings of your gateway on a cable connection somewhere ?

A post was merged into an existing topic: TTN GATEWAY central 3

we continue in TTN GATEWAY central 3