TTN GATEWAY central 3

Thank and we are agree, it’s an indoor gateway? I can not see that information on the web page and I watch the TTN video Look at the minute 0:48, it looks very easy to open it, no screws… It should not be waterproof

where did you read that it is waterproof … no it’s original an indoor gateway but if you put it in an IP67 enclosure you can use it outside too, see

is there anyway to diagnostic the Things Gateway device? (ssh, check logs etc.).
My Gateway runs for days without issues and then reboots for many hours before getting online again. (see also my earlier message).

Mine does something similar If the power is interrupted, it won’t get online at least 50% of the time unless I cycle the power a few times. Does anyone else see this problem?


I am trying to bring my TTN gateway online. I get stuck in the forth step of activation. What I am currently seeing is LED1 on, LED2 on (online via ethernet cable), LED3 slowly flashing (activating). This goes on for about 1 minute, then reboot of the device and it starts over again.

I have read about the Lora module issue and tried several different fixation methods and also measured contact of the pins between the module and the board. Everything is fine from my point of view. Also the modules LED do shine during the activation.

So I tried to connect to the UART debug port to see what is happening. I have an FTDI-UART-USB converter, I soldered the RX and GND cable to the SUB D connector and connected them to the UART pinout of the TTN Gateway. However, I do see random chars in the terminal (see picture) and no proper text. I even used an osziloscope and verified the baudrate to be 115200.

AND… I have flashed the latest available firmware images from github, but they all behave the same.

What is wrong, please help.


if you have 3 wires connected… switch Rx/Tx

I tried to switch. But if I had connected Tx instead of Rx, I would not see anything, right?

I do see a voltage of 3.3 Volts between GND and RX on the gateway. Can the gateway be changed to 5V?

really ? your lucky if it still works because you put 5V on the UART

Obviously, the FTDI UART converter seems to have a jumper switch for that as seen in this picture from the FAQ. I just wonder if this would make any difference


I got a new version 1.0.6 pushed on May 17th, which apparently might be needed if TTN updates the server certificate some day after July 2019:

With this patch we add the ISRG Root X1 CA to the gateway firmware. After 8 July 2019, many servers that use Let’s Encrypt will start serving a certificate chain which leads to this new root, and therefore it must be trusted by clients such as the gateway.

So, for those not having automatic updates enabled: you’d better do so, I’d assume.

1 Like

Sadly this is only disaster avoidance. I still miss basic functions like disabling WLAN when not needed.

1 Like

Did already somebody tried to re-purpose the mpcie card of the ttn-gateway with a raspberry? There are out some mpcie-hat’s like this one. Electrically this should work. Mechanically the TTN-Card is a bit long but no show-stopper. And since this is basically a modem, maybe there is a chance that this runs with existing Raspberry based gateway software or with minimal tweaking? I will check this later, but maybe somebody has already some know-how to share?

1 Like

Is this still a valid product? That last message makes me think I should save $350. I am new to the LoRaWan world and getting ready to setup a network in Kansas. So I want to spend my money right.

why should you ? sound like buying a whole car only to repurpose the engine :sunglasses:

There are cheaper better products available by now. Check RAKs gateway offerings (plenty about them on the forum)


While i can.
I hate car comparisons. But you started: I have a usable camper trailer but the towing car is no more usable and will be replaced. Or technically: The TTN Kickstarter Gateway is simply not state of the art. Never was. The geeky community gives much love on Raspberry Pi’s as base for their LoRa Gateway. Nobody forked TTN GW code for good. Open sourced code from TTN KS GW has zero evolved. Now there is an update where only a expiring certificate will be replaced. With a RPi i can disable WLAN, i can add PoE,i have a console, a Firewall, IPv6, can do crypto, use VLAN and and and… Like the Multitech Gateway i owned long before the TTN GW was delivered. That’s it.


LOL :rofl:

But to give it some credit, the kickstarter campaign success took a lot of companies by surprise and made them take notice of a market segment they hadn’t noticed before.
A shame the gateway took too long to get to ‘market’ and is more or less a technical dead end due to the technologies used. Too much embedded knowledge required to build and improve the code where there are easier and cheaper options available.


Purchased a RAK… Here goes nothing…

1 Like

In one of our ‘The Things gateways’ -that does not pass the stage of 1 led lit and the second one blinking fast- we see the following serial debug output “dump” (see below)
We are wondering if someone can tell what the “DRV PHY init failed” means, since this seems to be different from all dumps seen before. Looking for similar things on google leads to believe it is something to do with the ethernet chip.
Can anyone give a tip/answer/solution?

We did in the mean time successfully reprogram the PIC32 using MPLAB IPE and a PICkit 3, but that did not help…