Ttn gateway won't register


(Waterbug) #1

Hello,

I have been struggling with a IC-880a for a while now. I am using it in combination with raspbian-jessie-lite on rpi. I installed the USB version of the software conform


I changed /opt/ttn-gateway/lora_gateway/libloragw/library.cfg to:

CFG_SPI= ftdi
PLATFORM= lorank
DEBUG_AUX= 0
DEBUG_SPI= 0
DEBUG_REG= 0
DEBUG_HAL= 0
DEBUG_GPS= 0

I changed the different local_conf.json files with the right values for server settings and gateway_ID.
I repowered rpi, then repowered gateway, then connected USB. 1 green light is buring on the gateway now.
I did 'sudo /opt/ttn-gateway/lora_gateway/util_tx_test/util_tx_test -f 868 -r 1257'
and got:

INFO: concentrator started, packet can be sent
Sending -1 packets on 868000000 Hz (BW 125 kHz, SF 10, CR 1, 16 bytes payload, 8 symbols preamble) at 14 dBm, with 1000 ms between each
Sending packet number 1 ...OK
Sending packet number 2 ...OK
....

I did 'sudo /opt/ttn-gateway/bin/start.sh' and got one green light burning and output:

....
INFO: [up] Thread activated for all servers.
##### 2017-03-20 17:40:16 GMT #####
### [UPSTREAM] ###
# RF packets received by concentrator: 3 
# CRC_OK: 66.67%, CRC_FAIL: 33.33%, NO_CRC: 0.00%
# RF packets forwarded: 2 (46 bytes)
# PUSH_DATA datagrams sent: 2 (482 bytes)
# PUSH_DATA acknowledged: 0.00%
### [DOWNSTREAM] ###
# PULL_DATA sent: 3 (0.00% acknowledged)
# PULL_RESP(onse) datagrams received: 0 (0 bytes)
# RF packets sent to concentrator: 0 (0 bytes)
# TX errors: 0
### [GPS] ###
# Invalid gps time reference (age: 1490031616 sec)
# Manual GPS coordinates: latitude 0.00000, longitude 0.00000, altitude 0 m
##### END #####

I did 'sudo tail /var/log/syslog and got:

Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: # RF packets forwarded: 0 (0 bytes)
Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: # PUSH_DATA datagrams sent: 1 (196 bytes)
Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: # PUSH_DATA acknowledged: 0.00%
Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: ### [DOWNSTREAM] ###
Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: # PULL_DATA sent: 3 (0.00% acknowledged)
Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: # PULL_RESP(onse) datagrams received: 0 (0 bytes)
Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: # RF packets sent to concentrator: 0 (0 bytes)
Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: # TX errors: 0
Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: ### [GPS] ###
Mar 20 17:50:22 ttn-gateway ttn-gateway[675]: # Invalid gps time reference (age: 1490032222 sec)

I registered the gateway at https://console.thethingsnetwork.org/gateways/eui-aa555a1573888704. I made sure to use the same gateway_ID. I kept the gateway (with antenna) on for a few hours. After that at my desktop on ttn.org it still says 'not connected'.
So my presumption is that my gateway is working. But why is it not recognized on my ttn desktop ?

Thanks for helping me on, Rick

update 1
/opt/ttn-gateway/bin/local_conf.json

1 {
2         "gateway_conf": {
3                 "gateway_ID": "AA555A1573888704",
4                 //"servers": [ { "10.0.0.32": "router.eu.thethings.network", "    serv_port_up": 1700, "serv_port_down": 1700, "serv_enabled": true } ], // changed this thanks to someones suggestion
                   "servers": [ { "server_address": "router.eu.thethings.network", "    serv_port_up": 1700, "serv_port_down": 1700, "serv_enabled": true } ],
5                 "ref_latitude": 0,
6                 "ref_longitude": 0,
7                 "ref_altitude": 0,
8                 "contact_email": "",
9                 "description": "ttn-ic880a"
10         }
11 }

/opt/ttn-gateway/bin/global_conf.json

{
    "SX1301_conf": {
        "lorawan_public": true,
        "clksrc": 1, /* radio_1 provides clock to concentrator */
        "radio_0": {
            "enable": true,
            "type": "SX1257",
            "freq": 867500000,
            "rssi_offset": -166.0,
            "tx_enable": true
        },
        "radio_1": {
            "enable": true,
            "type": "SX1257",
            "freq": 868500000,
            "rssi_offset": -166.0,
            "tx_enable": false
        },
        "chan_multiSF_0": {
            /* Lora MAC channel, 125kHz, all SF, 868.1 MHz */
            "enable": true,
            "radio": 1,
            "if": -400000
        },
        "chan_multiSF_1": {
            /* Lora MAC channel, 125kHz, all SF, 868.3 MHz */
            "enable": true,
            "radio": 1,
            "if": -200000
        },
        "chan_multiSF_2": {
            /* Lora MAC channel, 125kHz, all SF, 868.5 MHz */
            "enable": true,
            "radio": 1,
            "if": 0
        },
        "chan_multiSF_3": {
            /* Lora MAC channel, 125kHz, all SF, 867.1 MHz */
            "enable": true,
            "radio": 0,
            "if": -400000
        },
        "chan_multiSF_4": {
            /* Lora MAC channel, 125kHz, all SF, 867.3 MHz */
            "enable": true,
            "radio": 0,
            "if": -200000
        },
        "chan_multiSF_5": {
            /* Lora MAC channel, 125kHz, all SF, 867.5 MHz */
            "enable": true,
            "radio": 0,
            "if": 0
        },
        "chan_multiSF_6": {
            /* Lora MAC channel, 125kHz, all SF, 867.7 MHz */
            "enable": true,
            "radio": 0,
            "if": 200000
        },
        "chan_multiSF_7": {
            /* Lora MAC channel, 125kHz, all SF, 867.9 MHz */
            "enable": true,
            "radio": 0,
            "if": 400000
        },
        "chan_Lora_std": {
            /* Lora MAC channel, 250kHz, SF7, 868.3 MHz */
            "enable": true,
            "radio": 1,
            "if": -200000,
            "bandwidth": 250000,
            "spread_factor": 7
        },
        "chan_FSK": {
            /* FSK 50kbps channel, 868.8 MHz */
            "enable": true,
            "radio": 1,
            "if": 300000,
            "bandwidth": 125000,
            "datarate": 50000
        },
        "tx_lut_0": {
            /* TX gain table, index 0 */
            "pa_gain": 0,
            "mix_gain": 8,
            "rf_power": -6,
            "dig_gain": 0
        },
        "tx_lut_1": {
            /* TX gain table, index 1 */
            "pa_gain": 0,
            "mix_gain": 10,
            "rf_power": -3,
            "dig_gain": 0
        },
        "tx_lut_2": {
            /* TX gain table, index 2 */
            "pa_gain": 0,
            "mix_gain": 12,
            "rf_power": 0,
            "dig_gain": 0
        },
        "tx_lut_3": {
            /* TX gain table, index 3 */
            "pa_gain": 1,
            "mix_gain": 8,
            "rf_power": 3,
            "dig_gain": 0
        },
        "tx_lut_4": {
            /* TX gain table, index 4 */
            "pa_gain": 1,
            "mix_gain": 10,
            "rf_power": 6,
            "dig_gain": 0
        },
        "tx_lut_5": {
            /* TX gain table, index 5 */
            "pa_gain": 1,
            "mix_gain": 12,
            "rf_power": 10,
            "dig_gain": 0
        },
        "tx_lut_6": {
            /* TX gain table, index 6 */
            "pa_gain": 1,
            "mix_gain": 13,
            "rf_power": 11,
            "dig_gain": 0
        },
        "tx_lut_7": {
            /* TX gain table, index 7 */
            "pa_gain": 2,
            "mix_gain": 9,
            "rf_power": 12,
            "dig_gain": 0
        },
        "tx_lut_8": {
            /* TX gain table, index 8 */
            "pa_gain": 1,
            "mix_gain": 15,
            "rf_power": 13,
            "dig_gain": 0
        },
        "tx_lut_9": {
            /* TX gain table, index 9 */
            "pa_gain": 2,
            "mix_gain": 10,
            "rf_power": 14,
            "dig_gain": 0
        },
        "tx_lut_10": {
            /* TX gain table, index 10 */
            "pa_gain": 2,
            "mix_gain": 11,
            "rf_power": 16,
            "dig_gain": 0
        },
        "tx_lut_11": {
            /* TX gain table, index 11 */
            "pa_gain": 3,
            "mix_gain": 9,
            "rf_power": 20,
            "dig_gain": 0
        },
        "tx_lut_12": {
            /* TX gain table, index 12 */
            "pa_gain": 3,
            "mix_gain": 10,
            "rf_power": 23,
            "dig_gain": 0
        },
        "tx_lut_13": {
            /* TX gain table, index 13 */
            "pa_gain": 3,
            "mix_gain": 11,
            "rf_power": 25,
            "dig_gain": 0
        },
        "tx_lut_14": {
            /* TX gain table, index 14 */
            "pa_gain": 3,
            "mix_gain": 12,
            "rf_power": 26,
            "dig_gain": 0
        },
        "tx_lut_15": {
            /* TX gain table, index 15 */
            "pa_gain": 3,
            "mix_gain": 14,
            "rf_power": 27,
            "dig_gain": 0
        }
    },

    "gateway_conf": {
        /* change with default server address/ports, or overwrite in local_conf.json */
        "gateway_ID": "AA555A0000000000",
        /* Devices */
        "gps": true,
        "beacon": false,
        "monitor": false,
        "upstream": true,
        "downstream": true,
        "ghoststream": false,
        "radiostream": true,
        "statusstream": true,
        /* node server */
        "server_address": "127.0.0.1",
        "serv_port_up": 1680,
        "serv_port_down": 1681,
        /* node servers for poly packet server (max 4) */
        "servers":
        [ { "server_address": "127.0.0.1",
            "serv_port_up": 1680,
            "serv_port_down": 1681,
            "serv_enabled": true },
          { "server_address": "iot.semtech.com",
            "serv_port_up": 1680,
            "serv_port_down": 1680,
            "serv_enabled": true } ],
        /* adjust the following parameters for your network */
        "keepalive_interval": 10,
        "stat_interval": 30,
        "push_timeout_ms": 100,
        /* forward only valid packets */
        "forward_crc_valid": true,
        "forward_crc_error": false,
        "forward_crc_disabled": false,
        /* GPS configuration */
        "gps_tty_path": "/dev/ttyAMA0",
        "fake_gps": true,
        "ref_latitude": 10,
        "ref_longitude": 20,
        "ref_altitude": -1,
        /* Ghost configuration */
        "ghost_address": "127.0.0.1",
        "ghost_port": 1918,
        /* Monitor configuration */
        "monitor_address": "127.0.0.1",
        "monitor_port": 2008,
        "ssh_path": "/usr/bin/ssh",
        "ssh_port": 22,
        "http_port": 80,
        "ngrok_path": "/usr/bin/ngrok",
        "system_calls": ["df -m","free -h","uptime","who -a","uname -a"],
        /* Platform definition, put a asterix here for the system value, max 24 chars. */
        "platform": "*", 
        /* Email of gateway operator, max 40 chars*/
        "contact_email": "operator@gateway.tst", 
        /* Public description of this device, max 64 chars */
        "description": "Update me" 
        
           
    }
}

Node is sending data to ttn, but no data coming in at ttn console
Node is sending data to ttn, but no data coming in at ttn console
#2

Because there is a known issue.


(Waterbug) #3

thanks for replying. I understand I have to ignore the 'never seen' status on the ttn desktop. Does this mean that I cannot expect any info on data traffic on the desktop ttn ? I like to be certain to know if my gateway is working properly, so that I can start testing to connect nodes.

I especially am uncertain about this feedback
....
# PUSH_DATA acknowledged: 0.00%
### [DOWNSTREAM] ###
# PULL_DATA sent: 3 (0.00% acknowledged)
....


#4

What configuration files are you using? (global_conf.json and local_conf.json)
PM them if you do not want them to become public.


(Waterbug) #5

I appended global_conf.json and local_conf.json to the initial message


(Jose Marcelino) #6

You have an error in you local_conf.json, should be

"server_address": "router.eu.thethings.network"

Don't replace server_address, it's an attribute name.


(Waterbug) #7

thanks, looks like that was indeed the problem. output is now

##### 2017-03-20 21:29:16 GMT #####
### [UPSTREAM] ###
# RF packets received by concentrator: 1
# CRC_OK: 100.00%, CRC_FAIL: 0.00%, NO_CRC: 0.00%
# RF packets forwarded: 1 (23 bytes)
# PUSH_DATA datagrams sent: 2 (437 bytes)
# PUSH_DATA acknowledged: 100.00%
### [DOWNSTREAM] ###
# PULL_DATA sent: 3 (100.00% acknowledged)
# PULL_RESP(onse) datagrams received: 0 (0 bytes)
# RF packets sent to concentrator: 0 (0 bytes)
# TX errors: 0
### [GPS] ###
# Invalid gps time reference (age: 1490045356 sec)
# Manual GPS coordinates: latitude 0.00000, longitude 0.00000, altitude 0 m
##### END #####
INFO: [up] PUSH_ACK for server router.eu.thethings.network received in 37 ms
INFO: [down] for server router.eu.thethings.network PULL_ACK received in 35 ms
INFO: [up] PUSH_ACK for server router.eu.thethings.network received in 37 ms
INFO: [down] for server router.eu.thethings.network PULL_ACK received in 34 ms
INFO: [down] for server router.eu.thethings.network PULL_ACK received in 34 ms
INFO: [up] PUSH_ACK for server router.eu.thethings.network received in 37 ms

Status of gateway on my ttn desktop now changed to 'connected'. Great!


(Hylke Visser) #8