TTN NODE central

(Swallage) #37

Nice you are willing to help so quickly! Hope you are able to find something that helps. I understand you are able to program the Node on a different OS?


well… you can run the Arduino IDE on a different OS, mostly windows but also MAC… and Unbuntu.
Ubuntu is way behind… do a google search for for ubuntu and arduino

for the Sparkfun micro you have to update your boardfiles… but you can’t find them under Ubuntu

(Swallage) #39

I already updated the board file using this URL: and there they quote the board file link:
Then you can select Sparkfun Pro Micro and 8 MHz CPU

(Swallage) #40

BTW, I run the 1.8.5 Arduino, I think that is pretty much up to date.


sorry, had to leave just came back now.
yes that’s up to date, also your board file is ok
have to try it myself first before I comment more on this :wink:

(Swallage) #42

No problem! Thanks for letting me know. This evening I have other stuff to do, so tomorrow morning is the first time I can try stuff out again.


ok after some troubles it seems to work :roll_eyes:

UBUNTU 17.02
TheThingsNode 2.02

problem I found is that after compiling it changes port… so I compiled to see if everything was fine and then upload while holding reset button, as soon you see the programmer (set upload to verbose in preferences) searching for ports you let the resetbutton go and it find the right port automagically.

another possibilty is that your laptop doesn’t provide enough power so you can try it with an USB hub in between.

(Swallage) #44

Hi BoRRoZ, very encouraring that you managed to get it working. I will try it now.Thanks a lot.

(Swallage) #45

Yes, what you describe is actually happening on my laptop too: it changes port. Will check now with reset. Not sure which switch that is.

(Swallage) #46

@BoRRoZ Ok, I have been trying all sorts of “press reset”-scenarios, but was unable to to succeed. This ports switching seems to confuse the avrdude program. The best result I got was this one:

Found programmer: Id = “CATERIN”; type = S
Software Version = 1.0; No Hardware Version given.
Programmer supports auto addr increment.
Programmer supports buffered memory access with buffersize=128 bytes.

Programmer supports the following devices:
Device code: 0x44

avrdude: devcode selected: 0x44
avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 3.13s

avrdude: Device signature = 0x0d3f0d
avrdude: Expected signature for ATmega32U4 is 1E 95 87
Double check chip, or use -F to override this check.

But I was unable to write to the device. I also tried with directly using avrdude. Still no success.

(Swallage) #47

@BoRRoZ, I also followed the suggestion of the Sparkfun website: . It seems you have more time to access the bootloader, but still no success. Coming thursday I can test on Apple and Windows. This device is not really convenient to use with Arduino and Ubuntu. Weird that you were succesfull and I can’t manage to get it working.


My ‘solution’ from yesterday seems to be non consistent.

I just tried it again and it give me a bunch of java errors ???
So I tried an Arduino pro micro and got the same result.

I tried an Arduino nano and that worked fine.

Conclusion, a virtual port like on the 32U4 doesn’t work well with the current Ubuntu/Arduino IDE
Can’t do much about this myself.

(Swallage) #49

I think the method from Sparkfun for the Pro Micro is not as elegant as the normal Uno and others from Arduino family. The port switchting is really confusing and unstable.


that’s typical 32U4 behavior and not very well implemented under Ubuntu … virtual serial port works under windows but can also give sometimes problems.

(Badryan) #51

My TTN Kickstarter kit was:

  • a gateway
  • two Things Uno
  • one Things Node

My gateway works as expected, and so did one of the Arduinos. My other Arduino didn’t see the radio, i.e., the radio wasn’t responsive to commands via the serial connection. My Things Node had a broken radio, which only worked in a narrow temperature window.

Now I received exchange parts for those two broken devices. The new Arduino does the job, however, the new Things Node doesn’t show up as USB/COM when connected to a computer. So I’m still without a working Things Node.

That makes 3 out of 5 end devices faulty, in one way or another. Am I the only one with really bad luck? Or are we looking at a quality issue with the kit? Don’t get me wrong – this is not to moan about the Kickstarter campaign or the TTN crew. I think they’re doing a terrific job. I just want to check if I’m the only one experiencing weird hardware issues and have all odds against me…



Hi Boris,

I moved your question to this topic because it seems that your gateway is working and you’re having a problem with the nodes, and this is TTN NODE central

I think that what I read is normal behavior, a 32U4 connected to an usb port behaves different then a arduino with a dedicated onboard usb serial connection and sometimes it’s really annoying.
especially with an arduino IDE under linux.

hope I can guide you through in this topic

(Badryan) #53

I’m all ears. Funnily enough, the Things Node with the broken radio quite happily connected like an Arduino. I hope I don’t need a JTAG programmer or something…



but you have to open the the things node, remove batteries , remove 2 screws so you see this and the reset button (the one on the left on the PCB) is exposed.

  • I am a bit busy today (and tomorrow) so there is a big chance that I can’t respond/continue immediately

(Badryan) #55

I had pressed the reset button earlier, before, after or during connecting to USB - to no avail. I’m curious now. Take your time!


yes I forgot, at the beginning of this topic, in December you allready had this problem.
Last week we solved a similair problem with a simple ‘swap USB cable and port’ sounds stupid but worh a try :sunglasses: