TTN NODE central


(Badryan) #57

Haha! That was the broken radio. The USB thing is a new challenge!


(Deux Vis) #59

Not sure what you mean by “way behind”.

In terms of numbers of people using thta combination ? You should do a google search on Linux and arduino then, because ubuntu is just one flavor of that OS.


#60

Using a Dell Inspiron 17 (3721) laptop running Windows 10, I just successfully followed Johan Stokking’s excellent video https://www.youtube.com/watch?v=tapK6EINx1k after some false starts. Thanks to BoRRoZ here and Todd Cottle in the YouTube comments for helpful hints.
In the node, which arrived this week, I spent some time tugging at the board seeking to smoothly extricate it from the case like Stokking did in the video, before realizing I needed to get out my smallest Torx screwdriver to remove the two inside screws beneath the batteries after using a Phillips screwdriver to remove the two visible ones from outside the closed case.
And I needed to be careful under the tools menu to not only consistently ensure that Sparkfun Pro Micro was selected as the board but also to go to the Port option and select, in my case, the COM3 port since otherwise the Arduino IDE seemed by default to look on COM4. And also needed to be patient and wait till the sketches were fully done uploading rather than jump too quickly to the serial monitor. And when copying and pasting the payload function careful to copy just the same parts of the sketch that Johan copied.
After my earlier failed attempt the node’s light was chronically red. But after removing the board I was able to hit the reset button that BoRRoZ had helpfully pointed out as the one on the left when the Microchip radio is on the bottom (with the other button above the Microchip chip being the one that triggers immediate sending of sensor data), and then start fresh.
Good luck to those running other machines/OSs, etc.


#61

Note: the Sparkfun Pro Micro board (used as a basis for the TTN Node) has a reputation for troublesome USB access. I’ve encountered it as well. Swapping cables did the trick for me, for some it is using a USB hub. Check this link:

https://www.thethingsnetwork.org/docs/devices/node/troubleshooting.html


(Badryan) #62

Just a brief note that I fixed my ThingsNode USB connectivity issue.

I tried like twenty permutations of USB cables, USB ports and Windows/Mac computers. In the end, I resorted to a complete reinstall of the Arduino IDE on a Windows 10 machine, followed by the usual drivers and Arduino libraries, and an extra-short USB cable. That fixed it.


#63

Hi,

glad you didn’t gave up fast ! congrats… don’t even start trying to figure out ‘but why ??’ :sunglasses:


#65

A second node with the same setup also worked fine. But a third node has a steady red light; it has never been successfully recognized, has never specified a viable port.


The Things Node : new low power library development
(Dacom) #66

Is there anyone who can post the factory-default fuse-bit configuration for The Things Node. (so the lfuse, hfuse and efuse value). Can someone upload a screenshot showing the last few lines of the ArduinoIDE output while uploading the firmware to the device (please enable “upload debugging” in preferences first)


(Calum Muir) #67

Wondering if anyone can help. I recently tried to set up a things node but it would not connect to my universities gateway. The gateway is operational. I tried using older versions of the basic sketch but they did not work so I changed back to the most recent version. I then tried to update the firmware in my node using the guide:

but after the update when I upload the basic sketch the serial monitor stops after:

Light: 49
Temperature: 28.69 C
Temperature alert: No
Moving: No
Button pressed: No
Color: Black
USB connected: Yes
Battery voltage: 4724 MV
– TTN: STATUS

Does this mean I have bricked my node? I cannot find the node on the LoRaWAN development utility. I’m not sure what to do next