Unable tot delete application


(Walterdekok) #1

Hi,

I am trying tot remove an application from the console but I get a message saying the application could not be deleted. I see no reason why it cant be removed.

Best regards,
Walter


Applications are not fully deleted
#2

remove1

remove2

it’s working here … did you ’ confirmed by typing the ID ’ before pressing Delete ?


(Walterdekok) #3

Hi BoRRoZ,

Yes I have…

image

image

image

best regards,
Walter


#4

oeps… I don’t know now , have to ask
(only thing I can think of is that the backend has data ready for the application/node but not sure…)

@rish1 @laurens


(Laurens Slats) #5

Hi @Walterdekok,
Could you verify you have the proper rights to delete the application? (If you’re a collaborator of an application this is not always the case).

Please also check if an integration is enabled, such as the AWS one. This could be a cause as well.]


(Walterdekok) #6

Hi Laurens,

I have the rights to delete te application and there is no integration enabled.
There is one strange thing….

Under devices it says that there are 2 registered devices but in the devices overview there is ony one visible….

Beste regards,

Walter


(Flowsailer) #7

With me also two devices are indicated. But they are not available. Here is something in the database something is not correct. Since an admin probably has to delete the data by hand.


(Pankoz) #8

Good time of day to everybody!
Last days I’ve deleted several applications from the private TTN-environment, and then I couldn’t register any device under my last application.
Deleting was done by ttnctl tool, applications list showed only one application… But every time when I try to register device, I have an error message like:

INFO Using Application AppEUI=70B3D57ED0010CA7 AppID=firstpankozapp
INFO Discovering Handler… Handler=dev
INFO Connecting with Handler… Handler=localhost:1904
FATAL Could not register Device error=Could not set device on Handler: permission denied: Broker did not set device: permission denied: NetworkServer did not set device: permission denied: No “devices” rights to Application “thirdpankozapp”

As I can see, it says that app “thirdpankozapp” was not deleted. But at www.thethingsnetwork.org this app is not presented (having the same results when using “ttnctl applications list”).
Maybe anybody had the same issue?

P.S. Notice: all my apps had the same AppEUI. Can this be a reason of non-completed removing?


(Flowsailer) #9

I have the same problem.


(Pankoz) #10
  1. OK, let’s suppose that ApplicationID (not AppEUI!) is “a central key of TTN-universe”, and it is stored in AppServer DB even after deleting (for example, we need store it when having a big log of transmitted data to/from devices).
    But today I tried to create and delete application without attaching devices to it and without transmitting any data. Why TTN can’t delete such “empty” application completely, giving me ability to reuse the same ApplicationID later???
  2. Additionally, the Console allow me to attach one AppEUI to several Apps. Is it feature or bug? (recall - I’ve deleted 2 apps with equal AppEUIs, which was assigned to that apps from Console and then from ttnctl).

(Albert Gashi) #11

I had the same problem since a few days and did not find a solution.
I deleted my account and registered again.
But now i have the problem with my gateway, which i can’t register anymore.

So if you find a solution plz let me know, cause i’m sure i will have the problem again.

Best regards


(Ricardos) #12

Hi
I have the same problem.

Can’t delete an application and in Devices it shows that i have 3 devices registered. However when i click in devices none is shown (because I deleted them)

Anyone as a solution to how to delete an app that down’t want to be deleted.

I’ve deleted all integration (cayenne, database and ttnmapper)

thanks


(Zone11) #13

I have the same problems for about two weeks now.
I can’t delete old applications anymore and and deleted devices are counted but not listed anymore.
No integrations are active and all the affected applications are with the ttn-handler eu.

Ideas or a solutions is very appreciated

Best regards,
Christian


(Albert Gashi) #14

Hi ricardos

Til’ now i did not find a solution.


(Zone11) #15

Just got a mail from Eric@TTN, they identified an issue with device cache and applied a fix.
For me everything works as expected now.

  • Christian

(Albert Gashi) #16

Great, for me also. I had also the problem, that when i deleted a device from my application, it still was counted. Now i only see the device, which i have registered.

So everything works now fine for me.

Thanky you guys!