V3: No packets received from MQTT connected GW

I’m running into two issues:

  1. After installing the V3 stack I’ve added a gateway with an “Link” API key. The gateway is able to connect to the running stack on port 1882 without any issues and shows active in the console. However the packet counters stay zero and a test node is unable to join (no indication data is received).

  2. When I connect the gateway using UDP data is received in the application, the counters still are not incrementing and when a joining no response is sent but the log shows:

stack_1      |   WARN Finished unary call                      duration=755.268µs error=error:pkg/gatewayserver:schedule (failed to schedule) error_correlation_id=13713f56bde4495788c66c1473a7339a error_name=schedule error_namespace=pkg/gatewayserver grpc_code=Aborted grpc_method=ScheduleDownlink grpc_service=ttn.lorawan.v3.NsGs namespace=grpc request_id=01DTFRWK5V59AYFTAETJW39W83
stack_1      |   WARN All Gateway Servers failed to schedule downlink, skip downlink slot attempts=1 device_uid=testapp1.rm186-dev1 downlink_type=join-accept error_0=rpc error: code = Aborted desc = error:pkg/gatewayserver:schedule (failed to schedule) namespace=networkserver started_at=2019-11-24 22:35:33.433169294 +0000 UTC

A third issue?: The data ‘tab’ for neither gateway shows any data events. The MQTT connected one shows the MQTT connection being setup, but that is all.

Does anyone have any pointers on where to look?

I’m not familiar with this particular setup, so can’t say if they did something odd, but MQTT is a many-to-many architecture rather than a direct producer-consumer connection. So ordinarily it is possible to subscribe something else to the same topic(s) on the MQTT broker (such as the mosquitto_sub tool) and monitor traffic to and from the gateway - something that’s extremely useful in all sorts of debugging of MQTT-based LoRaWAN implementations.

That is not relevant for this case. I know what messages are being sent by the gateway (is in the output of the packet forwarder) and the gateway software uses the ttn-gateway-connector protocol which works with the V2 stack. From what I understood it should work with V3 as well.

For 1: the default setup of The Things Stack accepts v3 protos on port 1882/8882. The v2 protocol is accepted on 1881/8881. Try changing the ports.

For 2: You can try enabling debug logs by changing the log level to debug. If that doesn’t give enough information, please create an issue on Github.

For 3: Not sure about that one.

According to netstat there is nothing listening on port 1881/8881. Open ports are 1882, 1883, 1884, 1885, 1887 and 8882, 8883, 8884, 8885, 8887. Do I need to enable something somewhere?

EDIT: Never mind, added the mapping to the docker compose file and now there is a process listening.