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About the presenter 
Remko Welling is as a teacher Embedded Systems Engineering at the University of Applied Science 

HAN in Arnhem and has 29 years of experience in radio planning and radio network optimisation. His 

expertise is in many different digital and analogue radio communication technologies like Microwave 

links, GSM, UMTS, LTE, TETRA, and simulcast networks POCSAG and FLEX. He worked for both 

commercial and governmental organisations as senior RF network specialist and lead architect RF. 

Remko is the founder of RFSee. A small company initiative that he uses to expand and maintain his 

knowledge of modern digital radio networks. 

Remko has 20 years of experience in using Radio Mobile. He used Radio Mobile in both non-profit 

projects and networks as well as for professional and commercial studies. His knowledge and 

experience in the use of Radio Mobile can be found on his websites documenting Radio Mobile: 

http://radiomobile.pe1mew.nl and http://radiomobileonline.pe1mew.nl 

TTN-Apeldoorn 
TTN Apeldoorn started in 2016 as a community. Within 6 month they installed their first full-blown 

LoRaWAN gateway sponsored by Wireless Things1 as a pilot with the help of Kadaster Apeldoorn at 

an height of 65 meters. The pilot lasted almost 12 months before it was reinstalled for permanent 

operation. In 2017 the second gateway sponsored by INCAA, a local company in Apeldoorn, was 

installed in joint corporation of the local department of the Dutch association of Radio amateurs 

(VERON) at their repeater site. 

This initiative was then followed by a sponsoring of Apeldoorn-IT2 of 4 gateways. This completed our 

city wide coverage of TTN and made it also redundant.  

The TTN-Apeldoorn Community organises regular meetings for those who are interested in 

everything that is related to IoT. The meetings are on average attended by 20 to 30 visitors. Topics 

over the last years ware: LoRaWAN security, IoT Use cases, Hiber Space, GPS, projects building 

LoRaWAN nodes and single channel gateways, Particle sensor project for the Citizen science project 

of Apeldoorn In Data. Meetings are announced at Meetup: https://www.meetup.com/LoRa-

Network-in-Apeldoorn-Growing-Meetup/  

The TTN community in Apeldoorn is supported by many local companies. They contribute with 

knowledge and sponsoring to operate the TTN LoRaWAN network and at meetups for the community 

members. RFSee is one of the companies that planned and optimized the radio network in 

Apeldoorn. RFSee installed all gateways. Using drive testing the radio coverage was verified by RFSee. 

 

  

                                                           
1 http://www.wirelessthings.be/  
2 https://www.apeldoorn-it.nl/  
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Introduction 
Radio Planning is a continues process of planning, realisation, and verification. Depending on the 

approach, you either step in to the process at the planning or the realisation phase. At some point 

you want to know what coverage a gateway will deliver. This coverage can be verified by measuring 

the service using solutions like TTN Mapper or by simulation Radio Propagation. Using TTN Mapper is 

labour intensive while simulation using a computer is (relative) simple and can deliver accurate 

predictions. In Figure 1 end Figure 2 a strong correlation can be observed between simulation and 

measurement. 

In radio planning there are basically two options. The first is planning a radio network with clear 

objective in mind. The service is planned homogenously to be delivered in the target area. The 

second is opportunity driven. In this case a gateway is installed either on occasions where a location 

is offered or when a use case requires one or more gateways. For the Things network the last one is 

most applicable. 

 

Figure 1: Simulated coverage of a gateway of TTN Apeldoorn 

 

Figure 2: Coverage of a TTN Apeldoorn gateway using TTN Mapper. 
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After this workshop the participant will know about simulation of radio signal propagation, have 

basic knowledge of link budgets, and how to model a LoRaWAN gateway and node in the software 

you install on your own Windows laptop. 

This workshop will deliver a hands-on experience in simulating coverage of LoRaWAN gateways. It 

will not cover the complete cycle of the Radio Planning process. 

The workshop duration is 45 minutes. 

To participate in the workshop the participant requires a Windows laptop on which he can run the RF 

simulation software. The laptop shall have WiFi and a USB port.  

Any other OS is not supported during the workshop! 

Participants shall have intermediate knowledge of the LoRaWAN standard, antennas, and dB 

calculations. As a RF engineer you know about receiver sensitivity and antenna gain. 

This workshop is divided in to 3 parts:  

1. Installation of radio simulation software.  

2. Setup a Link budget and discuss the individual parts of the Link budget. This will result in 

building blocks to be used in Radio Mobile. 

3. Exercise the use of Radio Mobile, simulate the coverage of a LoRaWAN gateway and what 

effect changes in the link budget have when we change parameters. 
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About this document 
This document is using icons to indicate the priority or type of some information. The used icons are: 

 

Attention: Important information about the topic that will have significant effect. 

 

Learning objective: What we will learn  

 

Information: Additional information about the topic, helpful for the Worksop. 

 

 

 

 

 

 

Copyright 
This Workshop paper is part of Worksop radio planning at the Things network conference 

The workshop paper is free: You may redistribute it and/or modify it under the terms of a Creative  

Commons Attribution-NonCommercial 4.0 International License  

(http://creativecommons.org/licenses/by-nc/4.0/) by Remko Welling (http://rfsee.nl) E-mail: 

remko@rfsee.nl  

 

 

Disclaimer 
The Workshop Radio Planning is provided in the hope that it will be useful, but WITHOUT ANY 

WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR   

PURPOSE. 
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Part 1: Installation of the software 
In this part we will setup the software. The software we use is Radio Mobile from Roger Coudé. 

Roger holds the copyrights of the software. Radio Mobile is free of charge but not open source.  

Although commercial use is not prohibited, the author cannot be held responsible for its usage. 

Radio Mobile can be used as a local application or as a web service. In this workshop we use the local 

application because it will give better control over the parameters involved in simulation RF Signals. 

As soon as the fundamentals of radio propagation simulation are understood results from the web 

service can be interpreted. Finally, the web service only has a limited set of functionalities of the local 

application. 

The installation instructions follow a two-step approach: 

1. Download and unzip all files in the described structure. 

2. Run the program and verify settings. 

 

Radio Mobile is documented by Remko Welling (PE1MEW) at the following website 
http://radiomobile.pe1mew.nl.  Here you can find more tutorials and explanation if you 
want to learn more about Radio Mobile. 

 

Installation from memory stick (TTN Conference Workshop) 
You will receive a memory stick for installation during the workshop.  

Where the installation instructions point to a file to be downloaded from the internet, with the use 

of the memory stick, these files can be copied from the memory stick. 

All files for the installation can be found in folder (directory) “RadioMobile” on the memory stick. 

Radio Mobile is using geodatabases like terrain-height, clutter (Land cover), and topographical maps 

(OSM) to make calculations and visualisations. When no internet access is possible the previously 

cashed geodata can also be copied from the memory stick. This date can be copied from 

“RadioMobile\GeoData”. 

Installation from scratch (Clean install) 

 

In this paragraph we will learn how to install and configure Radio Mobile.  

 

This installation instruction is using the instructions at http://radiomobile.pe1mew.nl 

 

 Create folder”c:\RadioMobile” 

 

 In “RadioMobile” create the following folders and subfolders: 

• Data 

• GeoData 

o LandCover 

o OSM 

o SRTM 

 

https://twitter.com/ttnapeldoorn
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 Download “rmwcore.zip” from http://www.ve2dbe.com/download/download.html and place it 

in folder “c:\RadioMobile”. 

 

 Download the program in the language of your choice and place it in folder “c:\RadioMobile”. It 

is strongly adviced to use the English version. This is file “rmw1166eng.zip”. 

 

 Download “wmap.zip” from http://www.ve2dbe.com/download/wmap.zip and place it in folder 

“c:\RadioMobile”. 

 

 Unzip all files in the “c:\RadioMobile” folder. To unzip files you can use 7zip form https://www.7-

zip.org/  

The result of these steps is shown in Figure 3. 

 

Figure 3: files and folder structure after downloading and unzipping. 

To prevent Radio Mobile from using the REGISTRY of your computer create an empty file named 

“rmw.ini” in “c:\RadioMobile”. Radio Mobile will use this file to store its configuration.  

To finish the installation create a shortcut on your desktop to the file “rmweng.exe”. 

 

Further reading on the installation procedure at: 
http://radiomobile.pe1mew.nl/?Installation 
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Running Radio Mobile 
To start Radio Mobile open the program “rmweng.exe” as shown in Figure 4 or using the shortcut on 

your desktop. 

 

Figure 4: The executabele Radio Mobile. 

This will result in a new window: 

 

Figure 5: Radio Mobile without map. 

 

Configuring Radio Mobile 
Radio Mobile is using data sources from the internet. This data is downloaded and cached locally but 

need to be configured when you performed a clean install of Radio Mobile. 

In the case of this workshop Radio Mobile comes predefined from your memory stick but requires 

verification. This verification is done by the checklist that is similar for a clean install scenario. 

Internet options. 
 

 Go to “Options > Internet”. A window opens with various configurable items. See Figure 6. 
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Figure 6: Internet options; Proxy 

Proxy 

Not needed for the workshop. In case you are using a proxy server to access the internet use these 

options 

Web update 

Not needed for the workshop. Configure to meet your needs.  

SRTM 

Mandatory for the workshop.  See Figure 7. 

 Check “Download from internet if a file is not found on local path and keep local copy” 

 

 Local files path: Browse to the folder downloaded SRTM files shall be stored. This shall be 

“C:\RadioMobile\GeoData\SRTM”. 

 

 Internet ftp directory:  Chose “SRTM – Best data – Site 1” 
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Figure 7: Internet options: SRTM 

Land cover 

Mandatory for the workshop: See Figure 8. 

 Check “Download from internet if a file is not found on local path and keep local copy” 

 

 Local files path: Browse to the folder where downloaded Landcover files shall be stored. This 

shall be “C:\RadioMobile\GeoData\LandCover”. 

 

 Internet ftp directory:  Chose “Landcover – Site 1” 

 

Figure 8: Internet options; Land Cover 

OpenStreetMap 

Mandatory for the workshop: See Figure 9. 
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 Check “Download from internet if a file is not found on local path and keep local copy” 

 

 Local files path: Browse to the folder where downloaded OpenStreetMap files shall be stored. 

This shall be “C:\RadioMobile\GeoData\OSM”. 

 

 

Figure 9: Internet options; OpenStreetMap 

NationalMap 

Not needed for the workshop. Keep default settings.  

Toporama 

Not needed for the workshop. Keep default settings.  
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Map properties. 
Go to “File > Map properties” or press “F8”. A window opens with various configurable items. 

 In “Elevation data source” choose “SRTM” in the highest layer (See red box in Figure 10). Drive or 

path: Browse to the folder where downloaded SRTM files are stored.  

This shall be “c:\radiomobile\geodata\srtm”. 

 

Figure 10: Map properties, Set “Elevation data source” of map window. 

First use Radio Mobile 
Now we have configured the geodata sources that Radio Mobile uses, we can test if it works. 

 Go to “File > Map properties” or press “F8”. A window opens. In “Centre” we fill in at “Latitude”: 

52 (degrees) end at “Longitude”: 6 (degrees). See Figure 11. 

 

 When settings are complete click “Extract” and Radio Mobile will display terrain height like Figure 

12. 
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Figure 11: Map properties, Set centre coordinate of map window. 

 

Figure 12: Loaded and displayed terrain height. 
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Part 2: Parameters and building blocks. 
Before we can configure Radio Mobile we have to know we can structure our nodes and gateways in 

such a way that Radio Mobile can use them and the parameters we have to set to which values. 

 

In this paragraph we will learn how to setup a link budget and where to get the required 
information 

 
Radio Planning is using a radio propagation simulation tool like Radio Mobile to predict coverage. Our 

radio planning tool is a big calculator capable of performing one mathematical formula: The pathloss 

calculation. This pathloss calculation has more than 50 parameters that need to need to be set and 

tuned to get an accurate result. The following parameters are the most important parameters:  

• Frequency 

• Effective Radiated Power (Erp) 

• Antenna type, gain, radiation pattern 

• (effective) Height of the antenna 

above ground 

• Polarization 

• Surface Refractivity 

• Permittivity 

• Conductivity 

• Climate zone 

• Simulation variability 

• Time variability  

• Terrain irregularity 

• Attenuations 

 

This workshop delivers a template project that will set the most of these settings.  
The template project can be found in “RadioMobile\Data\TTNWorkshopTemplate”. 
Before use, make a copy of the template folder and rename it . 

 

Link budget 
According to Wikipedia: 

A link budget is an accounting of all of the gains and losses from the transmitter, through the 

medium (free space, cable, waveguide, fiber, etc.) to the receiver in a telecommunication system. 

It accounts for the attenuation of the transmitted signal due to propagation, as well as the 

antenna gains and feedline and other losses. Randomly varying channel gains such as fading are 

taken into account by adding some margin depending on the anticipated severity of its effects. The 

amount of margin required can be reduced by the use of mitigating techniques such as antenna 

diversity or frequency hopping. (Wikimedia, 2018) 

The purpose of our link budget is to determine the minimum signal level at which our node can reach 

the gateway.  

To save time during this workshop we have reduced the number of parameters we have to modify 

and set most of the general parameters for a usage with LoRaWAN . 

The parameters we need to adapt are related to our node (mote) and our gateway and are specific 

for our situation. In Radio Mobile a node or gateway is parametrized in “Systems” and “Units” who 

are combined in a “membership”. A system describes the RF parameters while the unit describes the 

geographical parameters. 

A link budget is created for an individual service in a specific environment. For example: Outdoor 

coverage for nodes using SF7 or outdoor coverages for nodes at SF12. 
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Radio Mobile System parameters 
A system describes the parameters of the receiver, transmitter, antenna (type and height) and the 

connection (cabling) between the receiver/transmitter (radio) and the antenna. This is visualized in 

Figure 13. 

 

Figure 13: Principle of building blocks. 

It is important to notice is that we identify the radio link from the infrastructure (gateway) to the 

node as downlink and the radio link from the node to the infrastructure as uplink. 

For the transmitter we specify: 

Parameter Unit Default value Description  

Transmit power dBm +21 The transmit power of the IMST IC880A (1) 

 dBm +14 Transmitter power of a node. 

 
For the receiver we specify: 

Parameter Unit Default value Description  

Receiver sensitivity dBm -126 (SF7) The minimum level at which the receiver can 
detect a signal correctly.  

 
For the antenna we specify:  

Parameter Unit Default value Description  

Antenna type - Omni Type of antenna 

Antenna gain dBi/dBd 0 Gain of the antenna compared to isotope (i) or 
dipole (d) 

Antenna height Meter 1,5 (node) 
45 (gateway) 

Height of the antenna above ground level. 
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Figure 14: Gateway characterised for SF12 in Systems . 

The following paragraphs provide background information on these parameters.  

Gateway characteristics. 

GATEWAY RECEIVER SENSITIVITY: A LoRaWAN gateway is using for reception the SX1301 digital 

baseband chip of Semtech in combination with the SX1257 or SX1255 Tx/Rx/ front-end. These chips 

have the following sensitivities associated with their SF that we specify for the receiver sensitivity of 

the gateway. .  

Modulation Signal level  

SF = 7  -126,5 dBm 

SF = 8  -129,0 dBm 

SF = 9  -131,5 dBm 

SF = 10  -134,0 dBm 

SF = 11  -136,5 dBm 

SF = 12 -139,5 dBm 

 
Semtech, SX1301 Datasheet: 

https://www.semtech.com/uploads/documents/sx1301.pdf 

GATEWAY TRANSMITTER POWER: The LoRaGateway we use in this workshop is a IMST IC880a 

concentrator board. This board is using the Semtech SX1257 Low Power Digital I and Q RF Multi-PHY 

Mode Transceiver. According to the specification of IMST this board can have the maximum TX 

power of: 

Max TX power unit 

+20  dBm 

 
IMST IC880A Datasheet:  

https://wireless-solutions.de/downloads/Radio-Modules/iC880A/iC880A_Datasheet_V1_0.pdf 
Semtech SX1257 datasheet: 

https://www.semtech.com/uploads/documents/DS_SX1257_V1.2.pdf 
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Meeting the ERP3 power limit from your regulator. 

Whenever you use the ISM-licenced frequency band restrictions will apply. These restrictions are:  

• Duty cycle restriction (which is not part of this workshop) and  

• Maximum radiated power. 

We use the Dutch example and use the restrictions as specified in the telecommunications law:  

“Regeling gebruik van frequentieruimte zonder vergunning en zonder meldingsplicht 2015, 

Bijlage 11: https://wetten.overheid.nl/BWBR0036378/2016-12-28”. 

Here it is stated that the maximum radiated power 25 mW e.r.p. is which equals +14 dBm. Please 

note that ERP specification uses a dipole antenna as a reference.  

When using a 5,1 dBi (isotrope!) antenna the actual antenna gain is 5,1 – 2,15 = 2,95 dBd. This is the 

value we will use. Now we can calculate the maximum transmitter power of our LoRaWAN gateway: 

ERP [dBm] 14,00  
Antenna gain [dBd] -2,95  
Cable attenuation [dB] 1,00 + 

Maximum TX power [dBm] 12,05 <- This value we use for our transmitter power! 
 

Node characteristics 

In our example we use the RFM95 LoRa radio. This radio is comparable to Semtech 

SX1276/SX1277/SX1278/SX1279. Please observe the differences in sensitivity between HopeRF and 

Semtech specification. We use HopeRF in our workshop. 

HopeRF RFM95: 
 

Modulation Signal level  

SF = 6  -121  dBm 

SF = 7  -126  dBm 

SF = 8  -129  dBm 

SF = 9  -132  dBm 

SF = 10  -135  dBm 

SF = 11  -137  dBm 

SF = 12 -139 dBm 
 

Semtech SX1276/77/78/79: 
 

Modulation Signal level  

SF = 6  -123  dBm 

SF = 7  -128  dBm 

SF = 8  -131  dBm 

SF = 9  -134  dBm 

SF = 10  -135  dBm 

SF = 11  -137  dBm 

SF = 12 -140 dBm 
 

 
HopeRF RFM95 datasheet: 

https://cdn.sparkfun.com/assets/learn_tutorials/8/0/4/RFM95_96_97_98W.pdf 
Semtech SX1276/77/78/79 datasheet: 

https://www.semtech.com/uploads/documents/DS_SX1276-7-8-9_W_APP_V5.pdf  

 

  

                                                           
3 Effective Radiated Power 
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ANTENNA PARAMETERS: The antenna is specified in: 

• Antenna type (to which is linked antenna gain and radiation pattern) 

• Antenna height in meters. 

• Additional losses of (internal) cabling. 

Gateway antennas 

For antennas the rule of thumb is: The, bigger, the better. Gateway antennas are antennas installed 

on buildings and towers and shall be installed free of obstructions so they can “look around freely”. 

In this workshop we assume this. In this workshop we can use the following antennas: 

 

Manufacturer Type Gain Note 

Mars antennas MA-WO850-5 860 5 dBi  

Sirio GP 868 C 868 3 dBi – 5.15 dBi  

Radio Mobile Dipole 0 dBd Reference  

 

Together with the antenna gain the radiation pattern is provided. The radiation pattern of the Sirio 

and Mars antenna are shown in Figure 15.  

   

Figure 15: Sirio GP 868 C 868 and Mars MA-WO850-5 antenna radiation pattern 

 

To use the antennas in Radio Mobile copy folder “RadioMobile\antenna” to 
“c:\RadioMobile\” 

 
To see radiation patterns in Radio Mobile go: “Tools > Antenna pattern viewer”. 

Mars antennas: https://mars-antennas.com/ 
Sirio: http://www.sirioantenne.it/en/products/cellular/gp-900-c-gp-901-c-gp-868-c  
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Node antennas 

Antennas on nodes are almost never capable to come even near the performance of the “full size 

brothers” on gateways. Good antenna design is very important for the range of a node. As antenna 

design is out of scope of this workshop we provide some practical examples of antennas that can be 

used and the gain of these antennas. The antennas give are visualised in Figure 16. 

Antenna type   Gain [dB] 

GP antenna   0,0 

Long duck    0,4 

Short duck   -2,8 

Helical      -1,1 

Chip antenna -2,5 

Puck antenna -3,5 
 

 

Figure 16: Node antennas 
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Additional losses. Additional losses are the losses caused by coax cables between the antenna and 

the gateway. This attenuation is highly dependent on the type of coax cable and the length of cable 

used. The following table shows 4 types of coax cable that are generally used. For each type the 

attenuation in dB per 100m is specified.  

Type dB/100m 

Ecoflex 10 12,5 

Ecoflex 15 8,6 

LMR400 12,8 

LMR600 2,5 

 
Please lookup the exact cable attenuation at the manufacturer.  

Radio Mobile Unit parameters 
The unit contains the geographical information of the location where the gateway or nod is located. 

Also we can set here icon of the unit that will presented on the maps. 

For the unit we specify: 

Parameter Unit Default value Description  

Location degrees - Coordinate of the unit. 

Icon - - Icon  

 

Link budget Margins 
Margins in the link budget are required to compensate for additional attenuation or loss of radio 

signals by the environment. The margins we will describe are: 

• Loss of signal due to multipath fading, 

• Loss of signal due to indoor penetration loss. 

Multipath fading 

All radio coverage is based on probability theory. Radio coverage at a specific location from a distant 

transmitter can be specified for a 50%, 90% or higher probability of successful communication. Radio 

coverage cannot be guaranteed 100% of the time. 

If we take no margin in the link budget for probability there is a 50% chance at the cell edge that 

reception is successful. By adding a fading margin we reduce the cell size and coverage, however we 

can state that the reliability of the served coverage increases by a higher probability. 

   

Figure 17: Higher probability results in smaller cell size 
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As a rule of thumb the following margins can be applied in the link budget t orepresent our service 

objectives. 

Margin over minimum RX 
level (dB) 

Coverage probability at the 
cell-edge (%) 

Coverage probability over the 
entire cell (%) 

0 50 77 

5 75 90 

7 84 96 

9 90 97 

12 95 99 

 

 

To compensate for 90% probability the sensitivity of the receiver is reduced with the 
margin. This means that for example at SF12, sensitivity is lowered from -139 to -130 dBm! 

 

Indoor penetration loss 

Radio signals that penetrate a building suffer from the attenuation by the building. The following 

table shows some values to indicate the severity of these attenuation losses.  

These values are arbitrary and need thorough verification. Use at your own risk!  

Measured Losses at Building floor UHF 

Basement -27 dB 

1st -23,5 dB 

3rd -20 dB 

5th -15 dB 

10th -3,5 dB 

14th +2 dB 

 

Link budget calculation 
With the important physical parameters know we can setup our link budget. The link budget is 

created for up- and downlink.  

Because 99% of LoRaWAN communication is uplink traffic we will simulate only uplink coverage.  

Because downlink erp power is stronger than uplink erp power we have link unbalance in favour of 

the gateway. This ensures that the gateway will be better capable of reaching the node than the 

node the gateway.  

Figure 18 shows the link budget for a LoRaWAN downlink. Here the Gateway transmit power is 

adapted to meet the +14 dBm erp limit. Please note that erp is expressed with an isotope as 

reference. To use a dipole add 2,15 dB to the antenna gain.  

https://twitter.com/ttnapeldoorn
mailto:remko@rfsee.nl


Workshop LoRaWAN Radio Planning - Simulating your network deployment. 

 

TTN-Apeldoorn - https://twitter.com/ttnapeldoorn  
Remko Welling, remko@rfsee.nl 

page 23 of 42 

 

 

Figure 18: Downlink link budget example 

Figure 19 shows the uplink link budget. We can see that the poor antenna performance of the nod 

results in a lower Erp. 

 

Figure 19: Uplink link budget example 

TxPower 11,15 dBm a

Cabletype RG214 d

Frequency [MHz] 800 5 c

Cable Length [m] 1 d

Cable loss -0,021 dBm e

AntennaGain 5 dBi + f

Eirp 16,129 dBi g

Clutter type

Penetration loss

Coverage probability [%] 90

Fast fading margin 8 dB h

AntennaGain -2 dBi i

Loss 0 j

Sensitivity SF7 -126 dBm k

Bitrate [bps] 5468 l

Planning level target -116 dBm m
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This workshop delivers a template project that contains building blocks for a generic node 
and gateway at SF7. 

Notes on the Default network 
The default network is set up for 868 MHz and for two services types: 

• Outdoor coverage with a probability of coverage of 90% and SF7 and SF12. 

When you want to use the project at a different frequency this shall be modified at: File > Network 

properties, Parameters button. Set here minimum and maximum frequency.  

The propagation is setup for Dutch Climate. For use in other environments see: 
http://radiomobile.pe1mew.nl/?The_program:File_menu:Network_prop.._Parameters or 

http://radiomobile.pe1mew.nl/?Calculations:ITM_model_propagation_settings  
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Part 3: Simulating exercises  
In this paragraph we will do exercises the get familiar with Radio Mobile.  We will first use the default 

network that is prepared for the workshop and then tailor it to our own needs.  

Exercise 1: Navigating through maps. 
 

 

In this paragraph we will learn the essentials of navigating through Radio Mobile. 
Create and adjust maps and save one. 

 

Modify map window properties or open a new one when none is opened. 

 Open a new map in: “file > Map properties” or click:   

 

 1: Enter the new centre coordinates of the map window. (See Figure 20) 

Latitude: 52,20568, Longitude: 5,975069  

 

 2: Enter the size of the map window in pixels. (See Figure 20) 

Width(pixels): 1000, Height(pixels): 1000 

 

 3: Enter the map height in km. (See Figure 20) 

Width will be proportional to the pixel dimensions. Height(km): 50,00 

 

 Display the new map: Click on button: “Extract” 

 

 

Figure 20: Modify map properties. 
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Figure 21: Result of modifying map properties 

Overlay a topographical map in the map window. 

 Open Merge pictures “Edit > Merge pictures” or click:   

 

 1: Select the topographical map. Check “Internet OpenStreetMap” 

 

 Display the modified map: Click on button: “Draw” 

 

 2: Accept the changes: Click “OK” 

 

 

Figure 22: Merge pictures over map. 
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Figure 23: Sure? pop-up 

 

Figure 24: Result of overlaid map. 

Zoom in or out on a map. 
 

 Click in the map on the location to which you wish to centre and zoom in to (see Figure 25). 

 

 Open a new map in “file > Map properties” or click:  

 

 1: Select the centre pointed at by the previous click in the map window Click button: “Use 

cursor position”. (see Figure 26) 

 

 2: Enter the map height in km. Height(km): 5,00 to zoom in or a bigger value than before to 

zoom-out. (see Figure 26) 

 

 Display the new map: Click on button: “Extract” (see Figure 26). 

 

 Again, overlay the topographical map: 

Do instruction: “Overlay a topographical map in the map window.”. 
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Figure 25: New centre by cursor in map window. 

 

Figure 26: Steps in map properties. 

Centre map on a unit. 

 Open map properties in “file > Map properties” or click:  

 

 1: Select the centre pointed at by the previous click in the map window Select a unit using the 

drop-down menu. (see Figure 27) 

 

 2: Enter the map height in km. (see Figure 27) 

Height(km): 5,00 

 

 Display the new map: Click on button: “Extract” (see Figure 27) 
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 Overlay again the topographical map.  

Do instruction: “Overlay a topographical map in the map window” (see paragraph before) 

 

 

Figure 27: Steps in map properties 

 

Figure 28: New zoomed map. 

Save picture of a map. 
Once you have the result of your simulation on the map you want to save the result for further use. 

 Make sure you have the map on top you want to save a picture of 

 

 Open: “File > Save Picure as…” 
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 Provide the name of the picture 

 

 Select the image type 

 

 Click save. 

 

It is advised to use the PNG format. This format is lossless compressed and capable of 
storing transparency.  

 

Exercise 2: Simulate a gateway in the default network. 
 

 

In this paragraph we will learn the essentials of simulating coverage in Radio Mobile. 

 
In this exercise we will simulate the (uplink) coverage of a gateway using “Network Style”. Network 

style presents in three colours the coverage.  

• When a bin is coloured green the predicted received signal is >= 3 dB stronger than the receiver 

threshold. 

• When a bin is coloured yellow the predicted received signal is between 3 dB stronger than the 

receiver threshold and 3 dB weaker. This shows where reception is less probable than 90%. 

• When a bin is coloured red the predicted received signal is < 3 dB weaker than the receiver 

threshold. This shows where there is no coverage. 

Network style thresholds can be configured in: File > network properties, “Style” button. See Figure 

29. 

 

Figure 29: Network style setting in Network properties. 
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Preparations 
 

 Open default network: File > Open networks and open “ttnconferenceworkhshoptemplate.net” 

 

 Make a copy of this network in a new folder “MyFirstNetwork” and give it a new name: 

Open: File > Save Network as…“  

Create a new project directory in “c:\RadioMobile\Data” 

Save in this new directory the network using the name “MyFirstNetwork.net” 

 

Open a new map “ 

 Modify map window properties or open a new one when none is opened.” And start working in 

the copied network. 

Simulate gateway at SF7 
 

 Open a new map centred at unit “Kadaster Apeldoorn” 

Use “Centre map on a unit.” exercise and select height: 50 km. 

Make sure you have checked “Force gray scale” in Map properties window. 

Click the “Draw” button. 

 

 Accept the new drawn window by checking “Keep in actual picture” and click “OK”. 

 

 Overlay a topographical map using “Overlay a topographical map in the map window.”. 

 

 In the “Operation” box check “Add” and  

click the “Draw” button.  

 

 Open the “Single Coverage” Open: Tools > Radio Coverage > Single Polar. 

 

 1: Select centre unit “Kadaster Apeldoorn”, Mobile unit: “Unit 1”, and network “LoRa 868 MHz 

SF7” (See Figure 30) 

 

 2: check “centre RX mobile TX” because we are simulating uplink (See Figure 30) 

 

 3: Plot type; check ”Fill Area”, and “Network Style” (See Figure 30) 

 

 4: check “use network antenna settings” (See Figure 30) 

 

 Click “Draw” button. 

 

 Accept the changes: Click “OK”  

You now have simulated the (uplink) coverage of a gateway that is receiving nodes at a SF7. (see 

Figure 31) 
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Figure 30: Settings Single polar plot 

 

Figure 31: Simulation result Single polar plot, Gateway Kadaster Apeldoorn at SF7 
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Simulate gateway at SF12 
 

 Overlay a topographical map using “Overlay a topographical map in the map window.”. 

 

 In the “Operation” box check “Add” and  

click the “Draw” button.  

 

 Open the “Single Coverage” Open: Tools > Radio Coverage > Single Polar. 

 

 1: Select centre unit “Kadaster Apeldoorn”, Mobile unit: “Unit 1”, and network “LoRa 868 MHz 

SF12” (See Figure 30) 

 

 2: check “centre RX mobile TX” because we are simulating uplink (See Figure 30) 

 

 3: Plot type; check ”Fill Area”, and “Network Style” (See Figure 30) 

 

 4: check “use network antenna settings” (See Figure 30) 

 

 Click “Draw” button. 

 

 Accept the changes: Click “OK”  

You now have simulated the (uplink) coverage of a gateway that is receiving nodes at a SF7. (see 

Figure 32) 

 

Figure 32: Simulation result Single polar plot, Gateway Kadaster Apeldoorn at SF12 
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Exercise 3: Manipulate your network 
 

 

In this paragraph we will learn how to add a gateway to a network. This method is equal 
to adding a node to the network. 

 

Add or modify a unit to the network 
We will setup and add a unit to the network. 

 Open a map at the location of your desire.  

At the workshop we will use the following coordinates: Lat: 52,18369 Long: 5,983754 (see Figure 

33). 

 
Figure 33: Centre of the created map 

 
Figure 34: Building selected where we will place a gateway. 

 

 We will now select the building as can be seen in Figure 34.  

 

 
 

 Open unit properties: File > Unit properties 

 

 1: “Place unit at cursor position” (see Figure 35) 

 

 2: give the unit a name. We use “Werkgebouw zuid” (see Figure 35) 

 

 3: Set label “transparent” (see Figure 35) 

 

 4: choose foreground colour of the label black (see Figure 35) 
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 klick OK (see Figure 35) 

 

Figure 35: Unit settings 

The result is shown on the map: a new gateway. See Figure 36. 

 

Figure 36: new unit 

Add unit to network and configure 

 

 Open Network properties: File > Network properties. 

 

 Click the “membership” button. 

 

 1: Select network “LoRa 868 MHz SF7”. We will add the new unit only to the SF7 network. (See 

Figure 37) 

 

 2: check our new unit “Werkgebouw zuid” to make him member of this network. (See Figure 37) 

 

 3: Choose the initial System type “gateway SF7 (90%)” We will change this later. (See Figure 37) 
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 4: set the initial antenna height to 12 meter. (See Figure 37) 

 

Figure 37: Network properties, membership. 

 Click the “Systems” button. 

Because we use different antenna we need to change type and antenna gain. Also we need to set 

power of our gateway. See Figure 38. 

 1: Select “System 10”, the name will change later. 

 

 2: choose the preset system “Gateway SF7 (90%)” from the drop down menu. 

 

 3: change the name of the system to “Werkgebouw zuid SF7 (90%)”  

The system name at (1) will change now too. 

 

 Set the power of the gateway to +14 dBm. 

Because we use a low gain antenna the power may go up a bit. 

Is this the right power setting? Calculate! 

 

 5: Choose the new antenna type “GP_868_C_868.ant” 

 

 6: set the antenna gain of this antenna: 0 dBd 

 

 7: set the antenna height for this gateway to 12 meter. 
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Figure 38: Network properties, Systems setings 

 Click the “membership” button. (see Figure 39) 

 

 1: Select system “Werkgebouw Zuid SF7 (90%)” 

 

 2: Check system at antenna height to 12 meter 

 

 

Figure 39: Network properties, membership, verification. 
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Simulate coverage 
You can now simulate the new gateway using: Simulate gateway at SF7. 

Exercise 4: Optional activities 
 

 

In this paragraph we will learn how to setup Radio Mobile to display RF coverage using a 
custom colour scheme. 

 

Set coverage plot to TTN Mapper colour scheme 
If you want to compare results of TTN Mapper you have to set Radio Mobile to the right colour 

scheme. The TTN Mapper colour scheme is given at Figure 40. 

 

Figure 40: TTN Mapper colour scheme 

Preparations. 

 

 Create a map using “centre unit” and overlay a topographical map. 

Setting a new colour scheme 

 

 Open the “Single Coverage” Open: Tools > Radio Coverage > Single Polar. 

 

 1: Check “Fill area” and check “Rainbow”. (see Figure 41) 

 

 2: Set threshold to “dBm”, From value to: -120.0 and to: -100.0. 

Leave “To” unchecked! (see Figure 41) 

 

 Click the “Color” button. (see Figure 41) 

A new window opens. (See Figure 42) 
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Figure 41: Settings Rainbow colour scheme 

 

 1: Select 6 form the drop-down menu. 

 

 2: Configure all colours per step; click on the button and choose the colour required. 

Make the colours as shown in Figure 42. 

 

 3: Save the colour scheme for future use.  

 

 Click OK to finish defining colour scheme. 
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Figure 42: Defining colours of the colour scheme 

 

 Now we can simulate coverage using the new colour scheme. 

 

 

Figure 43: RF Coverage in TTN-Mapper colour scheme 

  

https://twitter.com/ttnapeldoorn
mailto:remko@rfsee.nl


Workshop LoRaWAN Radio Planning - Simulating your network deployment. 

 

TTN-Apeldoorn - https://twitter.com/ttnapeldoorn  
Remko Welling, remko@rfsee.nl 

page 42 of 42 

 

Other Exercises 
With the skills and experience learned you now can continue in the exciting world of Radio Planning 

and Network Optimisation. 

To exercise your skills we propose the following exercises: 

1. [Beginner] Create a link budget for other SF than the ones in this workshop.  

For a instruction see the Radio Mobile website of PE1MEW: 

http://radiomobile.pe1mew.nl/?How_to:Linkbudgets  

2. [Beginner] experiment with height. 

Alter the antenna height of your gateway antenna to see the influence antenna height.  

3. [Beginner] experiment with antenna gain of your gateway. 

The antenna gain of your gateway will influence the uplink range of your gateway. What will 

be the effect on the downlink when we obey the ERP restrictions of the local regulator? 

4. [Expert] Create a link budget for indoor coverage.  

Do research on the internet for penetration loss of 900 MHz frequencies and setup a link 

budget that accounts for indoor penetration loss. 

5. [intermediate] Add extra gateway(s) to your network.  

When you have multiple gateways in your network you can create a combined coverage plot 

using Cartesian coverage. For a instruction see the Radio Mobile website of PE1MEW: 

http://radiomobile.pe1mew.nl/?How_to:Combined_Cartesian  

Further reading 
Radio Mobile is documented by Remko Welling (PE1MEW) who has delivered this workshop to you. 

You can find all information about Radio Mobile and Radio Mobile Online at: 

http://radiomobile.pe1mew.nl/ and http://radiomobileonline.pe1mew.nl/  

The RSGB published in 2006 an article about Radio Mobile: 

http://www.g3tvu.co.uk/Introduction_to_Radio_Mobile_RadCom_Oct06.pdf  

Radio Mobile has an active user group at Yahoo: 

https://groups.yahoo.com/neo/groups/Radio_Mobile_Deluxe/info  
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