Arduino MKR 1300 not connect at the Gateway to 1 km


(Manux25) #1

Hi everybody! I have been reading the forum and I not get somebody with the same issue than me.
I have 1 week trying to connect two arduino mkr 1300 wan to TTN (using OTAA) and the result is failed… the amazing is than I’m very close to the gateway (to 1 km distance), I’m from Norway, Oslo.
You can to see the location gateway and me (below link).
http://ttnmapper.org/colour-radar/?gateway=lilletorget&type=radar&hideothers=on

After 5 days I took my fipy board and setup to run like NanoGateway, then both boards get connect success (using OTAA) but the strange is the boards connect to the gateway ’ lilletorget’ and not at the nano gateway.
Then I making more tests when I turn off the nano gateway (fipy) the boards not get connect… but when the nano gateway is on, the boards connect success to TTN and send data (uplink), the downlink not work.
I took an image when the boards are connected and the boards has good RSSI (see below link)

I’m confuse… I am so close and the boards should to connect at the gateway ‘lilletorget’ without problem… but not… this need the nano gateway on to connect.

I hope somebody can to help me

Regards
Manux


(LoRaTracker) #2

So how close do you have to be to the Gateway for the connect to work ?


(Manux25) #3

I have to turn on the fipy gateway then both boards connect at the gateway ‘lilletorget’ the gateway ‘lilletorget’ has an distance 1 km, but when I turn off the fipy gateway then the boards not get connect to gateway ‘lilletorget’, the boards should connect without problem with gateway ‘lilletorget’

Note1: my fipy_gw has other gateway_id.
Note2: I have the devices in the apartament.


(Cslorabox) #4

Nodes do not connect “to” a gateway, they connect to a network through one or more gateways.

Which gateway is used depends on which is practically most advantageous (or at least seemingly so) at any given instant in time. Nothing is perfect, so it’s entirely possible for a nearby gateway to miss a packet at which point if a faraway gateway has heard it that may be elected for the reply. A moment later the nearby one could be used again…

Beyond the practicality that a gateway would only typically have timing information to be usable for a reply to an uplink packet which it had been one of the gateways to just hear, there’s no “state” of association between nodes and gateways, only between nodes and the network server.


(Manux25) #5

I see… but why I not get connect the boards (alone) at the network? I’m in the top floor 5th and the gateway more near to 1 km distance, then this should to help my boards to connect at the network correct?
Then when I use the fypi gateway in the apartament, this is helping my boards to connect at the network?


(Ud Lo Ra) #6

Check on the console where OTAA join succeeds. Maybe for some reason the far gateway is not able to let you join, but after joining on the NanoGateway (disclaimer: I do not know it, not sure it allows OTAA), then your packets are received by the other. And: did you try with ABP, at first?


(Cslorabox) #7

The “fipy” board does not appear capable of being a real gateway - it looks to have only a node class radio which could only listen on a single frequency and spreading factor at a time.

As a guess, what has happened is that you’ve hacked your node firmware to startup with its dynamic configuration settings defaulted to use only one uplink channel and spreading factor, specifically the single settings that your gateway supports.

But as soon as it does an OTAA join to TTN it is given a MAC command to set it to the normal 8-channel bandplan for your region, and quite likely a different spreading factor than your personal gateway is listening for. Once it starts using all those channels, your personal single channel gateway can either no longer hear it at all, or only hear it 1/8 of the time.

Single channel gateways are problematic…


(system) #8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.