BIG ESP32 / SX127x topic part 1


#189

Exactly the same error here.

README.md file at https://github.com/kersing/ESP-1ch-Gateway-v5.0 says:

ESP32 Specifics / untested features:

  • GATEWAYNODE : use gateway as sensor node
  • REPEATER

(Biohazard) #190

Hi,

To add some infos about power consumption, here are my last tests:

  • First I validated my hibernation mode sketch with only esp32 (esp-wroom-32 module alone). I could achieve 4.5µA.

  • Then I added a LoRa1276 (from NiceRF) module, based on sx1276 with every passives needed. I could measure the different modes (continuous receive, idle, sleep). The lowest power consumption was 1.76mA in hibernation + LoRa sleep.

In the sx127x datasheet you can find the power consumption in sleep of about 1 µA. But this is not the consumption of the entire module. Somes guys found same trouble with RFM95: the TCXO crystal isn’t switched off so it drains energy even when the LoRa chip is off.

I am currently playing with RTC IOs. I think I’ll use a GPIO controlled mosfet to power on/off the LoRa module (including crystal). You can set a pin to hold the state even in hibernation (only RTC GPIOs…), thus powering the LoRa module though the mosfet even in hibernation, so you can use RTC timer or interrupt from LoRa to wake the esp32.

In conclusion, you won’t beat these 1.76mA on the Heltec LoRa dev board.

My two cents.


(Knutella) #191

I’ve setup my first Lora system and i’m getting a maximum of 100m in a dense suburban environment with both antennas outdoors. Is this normal? how are people getting these huge ranges? I can get better range on a cheap walkie talkie

My equipment is based off two of these modules:

Aliexpress

I’m using the included antenna and setting my frequency to 915mhz in USA. I’m using a spreading factor of 12 of bandwidth of 7.8E3.

Any ideas?


(Richjdavies) #192

I had trouble with range too. First problem was that the aerial cable was provided open-circuit (must have snapped inside), so tried another one. Next problem I think is the actual aerial that came with my aliexpress order. I’m going to try to find an alternative.

Anyone found a way to get these Heltec (or TTGO) boards to have a better, longer range signal? Maybe there are other faulty components, but I’ve got no idea how to test …

I assume it is the Aerial - as that is black magic for me. The software seems to work, the Laird gateway I’m connecting to has a very good long range signal with other boards (got a Microchip dev board with built in aerial that I can get several-km range from), so it comes down to the problem being between the ESP32 and gateway for me…


#193

It is better/required to have the RF antenna connected when the board is powered on (and transmitting).
The RF transmitter needs a load to dissipate its power. Not sure if SX127x has any form of open antenna protection, or that open (unconnected) antenna may damage the (on-chip) RF circuitry.


(Irrlicht) #194

Could somebody post example code for sensors like DH11, DHT22, DS18B20 or BME280 please? Still struggling with my spaghetticode.


(Ldsrc2008) #195

Hi, I have followed your process and try to test it on my heltec esp32 OLED lora module, but I got an error on wpa.h, where should I locate this file?
following is the error message:

Arduino: 1.8.5 (Windows 8.1), Board: “Heltec_WIFI_LoRa_32, 80MHz, 921600”

In file included from C:\Users\Melody\Dropbox\Arduino_projects\libraries\ESP-sc-gway\ESP-sc-gway.ino:30:0:

sketch\ESP-sc-gway.h:250:28: fatal error: d:\arduino\wpa.h: No such file or directory

compilation terminated.

exit status 1
Error compiling for board Heltec_WIFI_LoRa_32.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


#196

In post 123, please re-read the info. It tells you how to delete this part of the code, and replace it with a definition that contains your own SSID


#197

Or you could create the file with contents. I used this construct to make sure I never accidentally put my WiFi keys on github.


(Ldsrc2008) #198

Thanks you…I saw the password part, but missed to delete the “if” part…


(Bluesensing) #199

Hi all,

did anyone do a deeper insight in integrated hall sensor of ESP32?

Any qualified links to resources?

g.


#200

(Bluesensing) #201


That’s what i searched 4

#203

@bluesensing - maybe this article clarify’s the subject a bit more
https://diyhacking.com/arduino-hall-effect-sensor-tutorial/


(Bluesensing) #204

ESP32 often seems to have a bigger antenna problem… how could this be solved? or tested… more discussion also here in a new fb group from Orleans/France: https://www.facebook.com/groups/776434259224739/ What are your experiences? reach?


(Richjdavies) #205

Thanks for the link bluesensing1 - don’t think I’d have found that in google - my experience - TTGO board - range 10m… maximum // Microchip board 15km and counting. Something is seriously wrong with all 3 of my TTGO’s in terms of the aerial.


#206

So I’ve asked this before almost a year ago on TTN, and back in November on the ESP32 forum. But I’m still looking for a LoRaWAN IDF component (so not an Arduino lib) I could use to drive the LoPy SX127x using SPI. The Lua RTOS project has an interesting component (but very strong coupled to the project), and PyCom uses a MicroPython fork and drivers, but I’m still looking for a clean LoRaWAN IDF component so I can use it within a FreeRTOS task to schedule messages.

Any pointers or thoughts are welcome.

Thanks,
Martijn


(Rmh78) #207

I have tried to use LMIC with FreeRTOS and ran into big timing issues. As soon as the Taskmanager is activated LMIC does not work in a stable way any more. So I am also very interested in a solution for RTOS.


(Verkehrsrot) #208

Yould you post your ESP32 hibernation code here, or give us a link to it?
I’m currently trying to lower the power consumption of my Heltec/TTGO board.


(Mouseclicker) #209

Hi, first of all Thank You for all your contributions. This is great source of information of tremendous value! recently my TTGO (black) board arrived. I used instructions and sketch of post #123 with the additional patch in hal.cpp: SPI.begin(5, 19, 27, 18)
Unfortunately I have only one device and no public gateway close to me. So I am not sure I will able to connect to TTN and TTN console still says “Never seen”.

But I am suprised that I never see a message “EV_JOINING”.
Serial monitor shows this
rst:0x1 (POWERON_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:956
load:0x40078000,len:0
load:0x40078000,len:13076
entry 0x40078ad0
Starting
Configuring EU frequencies
Packet queued
170256: EV_TXCOMPLETE (includes waiting for RX windows)
Packet queued
934310: EV_TXCOMPLETE (includes waiting for RX windows)
Packet queued

Is this normal behavior or is there something wrong?
Thanks!