Can´t join Device

Grettings people, I hit the wall after several attempts and reading different posts. I installed TTN indoor gateway and all seems to be OK (meaning I see it in a console as connected). And then I created the Application, which was fairly straightforward. Now then, I restarted Device (pretty much sealed vibration sensor) and could see this communication:


Nothing else afterwards (I was checking the page online). No confirmation from TTN nor Application. No sign of any data in Applications/Device/Data screen either. Just blank screens. I also did modify generated AppEUI to 01 01 01 01… as I saw this in the traffic dump. Status in Device Overview says “Never seen”. I reckon I can´t use ABP for not having possibility to set keys on sensor.
No luck so far. Any help would be greatly appreciated.Thank you all, Pavel.

For an OTAA device three things need to match between TTN and the node.

  1. The AppEUI
  2. The DevEUI
  3. The AppKey

1 and 2 are visible in the join request, the AppKey is secret. Did you either set the node to use the AppKey generated by TTN or enter the manufacturer AppKey into TTN?

Hey Jac, thank you for swift feedback. I used both AppEUI and DevEUI that I found in Join request. I cannot enter the key generated by TTN into device. It is pretty much sealed. Guess I am done for today as I need to reach out to device developer and ask for the AppKey. I do have bunch of ASCII from them but it doesn´t look like HEX code.

…and a proper AppEUI. The AppEUI of 0101010101010101 is bogus.

Hi there sir, well, I am newbie to this realm.
So you say the 010101… I can see in the screenshot above is just for Inicialization phase and would be replaced by real one in the log?

As you can see in the OTAA Join Request, the device is really using 0101010101010101. If you take some time to read the post I linked to (which I doubt you did in the two minutes between my post and your response) you’ll see that such is not a properly registered EUI-64.

If you cannot reprogram the AppEUI in the device, then just get your money back.

Might be worth trying to run that through a base64 decoder on the off chance they used that. If you get an error or the wrong size of result you know it’s not. If you get something plausible it might still not be it but could be worth trying.

1 Like

Yep, tried this one as well. Only 13 bytes …

Thank you for more insight. They can re-program it, I can´t. My part is to get the whole Thing connected with AWS and apparently I am learning new stuff along the road. Funfunfun…