Cannot login new account to v3 console

I had a TTN account that I decided to delete as it had a poorly conceived name. I deleted the devices/apps/gw and then the account.

I then successfully created a new TTN account using the previously used email address. I can successfully login to the V2 console. However I cannot complete the login to the v3 console at

The login partially completes and then I get an error “too many requests no user name available”.

This has all happened over the past 1 hour. Should I just be patient as the v3 system is not aware of my new account? Or is it something else? FYI I am in Canada.

Do you use the “Login with The Things ID” button? If not, that is the one to use, not the credentials one.

Yes I tried the Things ID. I get partially in, it asks for authorization regarding my email and then fails.


Maybe you want to have a look at this topic:
Seems there are still issues with logging in to V3. Let’s hope this can be fixed soon.

Thank-you I did read this. My issue seems to be slightly different. A different error message. But just in case I tried all the suggestions, clearing cache etc. I even used different completely computers with unrelated browsers.

Still nothing worked.

Still cannot login in to V3 console with a re-created v2 account.

I get a " Too many requests No username available".

Does anyone have any ideas?

What browser & OS are you using - names & exact version numbers please.

I have tried with Chrome Version 88.0.4324.190 (Official Build) (64-bit) on Windows 10 latest 64bit. IOS/safari (latest), and Windows 10/ Edge Version 88.0.705.81 (Official build) (64-bit).

Let me re-iterate I believe the error is the result of deleting my old V2 account and creating a new one but using the same email address. I have cleared caches, cookies, changed browsers, computers etc. I believe the issue is at v2/v3.

A brand new account unrelated to any of my working accounts works fine in v2 and v3 on all my computers.

Same here after deleting old account and create new one.
After that same as RockiesIOT got → “Too many requests No username available”.
Cleared cookies & cache. Used other computer. etc.
Still not allowed to login at Old v2 works great.

1 Like

Just curious, why did you delete the old account?

@laurens who can resolve this issue?

First I tried to migrate to v3 to see if it would work.
That worked out nice so ik decided to build up from scratch with a new account.
Therefore I deleted the devices, application, gateway and the account.
After the creation of a new account I couldn’t manage to logon on the eu1 server as descibed above.
The V2 server works fine and added the gateway again.

If I have to do some testing or give more information, no problem.

1 Like

Clearing cookies / cache for your primary web browser is very painful so I won’t suggest that.

Can you install another browser to give the new login a try? Or use a different computer?

For anyone finding this thread, you can delete devices, gateways & applications to clear out entries you don’t want, but you can’t reuse the id’s you gave those items again - NB, I’m not talking about EUI’s, just the id’s.

Thanks for the reply. I’ve tried the following combinations:
Linux Ubuntu 20 & Chrome, Win10 Surface & Edge, Win10 pc with Edge and Chrome and a Android Samsung smartphone with default browser.
All situations gives the same respond “Too many requests, no username available”

I also tried many browsers and computers/tablets. Same issue.

@RockiesIOT / @kleinewim

Could you submit an issue on our GitHub and provide as much information as possible? I will make sure it ends up with the right developers at our end.

If possible, also add the logs/error codes found in the DevTools of your browser.

2 posts were split to a new topic: Deleted account with gateway, can’t register gateway on new account

Hello, I have Login problems with an new account: