Cannot read payload Laird LoRa Gateway

Hello everyone, I’m working with LoRa Gateway and sensors from Laird (model rg191 and rs191 respectively)

I’m using TTN preset and TTN Forwarder package for the server. Gateway and sensor are connected-ish: I have frequent downlinks and uplinks, but can’t read the payload from uplinks.

From TTN console, application/traffic return uplink with payload “not provided”, while in gateway/traffic, I can see a 12 bytes payload which makes no sense if I decode according to Laird message protocol ( ideally, it should be 10 bytes, or 11)

The problem happened right away, I only followed the guidelines.

I have been stuck for 3 days, please help.

senor: Sensor’s docs
gateway : gateway’s docs

As the application data also claims “retry”: what does the first entry for this very same packet show you? (Another gateway might be faster, in which case the 2nd reception might be classified as a retry, but in which case you should also see the earlier reception.)

Also: what does the “trace” part in the gateway’s Traffic show?

The payload in the gateway’s Traffic page is the full LoRaWAN payload, including the LoRaWAN header and the MIC, which together are often already 13 bytes. However, you’re only getting 12 bytes, which makes me guess your node is not actually including any application payload at all. You can check using an online decoder.

Apparently the MIC is valid, so the keys you’re using are okay too, as otherwise TTN would not be able to show the packet in the application’s data at all. (The DevAddr alone is not enough, as that is not unique.)

Please read this to see what you need to do.

BTW, searching the forum would have saved you some time…

Hi kersing,
The post you mentioned was the the very first thing I tried: I changed the reading interval to 400 and “aggregate number”(number of readings before send an uplink) to 10, but it did not work. Uplinks and downlinks still happened at the same rate and dont gave me the payload.

About the Node-RED application, I’m talking to Laird support team to debug the app, it looked like the app was not connected to the LoRa gateway, hence could not assign RTC time to sensors?
Pic 1 suggests if there is a sensor connecting to the server, the payload will be displayed in the debug windows, but I see nothing, so the sensor is not connected to the server.
Green dot in “device subscription” suggests that credentials I use for the MQTT broker (the server) are correct. I also tried to have a separate MQTT client to reach the broker, and got some feedback (?) Pic 2, so the broker/TTN server actually exists.
My guess is Node-RED app couldn’t assign any RTC downlink, because no sensor sent activation subscription. Could it be sensors are not connected to the gateway, or gateway/ TTN server is not connected to the Node-RED app? Both of them look correct to me at this point.

And Kersing, I would like to ask you more about the maximum 10 confirmed uplinks/ day. Isn’t it quite limited that I can only do an uplink every 2.4 hours? Where can I read more about this policy? And what is the math behind the 4000 sec interval? My guess is the guy had the aggregate number of 2 or 3 (so it made 22.22 hr or 33.33 hr for 10 uplinks)

The Uplink I screenshot was the very first uplink once I rest the sensor, all uplinks had retry status. Ealier entries could be only join request and join acceptance, is that what you meant? I will provide trace of gateway’s traffic once I arrive to work tomorrow.

Full Node-RED flow:s4

That is because the sensor did not get the initial setup downlink packet.

In your previous message your are seeing application data. So the sensor is sends data which is received by the network. It not being received by Node-Red probably means your MQTT setup (in node red) is not accessing the same application. Check your node-red configuration.

For the MQTT command-line subscription, the correct topic is ‘+/devices/+/up’, you also need to supply username and password to connect.

The device ID you need to enter in rs1xx-demo-config.json is the name of the node as entered in the TTN console. So if you call the node ‘sensor1’, the file should be:
{"dev_ids":["sensor1"], "degreesFahrenheit": true}

Read this message.
BTW Lairdtech is aware of the issue with the confirmed uplinks, it will be fixed in a future firmware release.

Perhaps ask the author of that message?

Update: Problem solved,

It was the TTN app handler, I had eu handler while my Node-Red app used us MQTT broker.

Thank you all.

I had the same problem with my Laird LoRaWAN Gateway RG191 and the endnode RS1xx.
I mean the TTN app handler defined in the Application Overview is “ttn-handler-brazil” and the packet flowed to Node-Red only when I configured in the Node-Red for my endnode the MQTT Broker to “” ( ):