Can't get the Device EUI out of TTN Node


(Royduf) #1

Iám a newbie with TTN and programming in Arduino.
Tried 2 days on several computers with Arduino 1.8.5. to get my Device EUI. Did all the settings:

  • Board is “Sparkfun Pro Micro”
  • Processor "ATmega32U4 (3,3V, 8mhz)
  • Schets: TTN DeviceInfo (I replace with TTN_FP_EU868)

Node is installed with USB-cable and blinks sometimes blue.
I also did a Node reset 2 pushes (then a got first red and then green light)

Still I get after compiling the following message:

Arduino: 1.8.5 (Windows 7), Board:“SparkFun Pro Micro, ATmega32U4 (3.3V, 8 MHz)”

De schets gebruikt 6258 bytes (21%) programma-opslagruimte. Maximum is 28672 bytes.
Globale variabelen gebruiken 960 bytes (37%) van het dynamisch geheugen. Resteren 1600 bytes voor lokale variabelen. Maximum is 2560 bytes.
---->Kan op de geselecteerde poort geen board vinden. Controleer of u de correcte poort hebt geselecteerd. Indien deze correct is, druk dan op de resetknop van het board nadat u de upload hebt geïnitialiseerd<-----

In the Arduino 1.8.5 program the “port button” is inactive.
Do you know a solution?


#3
  • what you can try is this

set under File/preferences check ’ Show verbose output during ’ compilation

up1

start compiling… when you see the searching for com port you hit the reset button once.

up2

up3

then you start the serial monitor and set the speed to 57600


(Royduf) #4

Thanx you, I’am to try this tomorrow and let you know


(Royduf) #5

I tried your suggestion, but it doesn’t work.
Somehow I do something wrong or the node doesn’t work correct. Problem is still, can’t find “com1” by compeling and upload I see tig lines with: PORTS {} / {} => {}
Mededeling is:
“Kan op geselecteerde poort geen board vinden. Controleer of u de correcte poort hebt geselecteerd.”
But I can’t change the port, because “port button” is not activated.
Changing cable from USB-port doesn’t also not work.

Maybe there is a TTN-expert in the neighbourhood of Hilversum who wants to activate my TTN node? Thanxs!


#6

sended you a PM … I think you pushed the wrong button

x963
resetbutton TTN node


#9