Connecting Link Labs LL-BST-8 LoRaWAN gateway to TTN

Hi all,

I need some help connecting a new gateway…
It’ s the Model: LL-BST-8

Is there someone who can help me?

1 Like


I was planning to buy a LL-BST-8 as well. Did you manage to connect it to TTN? I would appreciate some advice.


Hi loswochos,

I have had some great tips from the guys in Rotterdam. But i haven’t had time to get into it.
The linklabs is able to connect with
But it looks like the backend is prioritary so it’s not clear to me whether or not i get it to connect to TTN.
I’m planning to have a look at it this weekend.

Kind regards,

Hi there. Link Labs is happy to support those who want to use LL-BST-8 (LW) on TTN. The first step is to get you the root password, so you can install whatever packages are needed on their. Please send me your gateway ID, which is accessible on the local webpage (plug into center Ethernet port and hit - admin/password). Email that ID to me at, and I’ll respond with the password.


1 Like

In order to install another service, you’d need to stop the Link Labs service:
supervisorctl stop llgw-msg_traf-svc
supervisorctl stop llgw-ui-svc
supervisorctl stop pkt_fwd

hi all,

brian helped me with getting access to my modem. can anyone help me install the ttn package forwarder?

1 Like

I’m at the same point. I’ve access but not sure what to do.

Was starting to follow the Raspberry PI instructions but stopped on the way as I’m not sure it will work.
Emery to you have insights if that will work?

You need to use the 3.1.0 version of the HAL.

that ins’t true, throught my little experience with LinkLabs Gateway, there is no space to install , even a small command like binary file

also, this Gateway, don’t have a datasheet, so don’t wast your time with this model.

for support, they tried to help us, but it seem they don’t have the necessary experience to assist us in our project

Hi Emery,

Is it possible that you provide me with a root access for my Linklab GW!



Sure thing. Email me at with your gateway ID (Starts with $) and I can hash out the root password for you.

@GMA I wouldn’t say that we don’t have the experience to assist you, it’s just not the business we are in. We sell LoRaWAN hardware only, as the software side is moving open source. If you email me with questions, I’ll do my best to help. But we’ve never run TTN on our gateway. It is the same hardware as other gateways, so it would be possible. It just will require work. I know of several others who are doing it without a problem.

1 Like

hi bryan,

could you then be so kind to connect me with these people…
so we can get together a complete manual and get over this fuss…
on your website you promote an outdoor closure which does connect to ttn.
can we use this configuration?

kind regards

YIPPIEEEE… got it working…FINALLY

In short:

  • Since I fucked up the original Debian Wheezy version I did a complete reinstall of the software but to a supported Linux version, I used Ubuntu 16.04 LTS
  • You then can install the gateway software from
  • BUT!!! make sure you use the OLD versions i.e.:
    • lora_gateway version 3.1.0
    • packet_forwarder version 2.1.0
  • The reason for this is that the LinkLabs uses an SPI over FDTI interface, BUT this is not anymore supported in the new versions of the gateway software.
  • Follow the instructions in the readme file of the lora_gateway package.

Some tips:

  • The board is a PC Engine GMBH board, CPU: AMD G series T40E, 1 GHz dual Bobcat core with 64 bit support, 32K data + 32K instruction + 512K L2 cache per core (see
  • You need a NULL modem cable to connect to the serial port for install/reinstall of the OS, connection settings are 115200, N-8-1
  • For installation follow instructions from the PC Engine GMBH info website (

So with the system running I can say that the LL-BST-8 gateway can run a LoRaWAN gateway however, all software has been superseded by new versions and unfortanunely these versions do NOT support anymore the setup of this device specifically to the LoRa concentrator board it has installed. If LinkLabs would provide a concentrator board that supports natively SPI instead of FDTI there would be no problem using this system. Since all current gateways are still a fancy LoRaWan concentrator/modem that connects via a serial interface to a simple PC board running a Linux version.

Regards, Dennis


Hello @emery02

thanks for your reply

believe me, we meted a lot of problem with LinkLabs Gateway, we sent a lot of email, we spoke for long period with LinkLabs support, but most of time, they look like they aren’t the propriety of this GW, we can’t find any documentions, or when we find it, it just 2 pages on their website.

I appreciate your availability to help us in our project, just we need a support for a little problem witch is the key of our project,
I will send you a private message, we can send you all our discussion with LinkLabs,; so you can understand the issue

thank you again

Hey guys,

I’ve got it working as well with much less effort.

I wrote down the notes in a wiki page. Should be 10minutes work to get it up and running. I’m basically reusing the installed packet forwarder and make sure the config are correct. Check it out


Link Labs has decided to temporarily reduce the cost of these gateways to $425

This is a good price for a fully integrated LoRaWAN gateway with WiFi:

Hi Christoph,

I have a LL-BST-8 gateway and RN2483. This worked until it appears Link Labs switched off their back end. Link labs advised to read your How To.

Before I attempt to work on the gateway do you have any pointers ??

I look forward to your reply.


Location: Market Harborough UK.

Should be straight forward, just read the HowTo I wrote down.


1 Like

hi @corck,
can you please suggest me how to convert the Link-Labs Gateway ID from the form: $xxx$0-0-000000-xxxxxxxxx
to the TTN form required by the config file you report in the guide?


I’ve tried to use the LL-BST-8 to run the examples coming from:

My goal is to run the util to sniff all the packets and do stats on them.

I’m running v3.1.0 of this software (available here to still have the FTDI support that is removed on versions coming after. We configure the use of FTDI using this patch:

All code compiles after installing the libmpsse but when I try to launch the ./util_pkt_logger I get the following errors:

That boils down to: loragw_pkt_logger: ERROR: failed to start the concentrator

I’ve tried using the instruction given by @dennisi but ./util_pkt_logger doesn’t seem to work. The instructions given by @corck : seems to work therefore I don’t think the board is damaged.

Are you familiar with this kind of errors?
What is the concentrator? Have you met this kind of errors before?

Best regards