Installing and using the V3 stack as a private service - I got stuck

I also ended up using that folder to get self signed certificates into the container, commented out all the sample certificate stuff in the .yml file and added them in the environment section of the stack

     TTN_LW_TLS_CERTIFICATE: /config/cert.pem
      TTN_LW_CA: /config/cert.peme
      TTN_LW_TLS_KEY: /config/key.pem

I suspect this is wildly insecure but I can log in to the system, create devices and gateways.

I have the same problem with ttn-lw-stack.yml. I tried placing this file in same directory as docker-compose.yml and also tried placing it in the created directory config and config/stack. Always I get the result “open /ttn-lw-stack.yml: no such file or directory”.

have you changed the path in the .yml? it should say open /config/ttn-lw-stack.yml
I have found that docker has a steep learning curve… good luck

Looking for The Things Stack feedback & beta testers

To keep on improving The Things Stack, we are looking for people who have experience with using the software and can provide us with some feedback on what parts of our Stack work as expected, what is above expectation and what is yet to be improved.

Every now and then we might also ask you to try out one of the new features we are about to deploy (no commitments required).

Interested? Please send me a dm with you email address and I will share with you some further information shortly.

Thanks for the tip. I was careful but not careful enough. The .yml config files are sensitive to columns also. It’s been working for awhile now. Another thing I learned is that while docker can help easily perform upgrades, I hadn’t kept the docker-compose.yml file up-to-date in sync with the releases. I had kept the original .yml file from about v3.2. I learned that a ttn-lw-stack.yml was introduced along the way.
Now looking at how to make a database backup before next upgrade.

I know you posted a long while back, but this response is for future generations, so that they spent less time caught up with config issues:

By default, The Things Stack listens on ports 1885 and 8885 inside Docker. To make localhost work both on your local machine and within the container, append the port to localhost and make sure port forwarding is enabled in your docker-compose.yml for that port.

You must also remove ports 80 and 443 from your The Things Stack Docker configuration. This is as per configuration guide

For anyone having trouble with setting up The Things Stack, I also highly recommend this very informative walkthrough by @benolayinka :

1 Like

Hi @kschiffer , one question, It is not clear to me in a private instance of TTS how to use the basic station protocol with a gateway, how would the part of the certificates be?

I don’t know about the specifics for basic station gateways. Maybe @KrishnaIyerEaswaran2 can help you out here.

There is another thread (currently unlisted due to some of the commentary) in which @KrishnaIyerEaswaran2 says he will get some “using a TTIG else where” docs sorted out. Which should get this query sorted.

Yes indeed. I’ll add documentation for that soon.