Issues connecting BasicStation to TTN

What are your motivations/purpose here - there are other easier/cheaper ways to get an SX1302 GW - plenty in the market now - and whilst a great ref design (I stared with the original SMTC SX1301 version years ago) are you looking to just get into LoRaWAN, get nodes up and running or planning to build your own GW’s or…? Several RPi/SX1302 builds available where you have a functional known good start point out of the box that you can then look to hack around if needed - once you have the basics nailed…

$420/€410/£365 ish (+taxes?) isnt a cheap entry point…

Just doing an evaluation for a potential project at work right now. We are considering deloying a lorawan network of gateways and nodes to collect data from environmental sensors studying climate change.

I didn’t really know where to start to be honest, lots of info out there but very disjointed and overwhelming for someone just starting out. Plus many products i looked at were unavailable, this is kind of what i could get at the time without really knowing too much about what to try.

Ok, good to know. A piece of advice if I may…… start with the purpose

Work on the method

Focus on what you need most and the way to get that

The gateways are then just a means to an end and enabler…if there are none you can already use in the area, community or an already deployed commercial network provider. There are plenty of gw providers out there who have done the heavy lifting and have gone through qualification and certification, so you don’t need to invest your valuable internal resource and can focus on where you plan to add value. By almeans do gws if that is what floats your boat but you don’t have to….grab some off the shelf….(btw I came at it from the other end…interested in getting networks up and doing gws….TTN community and private….then worked down stream from there driven by client needs and use cases, so have lots of (various) gws both off the shelf and self builds)

1 Like

Thanks for the advice. Do you have an off the shelf GW that you’d recommend?

It’s like you just asked on a car forum “do you have a car that you’d recommended”.

If you search ( :mag: ) the forum for “gateway recommend” you’ll find plenty of discussions, but mostly without any parameters (like indoor/outdoor, power, external antenna, internet connection etc), we’d just be guessing.

All that said, I think everyone should have a TTIG in their desk draw for those unpleasant debugging moments that come up where you need a known good gateway.


Sure, but Id probably get lots of suggestions. Maybe just opinions, but thats better than empty condescension.

Nick has followed a well trodden path of recommending use of Forum search…. A wealth of information recommendations and opinions…… often the best option where we do not have specifics on actual users defined needs. Also not empty as he recommended, and I would endorse, having a TTIG nearly by (though not on same bench!) to assist with basic node debugging.

If you follow what you have used and comments above and are intent on fiddling with the gw internals or looking to make enhancements/add features (temp monitoring, solar power, back up batteries, etc.) then you can narrow search to say RPi based gws of which there are many - dare I suggest search also? :wink: RAK and iMST make good start points in that space when searching….but there are many more. Perhaps a correction or note to Nick separately might be in order -not least as he is one of the most experienced on the Forum these days and likely a good source of help in the future, and I doubt he would be so inclined right now :man_shrugging: … just saying….

1 Like

You won’t get useful suggestions if you don’t provide some information along the lines Nick mentioned. However, let me suggest the most expensive brand I can think of with carrier grade gateways which require a monthly subscription to manage: Kerlink. Go for the more expensive outdoor units which can be deployed indoor as well so all bases are covered.

BTW, you will be spending at least twice the amount other equally capable gateways will set you back, however you don’t seem to care wether we recommend a Lamborghini or a Smart and we don’t have the information required to recommend a city car or a ridiculously expensive status symbol.

1 Like

This board is a USB-based reference design. You will need to configure Basics Station to expect a USB interface as the device name. So, please edit your station.conf by changing the SX1302_conf.device field in this line


"device": "usb:/dev/ttyACM0"

The prefix usb: identifies the device to be a USB device and /dev/ttyACM0 is the device path. You can read more about it in the docs.

1 Like

Wouldn’t it require the software to be build for USB as well?

No. This is a HAL configuration parameter and the corecell HAL can deal with both types at runtime.



Excellent to see the SX1302 HAL supports both in parallel. For the old(er) HAL it was a compile time option.

I have tried that, but it still fails to start the Lora concentrator.

[HAL:XDEB] [lgw_stop:1201] Note: LoRa concentrator was not started...

Can you post the full log file? This one line does not provide enough context. It looks like the HAL is complaining why it is being stopped without ever been started. In principle, stopping the HAL should be an idempotent function, always result in the same initial condition. So, I think this particular line does not bear much meaning.
What exactly is failing still?

Hello Bei,

Well I take it back - it appears to be working now with the USB enabled in the station.conf. When I tried this previously I was at work and it was failing - today I am trying this from home and it appears to be working. The capture is attached - I could attached a more verbose version is desired?

Initially, it says the concentrator didn’t start:

2022-10-12 13:10:35.143 [HAL:XDEB] [lgw_stop:1201] Note: LoRa concentrator was not started.

However, a little farther down you can see the USB is initialize and the concentrator starts up:

2022-10-12 13:10:35.160 [HAL:XDEB] [lgw_connect:1194] Note: success connecting the concentrator

I can also see that the GW is connecting on the network server side in TTN.

The issue I have is when I was trying this previously I was at work and I cannot connect to the Network Server so it didn’t even seem to get to the stage where the concentrator started. However, now that I am at home it seems to be working fine - this is obviously a difference in how the network security is configured at work vs at home. This is one thing that confuses me. Based on what I’ve read and some videos I’ve watched - I understood that since all requests are outgoing originated, there is no need to have these ports (8887, 443) opened. This is obviously not the case I guess since I cannot get it to connect at work. Or could there be something else going on??

Thanks a lot.
capture.txt (68.8 KB)

Thanks for the confirmation that you got it working.
Indeed corporate firewalls these days are becoming more tricky. I’ve seen instances of corporate firewalls where all TLS connections on ports other than 443 were rejected. However, most LNSs are configured to accept the gateway connections on a port which is not 443. Obviously, such firewalls are optimized for regular office applications, but for IoT/M2M applications this does not make much sense.

We are making an update soon to the TTS Cloud and TTS Community editions to allow our proxy to allow LoRa Basics Station connection via port 443.

If you are running TTS by yourself and you have a proxy in front, you can configure the proxy to forward the /router-info and /traffic/ routes on port 443 to 1887 of TTS.


This is brilliant! Thanks @KrishnaIyerEaswaran2

Fantastic Thanks. Is there a planned date for this update?
I ask because I am trying to find alternative methods of connecting, but with this change coming, I may not need to!

The feature will be merged in v3.22.2 so it will be available soon after.