Migrating "The Things Gateway" to V3 not using the CLI

I try to update my gateway to V3. I failed. Too many Terminal things that I cannot handle how it is shown. Maybe some tools are needed, which I haven’t. I removed my gateway V2 definition.

How can I update my physical device so that I can define my V3 gateway?

Best regards

It helps if you are more specific about what you tried and what fails. Are there any instructions you used? If so which. Are there any error messages displayed? If so which.

1 Like

You did not buy “The Things Gateway” from anyone here, so I’ve removed the implied imperative to assist you by some form of shopping based emotional blackmail.

The volunteers will be happy to assist you if you could tell us which model gateway you actually have, along with the information that Jac as asked for above.

Guys, be friendly, maybe I’m naive. I’ve bought regularly the TTN Gateway named “The Things Gateway TTN-001-868-1.0” and let it run for the idea to grow the network for free without using it myself. Had cost me about 300. Like a router for everyone. My knowledge isn’t that much about LoRa V3, but grows. It should be as simple like a router to install, configure, update and else.

A EUI is not known by me. I think that is the showstopper. I cannot remember that it was in V2.
So, where can I get this Gateway EUI. The Web told me to get it from the manufacturer or reseller. This is TTN. Sorry, Here I am.

I tried again and thus time it seems to work. EUI not needed however. Thank you.


Glad it works.

Had you tried forum search? You are not the first to try this and we’re repeating the same answers over and over. Nice for you to provide the connectivity, thank you very much for that. Keep in mind the forum moderators are helping people without any payment so our investment is certainly not less.

For others looking for a solution:
If you use The Things Kickstarter Gateway | The Things Stack for LoRaWAN
combined with Cannot connect new The Things Kickstarter Gateway to V3 - #5 by rbrightwell you should succeed. No EUI required.

1 Like
  1. is it now possible to update the Gateway to V3 ?
  2. I haven’t any Gateway-EUI, under V2 it was working and a EUI obviously not needed
  3. where I find the EUI ?

I kept only my account and deleted the V2 Gateway. Now I start anew.

Best regards

Directions here


Recommendation would be dont delete a gateway from V2 until ready on V3…but guess you didnt read/search forum 1st :wink:

1 Like

Hello Jeff,

thank you, it seems to work. I tried weeks ago but there the EUI stopped me out doing it.

Best regards