Nemeus NIS-UL – Ultrasonic sensor


(Habibraed) #22

I am using a new application with a different name but i am using a specific DEV EUI, APP EUI and a APP KEY provided by Nemeus.


#23

if you scroll back a bit I read it’s not the first time you encounter this.
how did you solve it a few months back ?

A DevAddr as assigned by TTN will always start with 0x26 or 0x27 , and for TTN the next bytes indicate other details such as the region; see https://www.thethingsnetwork.org/docs/lorawan/address-space.html , a manufacturer cannot assign those addresses.


(Floodnetwork) #24

You would have to make sure the AppEUI and AppKey are exactly as they were before since there’s no way to change them on the device. I expect the AppKey will be different each time it’s generated, but there seems to be an option to override it and paste in the old AppKey for that device.

Also make sure the sensor is properly reset to trigger a join. Setting the device to standby mode and back doesn’t trigger a join if it thinks it’s already joined. Using the magnet for 20 seconds will hardware reset it, triggering a join.


#25

tnx… I don’t own a device like that but I’ve read that you allready advised him about this in the past.


(Habibraed) #26

Thanks sir, I have thought about resetting it by holding the magnet for 20 sec, but won’t this reset the configuration also?, and unfortunately, these sensors were shipped configured and i don’t think we know how to reconfigure them again.


(Habibraed) #27

At that time, i think it was by re creating the app. but i am not sure


(Floodnetwork) #28

Hi @habibraed ,

Using hardware reset doesn’t clear the configuration of the device, but does reset the session keys. No other options cause a Join message to be sent, so this is the only choice except maybe leaving the battery out, but flash storage would survive this and supercapacitors can complicate the process.

You must make sure you get your keys correct in the application, but for a quick check you can see the join attempt in the gateway traffic console.

Ben


(Habibraed) #29

Hi Ben, thanks so much for your help. It finally worked…
What i did is i let the newly created app generate the Dev EUI, at that moment i could see the join attempt in he gateway traffic and i could see that it has failed, then i manually modified the Dev EUI back to the sensors specific, the join was successful and the app worked.


(Habibraed) #30

I just have a quick question regarding the coverage, it seems that the sensor only work when it is extremly close to the gateway, i have tested the battery level and it looks fine.
I have contacted nemeus regarding this, and they send us a few models for an external antenna, but their seems no where to connect a SMA connecter on the PCB once i opened the sensor, is their some sort of modification needs to be done ?

Thanks


(Floodnetwork) #31

@habibraed great news that you are back online!

We have had no range problems with the NIS-UL like that you describe. The external antenna model is currently being tested by a client and comes with a bulkhead SMA connector. The other versions I assume have a PCB or ceramic antenna but have achieved several km range without problems. Perhaps you have a faulty device? Is it an 868MHz model? Also be sure your gateway is multi-channel or you’ll be missing many messages.


(Habibraed) #32

Hi Ben,
Thanks again, We have a multitech outdoor unit, and i think all chanels are enabled, or atleast when i ran the ttn packet forwarder script i think it showed that.

and yes we have the 868MHz model